Constant re-locking after update to 1.13.1 [fixed in 1.13.2]

2

Comments

  • edited December 2018

    @brenty Sorry I didn't search more to find this thread. :| Thanks for merging. I rebooted and I thought it seemed to help, but I'm still finding that I look up every once in a while to find the toolbar locked when I don't expect it to be. Thanks.

  • edited December 2018

    I spoke too early. The Chrome extension is back to locking up. I locked my computer when I had to walk away, and after returning it's back to locking up. As written earlier this is after removing and re-installing the extension. I unlocked it when I returned, hoping it is fixed and will remain unlocked but it's back to locking up.

  • brentybrenty

    Team Member
    edited December 2018

    I began to follow the route of the new profile, and found that it created a new browser window without the same extensions, requiring I add the extensions and login anew.

    @chazzunokuthunuchtec: That was exactly the point. We're trying to narrow down if you still have the issue with only a fresh copy of 1Password X.

    Seeing what it would require (that the effort would be about the same as starting over) I stopped the new profile process, and closed that new window, removed the second profile, removed the 1Password X extension, cleared cache and cookies, and re-added the 1Password X extension, and logged in. It has not yet logged me off and it's been about two hours (used to log me off within 5 minutes). For now it seems fixed in both Chrome and Firefox. Not sure how this fixed it (what's different) but it does seem to have cleared this up.

    I didn't want you to have to do that if it ended up not even helping, hence the test, but I'm glad to hear that did the trick for you too. :)

    Edit: I just saw your post on the new page. If you're still having trouble please try a new profile like I suggested earlier.

  • brentybrenty

    Team Member
    edited December 2018

    @allynwstone: No worries. Thanks for getting back to me! Keep an eye on it for a bit, and if it is still locking when it isn't supposed to (your OS isn't being locked, your browser isn't being closed, and the appropriate time for auto-lock hasn't passed) please share any errors in your background console logs from 1Password X:

    Chrome:

    1. Open Chrome and go to chrome://extensions/
    2. Under 1Password X, click "background page"
    3. Click "Debug" underneath "1Password X - Password Manager"
    4. Select the "Console" tab
    5. Unlock 1Password X
    6. Copy everything in the Console and save it to a text file

    Firefox:

    1. Open Firefox and go to about:debugging#addons
    2. Select "Enable add-on debugging"
    3. Click "Debug" underneath "1Password X - Password Manager"
    4. With the console open, unlock 1Password and wait for it to lock unexpectedly again
    5. Save the logs that appear in the console
  • brentybrenty

    Team Member

    @runamonk: Thanks for the update! Glad that helped you as well. :chuffed:

  • brentybrenty

    Team Member

    @mtoomajian: Please make sure that you complete any pending updates in the browser and restart your computer. Let me know how it goes.

  • Restarting Chrome 68 seems to have resolved the problem for me as well. Hopefully this was a one-off accident and future updates are smoother!

  • brentybrenty

    Team Member

    Agreed. Glad to hear that helped. :chuffed:

  • edited December 2018

    @brenty there is nothing called "background page" - I even clicked on the "Details" button...

    FYI - I tried with 1Password locked and unlocked to see if something would be different.

  • @allynwstone It's hidden under the "Developer mode" toggle, which for me shows up in the upper right corner of the blue Extensions bar (I don't know if I did anything special to have it show up). If you enable developer mode, "background page" shows up under the "Inspect views" section. In Details view, it's between the "Size" and "Permissions" sections, at least on Chrome 68.

  • @c__ thanks very much. I feel like a moron. I've got the background page now thanks to the developer mode toggle, but I am not sure I've got quite the right information from the console in the text file. @brenty what am I supposed to do with that file?

    Thanks.

  • edited December 2018

    Restarting Chrome and even rebooting did not help the situation. I decided to uninstall then re-install the 1Password X Chrome extension. I have the lock timeout set to 999 minutes, and it's been running all day without locking. I think it's fixed.

  • Hm, I may have spoken too soon as well. It started constantly relocking again today. Chrome's DevTools console shows locking at 10:05:31, 10:21:46, 10:29:12, 10:30:13, 11:19:05, 12:10:59, 12:20:13, 13:37:19, 13:37:25, 13:40:44, and 13:49:47 (all Pacific time). None of these correspond to a sleep, screen lock, or (obviously) 999 minute timeout lock; all are spurious. :'(

  • SerinaSerina
    edited December 2018

    I have been having the same issue ever since the last update. Constant locking while I'm working with no rhyme or reason. I've tried closing all chrome windows and then restarting them and that only helps temporarily because the locking starts up again. I have also uninstalled and reinstalled 1password X chrome extension and the issue still persists. This is driving me insane. PLEASE put out a fix.

  • brentybrenty

    Team Member
    edited December 2018

    @allynwstone: You're right. Sorry about that. I've left Developer mode on myself and forgot that needs to be enabled first. :blush: Please send the logs to [email protected] and then let me know the Support ID you receive. In the mean time, try reinstalling the extension to see if that resolves it for you.

  • brentybrenty

    Team Member

    @mtoomajian: Thanks for the update! I'm glad to hear that helped. :)

  • Did a bunch of testing. Here's some detail:

    • Regardless of the value in "Lock after system is idle for," the idle lock time is 1 minute
    • All of the following applies to version 1.13.1 of 1Password X

    The idle timeout bug occurs in the following browsers:
    1. Chromium Version 71.0.3578.80 (Official Build) Built on Ubuntu , running on Ubuntu 18.04 (64-bit)
    2. Chromium Version 71.0.3578.98 (Official Build) snap (64-bit), running on Ubuntu 18.04 (64-bit)

    The bug does NOT occur in the following browsers:
    1. Version 73.0.3656.0 (Official Build) canary (64-bit) on Windows 10 Pro 10.0.17134 Build 17134
    2. Chrome Version 71.0.3578.98 (Official Build) (64-bit) on Windows 10 Pro 10.0.17134 Build 17134
    3. Mozilla Firefox for Ubuntu canonical - 1.0 64.0 (64-bit) on Ubuntu 18.04 (64-bit)

    Of course there are surely factors I missed. Of particular curiosity is the difference between Chromium 71.0.3578.98 and Chrome 71.0.3578.98.

    It appears that the problem has been solved in the 1.14.1 beta of 1Password X, though I only tested it once.

    This is a snapshot of the debug output with the idle lock time set to 10 minutes, and no other lock triggers (screen lock, etc.). I allowed it to sit idle long enough to trigger the lock, then entered the key to unlock, then allowed it to lock again. This demonstrates that the elapsed time was substantially less than 10 minutes. Of course, I have no idea if the last couple messages are related to this bug or not.

    crypto tests: 395.3271484375ms
    background.js:9 PBES2g-HS256(100000): 75.3359375ms
    background.js:9 PBES2g-HS256(100000): 59.432861328125ms
    background.js:31 [OP] Locked at Sun Dec 30 2018 17:05:59 GMT-0700 (Mountain Standard Time)
    background.js:31 [OP] Locked at Sun Dec 30 2018 17:06:07 GMT-0700 (Mountain Standard Time)
    background.js:9 PBES2g-HS256(100000): 61.39794921875ms
    background.js:9 PBES2g-HS256(100000): 69.787109375ms
    background.js:31 [OP] Locked at Sun Dec 30 2018 17:07:32 GMT-0700 (Mountain Standard Time)
    background.js:31 [OP] Locked at Sun Dec 30 2018 17:07:32 GMT-0700 (Mountain Standard Time)
    2background.js:31 [OP] Locked at Sun Dec 30 2018 17:07:37 GMT-0700 (Mountain Standard Time)
    _generated_background_page.html:1 Unchecked runtime.lastError while running contextMenus.create: Cannot create item with
    duplicate id settings
    at p.addItems.e [as addItems] (chrome-extension://aeblfdkhhhdcdjpifhhbdiojplfjncoa/background/background.js:31:181024)
    at chrome.contextMenus.removeAll (chrome-extension://aeblfdkhhhdcdjpifhhbdiojplfjncoa/background/background.js:31:180969)

  • brentybrenty

    Team Member

    @BSerlIfE: Aha. I hate to ask for more after you provided so much detail already, but have you tried reinstalling 1Password X in the browser/OS environments where you're still having trouble? It may be that some settings migrated poorly when updating to 1.13.1 originally, but were corrected on the beta channel when updating again to 1.14.1, and installing a fresh copy of of 1.13.1 might resolve the issue with, say, Chrome on Ubuntu.

  • @brenty I removed 1.14.1 and reinstalled 1.13.1 on Chromium snap on Ubuntu 18.04. The bug returned. How long does it take for a beta (e.g. 1.14.1) to be released as stable? I don't mind using this particular beta, though, I'm just curious.

  • I just discovered that it doesn't work correctly in Firefox. My earlier test must have not been done correctly. So it seems that it's across the board on Ubuntu, except for the 1.14.1 beta.

  • @brenty I unintstalled 1PasswordX and tried a clean install after a reboot... no luck.

    You have so much data from other users reporting the same issue and I am so uncertain about that file - is it really even necessary for me to provide that at this point to prove that there is clearly an issue? I am on Chrome on Mac OS.

  • I see the same issue on my Windows 10 and macOS 10.14 machines, both running Chrome 71.

    Windows 10 was actually a fresh install of both Chrome and 1Password. On macOS, it all started after upgrade to 1.13.1 but since then I've uninstalled and reinstalled a fresh 1Password X and that didn't help.

    Restarting Chrome helps for some time but then the issue begins to manifest itself again.

  • I have now discovered that the problem is present on 1.14.1 as well. Pretty much a universal issue on Ubuntu. About to give up on 1Password or Ubuntu or both. It's so frustrating to use an OS that gets second-rate treatment.

  • ag_sebastianag_sebastian 1Password Alumni

    Hey folks, first of all, Happy New Year! :)

    @GreyTeardrop, @allynwstone, @BSerlIfE (thanks for all the investigation!) and the others, I wanted to keep you updated on the issue. We believe a recent change in the lock behavior is the culprit

    On Mac and Windows, 1Password will lock when your device locks – not just when it goes to sleep {707}

    Even though this change was made to improve your 1Password X experience, it seems like 1Password X is now too eager to lock itself. We're working on a fix and hope to have it ready in the next update. I can't make any promises when that'll happen, but we'll keep you updated.

  • BSerlIfEBSerlIfE
    edited January 1

    @ag_sebastian thanks for the update!

    ... and do you guys ever take a break? :)

  • @ag_sebastian agreed - thanks so much. Happy New Year!

  • @BSerlIfE It's not just Ubuntu

    @ag_sebastian Thanks for the update! Please keep us posted!

  • beyerbeyer

    Team Member

    Hey everyone!

    We've reverted some of the changes we made to 1Password X locking in our latest 1.14.1 beta which should return everything to normal. If you'd like to grab the beta, you can follow Dave's instructions.

    Since there were only a couple of bug fixes in this beta release, I'll work on getting this moved to the stable channel within the next day or so.

    Happy New Year!

    Beyer

  • Had the same issue, will give 1.14.1 beta a try :+1:

  • beyerbeyer

    Team Member

    Please let us know if the beta works better for you @tqla! Thanks!

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file