How to use 1password 7.2.4 with Safari (using Mojave)? No extension needed? Not working...

When I try installing the 1password extension (either from Safari or 1Password directly), it installs an older version (version 4) which doesn't work.

Then I saw there was an article stating that Mojave no longer requires an extension, and 1password is supposed to work automatically without it. So I therefore uninstalled the extension to see if that would help. However, when I visit a website there is no option to fill in any passwords, and I have to open the vault separately to do so.

How is the seamless use of 1password supported to work with Safari?

Comments

  • I probably have the same problem... I downloaded a new copy of 7.2.4 on my new MacAir. It loaded OK; shows the license OK; opens OK; but will not open a login site. I've compared all options under preferences with my version on my iMac and all seem the same. I tried downloading another safari browser extension and got the message that the extension was already loaded. What is happening? Thanks

  • dancodanco Senior Member Community Moderator

    @4zogs It's not true that 1PW7 on Mojave no longer requires an extension. Rather, it no longer requires a separately installed extension. The extension is now part of the program itself (due to changes by Apple). You should have an extension with the same version number as the program, which is 7.2.4. This should be in your Extensions and should be enabled. If it's not enabled, then enable it. If it's not present because of your having removed it, then quit 1PW completely (using ctrl=option-cmd-Q), trash it and reinstall it. That should work.

    @PWChinook Check Preferences > Extensions and see if it is present and enabled. If not, follow my advice above, but if it is there and enabled and still not working someone else will have to advise you.

  • I must be blind! I can’t find Extensions under Preferences! I can find Install Browser Extensions under 1Password7 but that just takes me to the website that would normally download Extensions...

  • dancodanco Senior Member Community Moderator

    I may not have been clear enough. It is Safari > Preferences > Extensions you need to look at. I guess that because I just said Preferences you were looking at 1PW's preferences.

  • So I think I figured it out - instead of using the 1Password extension icon in the Safari browser toolbar, I am instead clicking the 1Password icon that is in my computer toolbar instead (near my Wifi and Battery icons) to find and fill the passwords. I think that's it?

  • 4zogs4zogs
    edited December 2018

    @danco - thank you. This morning the correct extension is showing up and working in Safari as well. Perhaps the hard reboot of my laptop helped. It actually wouldn't wake yesterday and I had to force start it.

  • LarsLars Junior Member

    Team Member

    @4zogs - sorry to be late to this one; from my reading of it, it sounds like you're OK now? Let us know if that's not the case.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file