1Password Stopped Prompting to save new password

Here recently, 1Password has stopped asking to save passwords on any website. For instance, in signing up here, I used the Chrome browser extension (which otherwise works terrific) to create a password. After submitting the form it did not suggest to save the form – this is consistent with any other website. I opened preferences and cleared out any entries that were "excluded" in autosave even though there were just two previously. Both checkmarks on the "Browsers" tab are checked. Further, these are sites that I know I haven't checked the "don't suggest to save again" box when it did prompt. I think I have only done that a time or two ever anyway.

Any suggestions on what might be going wrong here?


1Password Version: 7.2.4
Extension Version: 4.7.3.90
OS Version: 10.14.2
Sync Type: iCloud

Comments

  • rudyrudy

    Team Member

    @bassplayer_7,

    do you currently have any items in the trash or other vaults for the sites you're trying to get prompted for?

  • @rudy, no. I checked this site because it was an easy example, and another site from today as well. Neither of which have entries in trash.

  • ag_sebastianag_sebastian

    Team Member

    Hi @bassplayer_7! :)

    Before I dig into this, I'd like to mention something for others who might stumble upon this topic: If you don't get the prompt to save the login item after you've generated the password, you can still find that password in the Passwords category.

    Unfortunately, our Autosave feature can get very tricky to get right, and sometimes things just don't work as they should. Frankly, I'm baffled by the situation, as I wasn't able to reproduce the issue you're seeing. Furthermore, you've already tested all the things I could've suggested. :( The only thing left is the IT classic "Have you tried turning the feature off and on again", but I'm not convinced that would help in your case.

    Having said that, we've decided to handle Autosave differently and more reliably in 1Password X. Once you fill in all the details, you'll get an inline suggestion from 1Password X to save the login, and as soon as you click the suggestion—Bam, the login gets saved. :) Other feature that I like is that 1Password X is a standalone extension, which doesn't require you to have the app installed. Since you already seem to have a 1Password account, I'd like to ask you to give 1Password X a go and see if it fits your needs.

    Hope that helps, let me know how it goes. :)

  • I’m using Safari and not once have I been prompted to save a password after generating and updating. Because of all the manual copying and pasting to get passwords updated it takes me over five minutes just to update one password. Not as simple as it’s made out to be

  • BenBen AWS Team

    Team Member

    @Coach

    Do you have 1Password > Settings > Browsers > 'Detect new usernames and passwords and offer to save them' enabled?

    Ben

  • Boom! First good news of the day. The "Detect" button was not checked. Appreciate it, Ben!

  • brentybrenty

    Team Member

    Glad that Ben was able to point you in the right direction. We're here if you need anything else. :chuffed:

  • @ag_sebastian, thanks for the help here! I have been trying 1Password X. I want to like it and the design is beautiful. I think many people who aren't as accustomed to keyboard shortcuts will also like having the prompt right next to the prefill inputs. Unfortunately, it has backfired on me as I can't uninstall it and go back to the other 1Password browser extension which, it turns out I love (except for not saving passwords – funny irony). For me, 1Password X does not prompt with websites in my personal vault so it is leaves a large gap in desired functionality. Further, it does not use my app's password, so unlocking it is a royal pain.

    So I'm not sure where to go from here. It's clear to me that 1Password X won't work for now and I will continue to try reverting to the old one. If there was a way to tie it to my personal vault also, it would be great.

  • Hi @bassplayer_7,

    You should be able to revert so if you're having troubles something is definitely not right. For Chrome you should be able to remove 1Password X by visiting chrome://extensions/ and after years of weird browser behaviour I always chuck in a restart of the browser at this point just because. You should then be able to install the companion extension and a direct link to its entry in the Chrome web store is 1Password extension - Chrome Web Store.

    Now as 1Password X only works with 1Password accounts it can't access a standalone vault if that exists but your choice of words threw me a bit. Depending on the scenario a user's individual vault may be titled either Personal or Private whilst the first standalone vault is always referred to as Primary. 1Password X can't interact with a Primary vault but if a Personal/Private vault is a 1Password account vault it should be available. I have never tried adding multiple 1Password accounts to 1Password X and I will be filing an issue as I found unlocking the second account was not intuitive at all. It is possible though if that is something you want to do.

    That does still leave the lack of auto-save prompts. In your first post I think you used the account registration form for our own forums as an example of somewhere where 1Password wasn't prompting, is that correct? I just want to perform some sanity testing so that I'm sure you should be prompted in some place where you're not and that it does seem to be something localised to your machine.

  • @littlebobbytables, I really appreciate you all's help here and I'm sorry to be a trouble. I just use 1Password so much every (work) day that it's very noticeable when it acts up. I did try almost everything I could think of in terms of getting the old 1Password browser extension back. This included uninstalling both then reinstalling the new one, restarting the browser in there, restarting 1Password, and the like. Perhaps a computer reboot will help tonight. When I typed the shortcut (Cmd + ), it would flash the 1Password desktop app for a second and then disappear – ultimately doing nothing.

    I can see how that caused confusion. I was indeed thinking of my "Primary" vault and not my "Personal" one. I would be hesitant to upload all my personal entries to a business vault even though it should be personal, but that's not the point, I suppose.

    Remarkably, 1Password X didn't offer to autosave either. Since I still have it I used it to create another user on this forum to see if it would offer to save the password – but to my surprise it didn't. This is all quite baffling. I suppose I should take some time tonight to re-install the app. Are there any permissions in macOS Mojave that could be throwing something off?

  • Hi @bassplayer_7,

    Is the issue not so much that you can't install the companion extension but that 1Password isn't responding in the expected manner? I ask because that would potentially mean a very different set of causes. Something worth trying if you want to avoid the full restart just now is to quit both Chrome and 1Password and launch both again. Chrome is easy but you have to do a bit more with 1Password. The suggestion I find that seems to fit well with users is; if 1Password is currently running hold down the alt/option key and click on the 1Password icon in the macOS menu bar at the top of the screen. Select the menu option Quit 1Password Completely. If you quit both and then launch 1Password and then Chrome can you see if the companion extension responds to clicking its button in the Chrome toolbar. If 1Password mini appears that may have been nudge 1Password needed to behave.

    I would agree that uploading all of your personal items to a business account isn't recommended. Ultimately control of the business account lies with the owners of the account and if it were tied to you business email address, which they also control it would mean they could recover the account and gain access to the contents. The Personal/Private vault for the business account is definitely meant for items that pertain to the business and we'd always recommend maintaining that separation. Of course if you're the owner of the business the line gets a bit more blurry but I would never disagree with keeping personal and business separate as a practice, it just helps to keep things tidy.

    Let's first make sure you can fill using the companion extension and then we can turn our attention back to getting the auto-save prompts back. This should work so we'll keep going with the troubleshooting until we get 1Password to behave for you.

  • @littlebobbytables, thanks for clarifying that. Indeed, I quit 1Password only partially (Cmd + Q) the first time. Shutting it down fully, along with the browser has allowed me to restore the browser extension so it is working as it did before 1Password X. Breath of fresh air there. :)

    Thanks for the info on personal/business vaults – we're on the same page there.

    Interestingly, it seems that the extension re-install may have resolved the problem. I signed up on a different site to test it out and was prompted to save the password – to my great pleasure. So, thanks for your help and I think this just might be set!

  • brentybrenty

    Team Member

    Ah, excellent. Thanks for the update! I'm glad that lil bobby was able to help, and we're here if you need anything else. :)

  • I came on here with the same issue. We use Chrome on our Macs. We've used 1P for 2 years in our small business, and since 1P 7 came out in summer 2018, the prompting to save feature has been dreadful. I can force-hack it by digging into the password generator log and creating a login, but frankly nobody else on my team is capable of that. The whole point of using 1P for us is to force the non-tech savvy to use secure passwords but using a simple, functional program. We now have a ton of duplicate logins or the ones that look like grey keys that aren't attached to actual logins, and I think those are not searchable and hard to find.

    I recently started using a financial service that requires LastPass for PW sharing, and it is noticeable that LP prompts to save EVERY login and in many many instances, 1P does not on the same sites. I do have this setting below enabled on every machine:

    Do you have 1Password > Settings > Browsers > 'Detect new usernames and passwords and offer to save them' enabled?

  • Hi @lithigin,

    I now believe there is potentially a bug in 1Password 7.2.4, possibly going back one or two minor updates, where it isn't prompting after using the Password Generator and it could be this you're suffering from. If you're still running version 7.1.2 or earlier though this possible bug wouldn't explain any issues you're seeing. So the first thing I would like to do is learn what version of 1Password you're using. From there, do you remember a site or two from recent usage where you observed the issue to see if it supports my suspicions.

  • I am on 7.2.4. Sites in the last 2 weeks:
    www.tractiontools.com (new)
    upwork.com (updated)
    tsheets.com (new)
    mailchimp.com (updated)
    monday.com (new)
    capitalone.com (updated)
    superwarehouse.com (new)

    In fact, I can't recall it prompting at all in the last few months.

  • Hi @lithigin,

    So there are a combination of reasons it seems.

    • www.tsheets.com If I mash the keyboard for the password field on the registration page and click the button I'm prompted to save. If I use the Password Generator I'm not. So this is an example of the bug I was thinking about.
    • monday.com I believe the extension isn't reacting to the next button. This one is tougher as we don't want 1Password reacting to any button click, just the right ones and the word next could be used for any number of reasons.
    • www.superwarehouse.com This is another example of the Password Generator bug.

    I haven't tried any of the ones where you were changing a password yet just because it will take a little longer to test those. The Traction Tools website wasn't one I felt I could get away with creating a test account given the first step was a Zoom meeting but I'm hoping the others will all follow a trend, ideally supporting the Password Generator bug as I am hoping we understand that one sufficiently well enough to correct it.

  • 1 Password is not prompting to save logins or passwords anymore. I have had to revert to using Safari Keychain to avoid password hassles. I am using iOS Mojave 10.14.3 on a MacBook Air 2012. I have completely deleted and reinstalled 1 password from both the Mac App Store (no joy) and from the 1Password site (still no Joy). I am using 1Password 7.2.4 and have both the extension helper and autosave boxes checked. I am subscribed to 1Password and have a family account. I have changed the password several times on the LogMeIn.com site and have not gotten anything but the Safari 12.0.3 keychain to prompt me to save my password changes (which it does every time like it should but 1Password does not). Something is flawed and if it is me I cannot see where it might be. I have tried to install the Safari extension and shows up in the Safari Dock but does not work just prompts me if I want to open 1Password 7 and goes away if Safari is closed and reopened. I have the 1Password and Safari applications installed in the /Applications folder so that cannot be the issue. Can someone point me in the right direction before downloading the diagnostics tool- decompressing it and having to file a report. It should be easier than that.

  • Greetings @svennw,

    1Password 7.2 is the first version of 1Password that supports Apple's newer Safari App Extension approach to extension. With Safari App Extension the extension is bundled as part of the 1Password application bundle. After installing 1Password into /Applications/ the extension should appear automatically in the extension tab of Safari's preferences as version 7.2.4 and if it isn't something has gone wrong. The extension that you manually install won't help as it only works with 7.1.2 or older and we keep it because 1Password 6 for Mac also uses it. Can you try the following for me please.

    1. In Safari enter Safari's preferences and switch to the Extensions tab.
    2. Remove any copy of the 1Password extension that does display as version 7.2.4. Assuming you find it listed, if you try to remove it macOS will say you need to delete the application.
    3. Ensure the 1Password 7.2.4 extension is enabled. In the Extension tab the sidebar on the left lists the extensions and each has a checkbox. We're not allowed to enable the extension by default, the user must do this so that the user remains in control.

    If you don't find 1Password listed with version 7.2.4 it could very well be the application bundle is damaged as Safari will only list an extension if the bundle passes the code signature verification check. If that could be the case here the following should help.

    1. If 1Password is currently running hold down the alt/option key and click on the 1Password icon in the macOS menu bar at the top of the screen. Select the menu option Quit 1Password Completely.
    2. Drag the 1Password Application bundle from /Applications/ to the Trash.
    3. Download and install a fresh copy of 1Password from "Downloads - 1Password" page.
    4. Launch 1Password and unlock.
    5. Launch Safari and enter Safari's preferences, switching to the Extensions tab.
    6. Confirm the 1Password extension is present, is displaying version 7.2.4 and that the extension is enabled (the checkbox in the lefthand sidebar).
    7. Test to see if the extension is working.

    If that still doesn't result in the extension being correctly displayed we may need to review a diagnostic report to see if it reveals why things still aren't working.

Leave a Comment

BoldItalicStrikethroughOrdered listUnordered list
Emoji
Image
Align leftAlign centerAlign rightToggle HTML viewToggle full pageToggle lights
Drop image/file