Cannot access extension during HTTP auth prompt in Firefox

Hello,
I decided to make the jump from my trusty Firefox 5 to the latest Firefox 9.0.1 with 1P version Version 3.8.14 (build 31251). I was using FF5 because I needed http auth support. Seeing how in 1P for Chrome, you can copy/paste http auth passwords from the icon on the upper right of the Chrome window, this seemed adequate enough.

The first thing I tried after installing FF9 was to try logging into one of our many http auth protected sites. The username/password prompt came up, and I clicked command+\ The 1P window popuped up, but I cannot get the window to focus to enter in my master password.

I've attached a screen shot of of the window in question. Any help would be great.

Comments

  • khadkhad Social Choreographer

    Team Member
    Unfortunately, Firefox does not allow access to the extension while a modal HTTP auth prompt is displayed. :S
  • Thanks...back to FF5 I go.
  • khadkhad Social Choreographer

    Team Member
    edited January 2012
    At this time, Mozilla is only issuing security updates for the latest version of Firefox and the older version 3. All other versions have unpatched security vulnerabilities. Additionally, it is not known how long Mozilla will be maintaining the older Firefox 3 browser. As a 1Password user, we know that you take security seriously, so we thought it was wise to let you know this.

    In light of the above, it is obviously a good idea to use the latest version of Firefox if at all possible. However, if you still decide to use an older version of Firefox for some reason, version 3 is the one we suggest.

    Stay safe out there! :)
  • Hi,
    Sorry to bring this back up again, but I was wondering if your team is working along-side the Mozilla team to resolve this. I posted a comment regarding this on the Mozilla forums and got this back.


    Sorry, the Mozilla developers rarely visit this forum. If Agilebits has a problem with the Jetpack API and feel it needs to be fixed, the proper venue for them (or anyone, for that matter) is to file a Bug report at Bugzilla.Mozilla.Org . If they have a patch to fix the issue, they can include the patch with the report.
    That said, there is another forum for Add-on support which would be more in line with development issues related to Jetpack API's.


    I'm curious if any of the two steps were taken yet.

    Thanks!
  • khadkhad Social Choreographer

    Team Member
    We have been in contact with Mozilla, but we don't normally discuss future products or features publicly.

    Sorry I can't give more information at this time. I can assure you that I am advocating on your behalf for this. It is something that affects not only you but other users and even our own team. I appreciate your passion for this, and it has not fallen on deaf ears. :)
  • bassclefbassclef Junior Member
    Hi Khad,

    Mozilla is discontinuing security updates for Firefox 3.6 on Monday 24 April. Sadly this problem isn't fixed yet for later versions of Firefox in your current extension. This leaves us (your customers) with the bad choices of either copy/paste passwords from the app into the browser *or* using unsupported browser.

    I hope you will have good news for us with the return of http auth support in at least one (Mac) browser very soon!

    -Alan
  • khadkhad Social Choreographer

    Team Member
    So far, only Chrome has shown any progress on making HTTP Auth prompts available via extension APIs:

    http://code.google.com/p/chromium/issues/detail?id=32056

    Hopefully Safari and Firefox will follow, but for now they are unfortunately still not available to extensions like 1Password.

    I wish we had more control over the extension APIs of the major browsers. As a single developer we don't have much more clout than anyone else. But the more users request the feature from them, the more likely they may be to implement it.

    We're exploring other options, but I don't have anything I can share at the moment.
This discussion has been closed.