Trouble with Login

edited April 2013 in iOS

I am trying to get a new login set up for a financial site: I got it to work on my Mac...can log into successfully via main app and via browser key. However, I cannot access via iPad or iPhone. The login on those IOS devices takes me to the sign in pages...but the username & password fields are blank. Since the app on the Mac works....and the app on the devices is nothing more than a mirror of the same via sync...I don't understand why the fields would be blank.


  • I have added a login on Mac which works by using the main app & the website key. However, when I try to use it on the opens the site but the username and password fields are blank. Every other login that I have on the iPad takes me directly to the page or to a login page in which the username and password are filled they are supposed to be. Please help me or explain.

  • Am I not correct in understanding that the username & password fields should be filled in on the iPad & iPhone login? They are on the Mac app login. What could be the problem?

  • I guess this is so convoluted, stupid, confusing, or elementary to anybody to respond to? It's a real problem for me.

  • khadkhad Social Choreographer

    Team Member
    edited April 2013

    @kentp, we always reply within 24 hours as all of my other replies to you here on the forum should indicate. I'm happy to be able to reply to you now much sooner than that in this case as well. :)

    The URL you provided above is not a "real" website. It is a parked domain with a bunch of ads. There is no login form there.

    Could you let me know the exact URL of the login page where you are having trouble? I'd love to take a look, so I can better assist you.

  • khadkhad Social Choreographer

    Team Member

    I did just check just in case you meant the Albridge Wealth Reporting site and adding the trailing "s" was simply a typo. If that was the site you meant, the problem is that the site is using iframes which preclude 1Password from working on iOS. I don't think it is possible for us to fill iframes in the WebView that Apple provides for developers in iOS. That is was the built-in browser in 1Password for iOS is based on. For now, you will need to copy and paste the password. You can access it right from the browser by tapping the circled > to the right of the Login item in the toolbar.

    If that's not the URL you meant, please let me know. My guess is that it is an iframe issue, though, if it works fine on the desktop but not in iOS.

    Also, I'm moving this post to the iOS category rather than the lounge since it is an iOS issue.

    Please keep me posted. Thanks!

  • khadkhad Social Choreographer

    Team Member

    One more update. :)

    I just found the other thread you started for what appears to be the exact same issue. If the issue in the other thread that I just merged with this one is for a different site, please let me know the other URL.

  • I am trying to login at Vanguard and it has a two page login process. On the first page you input your user name and press submit. On the second page you supply your password. I tried the process you suggested for the B of A and it didn't work. The URL for the first page is the url for the second page is I can get to the first page with a saved 1Password url but I must then press submit and at the point I am moved to the second url and must manually enter the password. Help!

  • Hi @Phillip_Wright,

    I'm sorry to hear that you're having difficulties with Vanguard. I just want to make sure there's no confusion here: to use 1Password with the B of A site, or any two-page login process, you will need to use Cmd\ to fill the password on the second page. Is 1Password failing to fill for you here after using the shortcut?

  • @Megan I have the same struggle with Vanguard, so I can speak to it. The app successfully fills out the form on, but that then takes me to another page for the password where 1password just enters my username into the password field. I always have to just copy my password from the app into the field manually.

  • Hi Ben,

    Thanks so much for including your experience here. Since I don't personally have an account with Vanguard, I can't actually access that second page to take a better look at it, but luckily one my co-workers does. He was able to create a working Login by following the steps on the 1Password and Bank of America post. Could you try creating a new Login using those steps and see if it behaves as expected for you?

    If you are still having difficulties, please let me know the exact steps that you are taking. Please include what you expect to happen, and what actually happens. The more detail we have, the easier it will be to track down where things are going wrong.

  • Following the Bank of America post didn't fix anything, but I noticed they had a lot of Javascript functionality built into the form, and on a hunch tried changing the "Submit" option of my password to "Never submit", and clicked 'Submit' manually, and this fixes it.

  • Hi Ben,

    I'm so glad to hear you were able to get a Login working. In the future, you might also try toggling the 'Animate form filling' feature. In some cases, this will get the Submit option behaving correctly. :)

    Please let me know if you run into any further snags, I'd be happy to help!

This discussion has been closed.