Safari error: "Extension database not available."

chris068chris068
edited January 2014 in 1Password 3 – 6 for Mac

I'm using 1Password Version 3.8.21 (build 32009), syncing with Dropbox, on my Macbook Pro, running OSX 10.9.1, with Safari Version 7.0.1 (9537.73.11). Have been using it for a very long time, without any significant issues, other than a recent sync conflict snafu that seemed not to cause any permanent damage.

Earlier this morning, I removed an extension from my Safari config. The extension I removed was something unrelated to 1Password-- I didn't do anything to the 1Password extension (which is version 3.9.20). But immediately after removing the other unrelated extension, 1Password stopped working in Safari. When I try to unlock the database, I get an error message: "Extension database not available. Please press Command-Option-Q to restart your browser and discard invalid..." (I can't actually see the rest of the error message text-- it is truncated because it won't fit in the dialog box. That's a little frustrating...)

I followed those directions, pressing Command-Option-Q. That didn't help.

I "reset" Safari completely. That didn't help.

I completely uninstalled the extension, "reset" Safari, and then pressed Command-Option-Q. Then I re-installed the extension by downloading it from the page that is brought up by the 1Password app, "Install Browser Extensions" menu option. That didn't help.

I completely uninstalled the extension again, reset Safari, then rebooted my Mac. Twice. Then I re-installed the extension. That didn't help.

Meanwhile, the 1Password application works fine, has no problems opening my database, and doesn't give any errors at all, and I can see all my password records without any obvious problems.

What am I doing wrong???? How can I fix this? I use 1Password every day-- if not every hour I'm on my laptop. This is debilitating! Please help!

Thanks,
Chris

Comments

  • MeganMegan 1Password Alumni 1Password Alumni

    Hi Chris ( @chris068 ),

    I'm so sorry to hear that you've been having trouble with the 1Password Safari extension. Please see this article for some fix instructions: "Problem with database" in v3 extension in Safari on OS X Mavericks

    You should be all sorted out, but please let me know if you're still unable to use the extension, and we'll investigate further.

  • Thank you Megan. This does indeed correct the problem. Odd though-- I migrated to Mavericks quite a while ago and had no problems until just now.

    Also, on the page you provided the link for, the author says "This problem does not occur in the new 1Password 4 for Mac, but if you are sticking with 1Password 3 for some reason..." Thought I'd mention the reason. $49.99 is a very very very steep price for upgrading from 3.8 to 4.x. I've read what 4.x can do, and I certainly appreciate the increased/improved feature set. But it's not compelling enough to justify that stiff of a price tag for a long-time loyal user. At $19.99 or so, I'd do it. (Sadly I missed your half-price sale... Maybe you'll do that again? :o))

    Thanks!
    Chris

  • khadkhad Social Choreographer

    Team Member

    Thanks for you feedback, @chris068! If it helps, all existing users are entitled to 50% off when upgrading. Just enter your license key here:

    https://agilebits.com/onepassword/mac/upgrade

    Cheers!

  • OH! Outstanding. I did not know that-- thank you for informing me. I can probably justify $25.... :o)

  • khadkhad Social Choreographer

    Team Member

    Happy to help! Thanks in advance for your continued support. :)

  • Hey @khad, I'm sorry to bug you again, but I'm confused. Yesterday, when you posted the upgrade URL, I saw that I could get 50% off on single user or family license for 1P4. Today, I decided to go ahead and purchase the family license pack, and I followed the same link, but when I entered my current serial number today, your site just automatically put the single-user license in my cart, and didn't show me discounted prices on anything else. Did I do something wrong?

  • MeganMegan 1Password Alumni 1Password Alumni

    Hi @chris068,

    I'm sorry to hear that you're having trouble upgrading. It sounds like you may need to clear your cart. Go to https://agilebits.com/store/cart and remove any licenses that you see there. Then you should be able to add your family license.

    Please let me know if you run into any further snags - we're here to help :)

  • You guys are amazingly helpful! However, this didn't solve the problem. The URL you provided automatically redirects to /store, and shows original prices. To be sure, I completely reset Safari, and then followed the /onepassword/mac/upgrade URL @khad provided, entered my existing license, and once again got the single-user version automatically added to my cart at the upgrade price, and couldn't find any option to see family bundle at upgrade price.

    I even tried the URL in the Chrome browser, just to be sure there wasn't any history/cookies/etc on my side, and still got the same result. Not sure what to try next.... But I'd be grateful for a hint! :)

  • MeganMegan 1Password Alumni 1Password Alumni

    Hi @chris068,

    Ok, I've just tested things out here, and if you go to this page -- https://agilebits.com/store/upgrade -- you should be re-directed to a page that lets you choose your bundle. I just noticed that Khad's link is meant to be a one-step easy upgrade for the single user license. I'm keeping my fingers crossed that things behave properly for you through the general upgrade page!

  • Indeed! Thank you for the pointer, @Megan. Thank you both for the excellent support. :)

  • MeganMegan 1Password Alumni 1Password Alumni

    Hi @chris068,

    On behalf of Khad, you're so welcome! I hope the upgrade process goes smoothly, but we're here for you if you hit any snags. :)

This discussion has been closed.