Usernames entered from Safari aren't saved in 1Password, some websites password fill doesn't work

1) Entering a username from the pulldown in safari and clicking save doesn't save it. Opening the app it's not there. New usernames only stick when entered from the app.

2) Some websites the 1P autofill fails. Interestingly, creating a password on this very site, I had to copy and paste the generated password from 1P into the browser. In most sites it does work.

1P 3.9.2
Safari 7.0.1
OS 10.9.1

Comments

  • khadkhad Social Choreographer

    Team Member

    Hi @manfrommars,

    Thanks for taking the time to contact us. I'm sorry that you are having some trouble.

    I noticed that the version of 1Password that you listed is actually the version of the 1Password extension. Just to make sure we're on the same page, could you tell me what version of the main 1Password application you are using (not the extension)? Here is a screenshot of my own as an example. It shows I am running 1Password 4.2.BETA-1.

  • I am experiencing a similar problem.

    OS X 10.7.5
    Safari 6.1.1 (7537.73.11)
    Extension version 3.9.20
    App version 3.9.6 (39600.038)

    I also have 1Password 4 running on a laptop, but that isn't my primary machine.

    Extension troubleshooting says:

    Could not sync because the 1Password database was replaced or was recreated. You can fix this problem by reinstalling the extension.

    Now I have been eliminating a bunch of my old Safari KeyChain passwords, converting to 1Password, and have updated quite a few of the passwords with new longer versions. In Safari, everything is working fine, but if I go into the app, it shows most of these logins with no username and / or incorrect passwords.

    I reinstalled the browser extension to no avail. Do I need to uninstall and reinstall? And what is going to happen to all the passwords that the Safari extension is aware of but the application is not. I absolutely want to make sure that I keep everything. I was having some difficulty seeing changes I committed in one location show up in another, so I believe I disabled and re-enabled Dropbox syncing for the app. I think that is probably when things stopped working correctly.

    Ideally, I'd prefer not to have to copy the password entries by hand from the extension to the app, but I'm thinking that might be my only option at this point.

    I hope someone has a better solution?

    Thanks!

  • MeganMegan 1Password Alumni

    Hi @myramoki,

    I'm so sorry to hear that you're having trouble with 1Password right now. I'd like to take a closer look at your system. I'd like to ask you to create a Diagnostics Report from your Mac. They are easy to generate and gives us an idea of what is going on 'under the hood' with your installation of 1Password. To create a diagnostics report on OS X 10.7 Lion or OS X 10.8 Mountain Lion, please follow these instructions:

    http://discussions.agilebits.com/discussion/12057

    Then attach the entire file to an email to us: [email protected] agilebits .com

    Please do not post your Diagnostics Report in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your Diagnostics Report in our inbox.

    Once we see the report we should be able to better assist you. Thanks in advance!

  • myramokimyramoki
    edited February 2014

    Well I solved my problem by doing this:

    I did not know of a way to export the Logins that the extension knew about but the app didn't so I simple went into each Login, clicked the Edit button and then clicked Save. I watched that everything was actually showing up in the app. I then confirmed that there weren't any Logins missing usernames or passwords in the app. I also confirmed the modified date on everything in the app was from today, so that I knew everything had been updated.

    After that, I uninstalled the Safari extension, restarted Safari, installed the extension and everything seems to be okay now in that its properly syncing.

    It was tedious and I would have preferred a way that I could have force synced everything that the extension knew about back to what the app was aware of, but it worked for me at least.

  • MeganMegan 1Password Alumni

    Hi @myramoki,

    Thanks for letting us know that you're all sorted out! If you do run into any further snags, please don't hesitate to ask us - we'd be happy to help :)

This discussion has been closed.