Autofill works on 1Password for Mac, but not iPhone

I have set up Amerigas login information on my mac. After syncing, the entry shows on the iPhone, but it will not fill in using the built in browser on 1Password for iPhone. The web address I am using is https://www.eservices-ag.com/bd/public/frameset_top_html.jsp

Thanks for the help.
Philip

Comments

  • Does it help to change the User Agent in the 1Browser section of settings? It might or might not, but worth a try.

  • No. I tried identifying as safari for mac and iphone as well as chrome. I did clear web data too.

  • Hi @ddrumer,

    Thanks for including the URL in your original post - it makes this a lot easier to troubleshoot! I manually saved a new Login on my Mac using these steps:

    • Visit the site and fill in the fields you want filled. Do NOT click the login button.
    • Click the 1Password extension, and unlock it if necessary
    • Click the gear icon (or vault icon if multiple vaults are enabled) in the upper right corner.
    • Select Save new login.
    • Give the entry a unique and identifiable title.
    • Click Save.
    • Revisit the site and see if 1Password fills in the site correctly.

    When I tested this on my iOS device, the website that you posted did not fill (as you noted.) However, when I manually saved the Login, 1Password also saved a secondary website URL. By tapping on this URL - https://www.eservices-ag.com/logon/logonServlet?redirectURL=/bd/logon.sap - I was able to log in automatically in 1Browser.

    Please add this URL as a secondary website in your Login entry and see if it works for you as well! :)

This discussion has been closed.