MAJOR Issues Beta 10

edited February 2014 in Android Beta

So I attempted to create a new login item in 1Password for Android (beta 10) :

  • Bug #1

At the Logins screen after saving the new entry I would see the title of the new entry and below it, instead of the username (which was an email), a long string of letters and numbers presumably the password I had just auto-generated for it.

  • Bug #2

If you click on the URL field which reads (, type something and then delete everything on that field, a stubborn "http://" entry will appear which is NOT deletable. You are stuck with that field and entry on your new login even if you do not want an URL field.

  • Bug#3

I got an in-app confirmation that 1 new entry was added to my keychain but dropbox on my mac says that 2 (two) files were updated.

At some point in this whole procedure the app crashes. I can't pinpoint exactly what was happening but I did send the error report. I remember I tried to scroll down the list using the slider at the same time it was syncing when the app froze. Shortly afterwards it crashed.

Anyway the new entry does not appear on my Mac's 1Password so I try to access 1Password Anywhere to check if its there. I get this:

*Problem loading 1Password data file

A key data file could not be loaded and 1PasswordAnywhere cannot continue without it.

Please see this help guide for troubleshooting tips.*

the missing or corrupted data file according to the URL is this:

file:///Users/Admin/Dropbox/1Password.agilekeychain/data/default/encryptionKeys.js (the file is there in the folder).

The access to this file was working fine before this sync fiasco.

I finally try to add a new login entry on my Mac, I manually sync and the process works: I got it through over to 1Password for Android.

Yet, I am still getting the above error when trying to access my 1Password Anywhere, so I try to restore to an earlier version in my 1Password for Mac and sync. Still no fix.

  • Bug #4

When manually inserting a password to a newly created item, the keyboard will return back to the letter layout after you've typed in a number.

For instance, I want to insert password YADA1234 - After I type YADA I press the number button on my keyboard to take me to the number layout. I press 1 and it will automatically take me back to the letter layout right after that. So I have to go back to the number layout again to type 2, and so on.

If anyone can give me a hint how to fix my 1Password Anywhere problem I'll be much obliged, and watch where you step when creating logins using Beta 10.

There is still a long way to go devs, and beta 9 seemed more trustworthy than this version.


  • The 1Password Anywhere thing might just be a local file url issue. I was having problems using Anywhere on local systems and I read somewhere on this site that it doesn't work. Try logging into the dropbox site and accessing the html file directly from there.

  • thank you richard that did seem to work.

  • saadsaad

    Team Member

    Hey @Troneas. Thanks for reporting these bugs after updating to beta 10. My comments are below:

    Bug #1

    I was unable to reproduce this. :( Can you do a fresh install of beta 10 and let me know if you're still experiencing this issue? This will eliminate any possible conflicts from updating from beta 9. (Remember to safely store any unsynced items before uninstalling 1Password)

    Bug #2

    We are aware of this one! It's been there in older betas too. Expect a fix very soon. :)

    Bug #3

    Can you confirm if you are seeing all items using 1PasswordAnywhere through

    Beta #4

    This is another one we are aware of, it's also been there in older betas. I'll add your vote for this request.

    Thanks again for your feedback. Please keep me updated on Bug #1 and #3, and let me know if you have any questions.

  • TroneasTroneas
    edited February 2014

    ok i deleted the app and re-installed and Bug #1 seems to have fixed itself. I have managed to successfully add a username and auto-generated password without it being visible in the logins screen.

    and yes i can access 1password anywhere successfully via dropbox thank you. i only get the error when launching it from my dropbox folder in my mac.

    • Bug #5

    Quick Unlock is failing on me a lot.

    Since the new install I had the app asking for both the MP and the QU on occasion.

    I turned off QU and set it up again.

    Now I found out that if i close the app by pressing my phone's home key and launch it again by tapping on the icon it will ask for the MP, if I open it via the recently used apps screen it will ask for the QU password.

    this has been very consistent so i'm wondering if its intended; although its still glitchy because I was asked to type the MP twice once.

  • NikNik 1Password Alumni

    and yes i can access 1password anywhere successfully via dropbox thank you. i only get the error when launching it from my dropbox folder in my mac.

    If you use Safari, you can get around this.

    • Open Safari > Preferences > Advanced and enable Show Develop menu in menu bar
    • Select Develop > Disable Local File Restrictions

    That should resolve the issue for you, if you want to open 1PasswordAnywhere locally.

    If you're closing 1Password by pressing your phone's home button, it should still be running in the background, so tapping its icon should prompt you for the quick unlock code, and not for your master password. Sounds like something's not quite right here. @saad will correct me if I'm wrong; I'm a lot newer to our beta for Android than he. I tried switching back to the app both by tapping its icon and by selecting it from the recent list, and in both cases I was prompted to enter my quick unlock code, not the master password. Can you tell me which device you're using?

    I agree that we still have some glitches. While I wasn't prompted to enter the master password twice, I was (once) prompted to enter the quick unlock code twice. If I can reproduce the problem, I can file a report for our devs.

This discussion has been closed.