1Password - Failed to run import script

Hi.

I tried to run an import (only a single record so no big deal that it failed really), and I get the following message.

/Applications/1Password.app/Contents/Import/lib/json/pure.rb:17:in `rescue in ': uninitialized constant JSON::Iconv (NameError)

Followed by a large run of ruby errors.

Im not sure if this is something wrong on my side (Osx 10.9 Mavericks) or with 1Password. Any ideas?

Thanks.

Mike

Osx 10.9
1Password 3.8.21.

Comments

  • MeganMegan 1Password Alumni

    Hi mike.harr,

    The best way to confirm that there is nothing wonky going on with your installation of 1Password is to send our support team a Diagnostics Report.

    Download the 1Password Troubleshooting utility and follow the instructions to generate the report.

    Then attach the entire file to an email to us: [email protected] agilebits .com

    Please do not post your Diagnostics Report in the forums, but please do include a link to this thread in your email so that we can "connect the dots" when we see your Diagnostics Report in our inbox.

    Once we see the report we should be able to better assist you. Thanks in advance!

  • mike.harrmike.harr Junior Member

    Hi Megan.

    I had a little trouble running the tool and had to resort to the "Network" version. I have sent an email as requested with a link to this post and the output of the utility.

    Thanks for your help.

    Mike

  • MeganMegan 1Password Alumni

    Hi mike.harr,

    Sorry you ran into trouble there, but our support team should get you sorted out soon :) We'll follow up via email, just so things don't get too muddled between here and there :)

  • I also can't import 1password .PIF files on Mac OS X (Mavericks). It would appear there is a new version of Ruby 2.0.0 that doesn't work with the 1Password ruby script using the 'iconv' gem. I tried to install this gem, but it doesn't work with the new Ruby. See http://stackoverflow.com/questions/16032241/ruby-2-0-iconv-replacement

  • MeganMegan 1Password Alumni

    Hi @deadlyfingers,

    You're right, 1Password 3 for Mac doesn't play nicely with Ruby 2.0.0.

    I do apologize for the inconvenience - Apple included Ruby 1.8.7 for Snow Leopard, Lion and Mountain Lion... for all we knew they'd include it in Mavericks too! We're working to get everything updated for Ruby 2.0 just as soon as possible.

  • mcmark64mcmark64 Junior Member

    It's been 22 days since the last post. Has this issue been fixed?

  • MeganMegan 1Password Alumni

    Hi @mcmark64,

    As you can imagine, with the release of 1Password 4, our developers are a little bit busy right now. I'll be sure to pass this request along to them though. :)

  • Mavericks does ship with ruby 1.8. (/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby) so fixing the issue would as simple as using that binary.

    I would appreciate a fix of this issue as well. :)

  • MeganMegan 1Password Alumni

    Hi all!

    Our tech gurus have a lovely little script for you to run in the command line that should get import working for you in Mavericks!

    Just open up Terminal and copy and paste the following:

    PATH=/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin /Applications/1Password3821.app/Contents/MacOS/1Password

    (where 1Password3821.app is the name of the 1Password 3.8.21 app)

    Please let me know how that works for you.

  • celseecelsee Junior Member

    Worked for me!

  • MeganMegan 1Password Alumni

    Hi @celsee,

    Thanks for letting us know that got you sorted out - I'm so glad to hear it's working :)

  • Running those two commands did enable me to import a 1pif file, but only during that one run of 1Password. In other words the fix is not permanent. Is there a permanent fix in the works?

  • MeganMegan 1Password Alumni

    Hi @slessard,

    You're right, the script is a per-run solution. I'll let our developers know that you would be interested in a more permanent fix. :)

  • I too have been plagued numerous times by this failure to run import script problem, and I just now found this thread where I was hoping and expecting to find a solution. I'm saddened to see the last post here was more than 3 months ago, and apparently this problem has still not been addressed? We really need a permanent fix for this ASAP as the per-run solution via a terminal command is just not acceptable. What's the status of this fix?

    Thanks,
    Barry

  • MeganMegan 1Password Alumni

    Hi Barry ( @brabin ),

    I'm so sorry to hear that this issue has been frustrating for you! Unfortunately, at this time I don't know that there will be a more permanent fix beyond this import script. Our team is small, and our development efforts are currently focussed on making 1Password 4 as strong, secure, and full of awesome features as it can be and getting this product out to our users on other platforms. While we of course continue to support 1Password 3 and ensure that it continues to function as well as possible in Mavericks, there are some features that will inevitably require little patches such as this as the underlying architecture of the operating system changes.

    Your understanding here is much appreciated :)

  • Hi Megan,

    Thanks for replying. I do understand resource limitations and need to focus on the new version. Personally, I plan to upgrade to when the iOS version supports multiple/shared vaults.

    That said, a real "patch" here would be reasonable. I don't consider having to open Terminal and run a command each and every time I want to perform an import to be a "little patch". Seriously now, how difficult can it be to implement this terminal command into the built-in import script directly, and issue an update to 1Password 3 so that it can at least seamlessly import its own native file format? I know the team is small, but if this is not part of "...continue to support 1Password 3 and ensure that it continues to function as well as possible in Mavericks", then I don't know what is.

    Thanks,
    Barry

  • MeganMegan 1Password Alumni

    Hi Barry ( @brabin ),

    Thanks so much for your understanding here! Unfortunately, it's not quite a simple matter to translate the import script into the app, but I've passed your request along to our developers, and they will look into it. :)

  • I'm running Mavericks and 1P Version 3.8.21 (build 32009). The above terminal entry didn't work for me. Terminal responds with: No such file or directory
    . When I look in /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin, there isn't even an Applications directory. Ruby version 2 doesn't have an Applications directory either.

  • MeganMegan 1Password Alumni

    Hi @MikeMikeMike‌,

    I'm sorry to hear that you're having difficulties getting your data imported into 1Password 3. Since you're using Mavericks, the best solution here really is to upgrade to 1Password 4, and it just so happens that 1Password 4 for Mac is currently on sale for 50% off! You can purchase directly from the Mac App Store, or upgrade your license to get an even better deal on our website.

This discussion has been closed.