1Password not working after Safari update to 7.0.3 [resolved; "Problem with database" instructions]

BurtBurt
edited April 2014 in 1Password 3 – 6 for Mac

Running 1 Password 3.8.21 and when updating Safari from 7.02 to 7.03 1Password extension locked. When I enter the Master password I get this error dialogue box: "Extension database not available. Please press Command-Option-Q to restart your browser and discard invalid state." I've reinstalled the extension; restarted Safari and rebooted the machine after each change. Nothing has resolved the error. Any ideas to resolve? Thank you.

Comments

  • Hi @Burt,

    I'm sorry to hear that you're having trouble with the 1Password extension right now. I'd like to take a closer look at your system to see just what's going on here. Using your browser please download a small standalone tool from us that will run a networked copy of our diagnostics tool.

    http://i.agilebits.com/kyle/tools/1Password_diagnostics.zip

    After the download is complete, use Finder to locate it. It should be in your downloads folder. If the file ends in .zip then your browser has not already unzipped it. Please double click it to expand it.

    The expanded file will have a "Unix Executable File" named 1Password_diagnostics. Double-clicking this will cause a Terminal window to open and download some files it needs. (Note: If you use OS X Lion or Mountain Lion, you may need to right click the file, choose Open, and click Open on the dialog).

    Once it completes it should open a window in your browser with the results. Please click File->Save As to save this file to your computer. Please save it as "Page Source" or "HTML" if there are options for this.

    If you do not get a report created, please copy and paste the output from the Terminal window so we can take a look at the errors that were created. This will help us figure out where the problem is in creating the diagnostics report.

    Then attach the entire file to an email to us: [email protected] agilebits .com

    Please do not post your Diagnostics Report in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your Diagnostics Report in our inbox.

    Once we see the report we should be able to better assist you. Thanks in advance!

  • The directions to fix this worked. Remove two files from the Library/Safari Extension and Database folders seemed to have done the trick. A re-install of the extension worked "ONLY" after I closed and re-opened Safari. Now it looks like all is OK. Thank you for the help.

  • sjksjk oversoul

    Team Member

    Hi @Burt,

    You're welcome, on behalf of @Megan and Kyle. I see Kyle emailed you a link for these instructions:

    "Problem with database" in v3 extension in Safari on OS X Mavericks

    Presumably that's what worked to fix your problem. :)

This discussion has been closed.