1Password Anywhere encryptionkeys.js problem

Every time I try to load 1Password anywhere, I get an error message that "A problem occurred when loading the 'file:///...encryptionKeys.js' file." This is not particularly informative. It does not seem to be an updating issue, as it is over an hour since I last updated a password. I have tried loading the JavaScript file into DreamWeaver, which tells me that there is a syntax error on line 1 (effectively, the entire file) but gives me no more information. This happens on both my PCs (both running Windows 7 [one home, the other pro]; one running 1Password 1.0.9.340 - I will install it on my second PC when I'm sure it's working).

I am aware that other users (primarily Mac users) have asked similar questions, but the answers to those do not appear to apply in this situation.

How do I fix it?

«1

Comments

  • DBrownDBrown 1Password Alumni

    It sounds like you're trying to open the 1Password.html file on your local computer drive. Is that correct?

    If so, please note that most browsers refuse to do that, because the scripting used to gain access to your data is blocked when the data is in the local filesystem.

    1PasswordAnywhere is designed to give you access to your data when you're away from your computers and other devices that have 1Password installed, and you should have no problem opening the copy of 1Password.html stored in your private dropbox.com web site.

    Please give that a try, and let us know if you still see the problem.

    Thanks!

    P.S. We do not encourage directly editing the contents the .agilekeychain folder, as doing so could lead to internal inconsistencies that render your 1Password data unusable.

  • It works from dropbox, but 1Password advertises that cloud storage (which I do not trust) is NOT required to use it. How do I get remote access without using dropbox? BTW, I am well aware of the dangers of editing automatically generated data files. I went inside to see if the file was corrupted, not to edit it.

  • DBrownDBrown 1Password Alumni

    1Password 1 for Windows uses Dropbox for sync'ing your 1Password data across multiple computers and devices. A side benefit of having your data in Dropbox is that it includes a private area within dropbox.com that holds copies of all the data that is synchronized.

    You should be able to copy your .agilekeychain folder to any non-local drive and open the 1Password.html file there. Dropbox just makes it automatic and convenient to keep that non-local storage location up to date with your local 1Password data.

    I hope that's clearer, @Theologian‌. Please let us know if you have any other questions.

  • roustemroustem AgileBits Founder

    Team Member
    edited April 2014

    Most of the browser recently made a change to not allow loading of the local files from with the JavaScript code.

    You could temporarily turn this off to let 1Password load its files. In Safari, the setting is in Develop > Disable Local File Restrictions menu. I am sorry, I don't have a Windows 7 PC close.

  • DBrownDBrown 1Password Alumni

    Sad to say, I don't see that command in the Develop menu in Safari 5.1.7 for Windows:

    Perhaps it was introduced in a later release. (Of course, 5.1.x is the end of the road for Safari in Windows.)

  • @DBrown‌ @roustem I do not think Safari on Windows has this problem. Chrome and Firefox do.

  • DBrownDBrown 1Password Alumni

    That's correct, @svondutch. Thanks for the reminder!

    (By the way, IE also will not open the local copy of 1Password.html, either.)

    @Theologian‌, this means you can use 1PasswordAnywhere in Safari for Windows, if that helps.

  • This has all been useful. Thanks for all your help.

  • DBrownDBrown 1Password Alumni

    Glad to help!

  • T_WillT_Will
    edited April 2014

    So up until today I've been using Chrome for Windows 7 at work to access 1PasswordAnywhere without any trouble. Today (out of the blue) I started receiving the following error in Chrome (Version 34.0.1847.116 m):

    The page at https://dl-web.dropbox.com says:

    A problem occurred when loading the "https://....../encyrptionKeys.js" file.

    I also tried IE8 (which 1PasswordAnywhere says it doesn't support) but it also receives an error message about loading the encryptionKeys.js file.

    I verified that the file exists in Dropbox. But after reading this thread, it's sounding more like a browser issue of not being allowed to run this javascript? I checked the Chrome settings, and it is set to "Allow all sites to run Javascript".

    I'm using a beta version of 1Password on my iPhone (in case that makes any difference), and I'm still able to access my vault as usual on my iPhone.

    Any suggestions?? I highly rely on 1PasswordAnywhere at work! :-)

  • edited April 2014

    I have the same problem at T_Will. Out of the blue, 1Password Anywhere stopped working. I haven't changed the files in any way or moved them. I bookmarked the HTML file in Dropbox so I could go directly to 1P AW in a new tab in Chrome, and now I get a 403 error from Dropbox when I open that link.

    If I just go straight to Dropbox (not using my bookmark), and navigate to the 1Password folders and open the HTML file from there, I get the "A problem occurred when loading..." error.

    This is pretty frustrating.

    Also, is it at all possible to use 1Password Anywhere without Dropbox -- using a different cloud storage service? So far I can say it doesn't work for me with Copy.

  • I'm wondering if a Chrome or Windows update broke the ability to load the .js file?

  • I'm having the same issue here while trying to access my 1p|anywhere from a keychain stored on dropbox. I'm using Chrome on Windows and the latest 1Password 4 beta.

  • Out of the blue, 1Password Anywhere stopped working.

    Dropbox has made a server-side change. This has broken 1PasswordAnywhere. We're working with Dropbox. Please hang in there. Thanks!

  • Whew, good to know! Might want to post that to Twitter so there isn't mass panic. ;-)

  • Can we get an idea of how long this might take? I absolutely require 1PasswordAnywhere. Heck, I had to create a new account simply to post to this thread because I don't have the password to my original one!

  • GyranGyran
    edited April 2014

    In the meantime while the 1Password team fixes the issue you can have a look at the this Chrome Extension called 1Passwordanywhere extension I've created if you are using Google Chrome.
    I have integrated it as a Dropbox application so it will have access to your 1password data (the data is only used by your browser). It will fill out login forms on any platform, 1Password dosen't have to be installed (Dropbox don't even have to be synced to the computer). It also has a discussion thread if you have any questions or feedback regarding the extension.
    If you get a error messages when trying to authenticating with Dropbox please add a comment this issue or a comment in the extensions discussion.
    Any feedback or suggestions are welcome!


    [Moderator's note: This extension is not associated in any way with 1Password or AgileBits, nor is it tested, supported, or recommended by AgileBits. Use this extension at your own risk.]

  • I have both mac and pc. I have 1password for mac only. There are occasions when I need to access a site on my PC. When I attempt to access 1password anywhere via drop box I received the following error:

    A problem occurred when loading the "https://dl-web.dropbox.com/get/1password/1Password.agilekeychain/data/default/encryptionKeys.js" file.

    It doesn't matter the browser. I've tried it on IE10, Chrome34, Firefox28 for windows. Same version on Mac less IE.

    All browsers on both platforms yield the same error.

    I have tried deleting the 1password folder from drop box, disable sync then re-synch which creates a fresh new folder, but I still get the same error.

    What else could be the problem?

    Thanks

    aptorrez

  • I just tried in firefox on my mac. I was presented with the Master Password prompt, but after entering the master password I received this message:

    Problem loading 1Password data file

    A key data file could not be loaded and 1PasswordAnywhere cannot continue without it.

    Please see this help guide for troubleshooting tips.

    This is very frustrating.

    aptorrez

  • DBrownDBrown 1Password Alumni

    Dropbox has made some kind of changes on their web site. We are working with them to determine the cause of the problem.

    We apologize for the inconvenience and thank you for your patience.

  • Thanks for the update. I will await your response.

  • shadrachshadrach Junior Member

    This isn't exactly a "Windows" issue, it is occurring on my Win 8 PC, my Chromebok, and my Mavericks MacBook.

    I'm trying to use 1PasswordAnywhere, but it's continuing to display this error. It has been working fine for a few months, but this weekend it just will not work.

    I've followed the steps on the help guide, but I can't seem to fix it.

    Any suggestions?

  • Is there a workaround?
    I'm at work, trying to get into my own mailbox and since I can't install anything here I've been relying on 1Password on Dropbox.

  • I also eagerly await a solution. The Dropbox / HTML / Javascript method is the primary way I access my 1Password file, and the only way that works on my Chromebook. This is absolutely critical to the product's function for me.

  • DBrownDBrown 1Password Alumni

    We're working with Dropbox to figure out what they've changed that's causing this problem and to get it fixed as quickly as possible.

    We apologize for the inconvenience!

  • Right, so I set up a local webserver and hosted the HTML files on that and it finally worked. Not impressed though, I was already on the brink of leaving Dropbox over the whole Condoleezza issue. If they are still trying to figure out what they changed that is not really a good sign either.

  • DBrownDBrown 1Password Alumni
    edited April 2014

    Thanks for the update and tip, @ivarni!

    We still have confidence in the dedicated folks at Dropbox. (To be clear, it's not that they don't know what they changed. :D It's that they don't know what among what they changed is causing the problem.)

    In fact, I've just received word that Dropbox is testing a fix, now.

    Thanks again for your patience!

  • DBrownDBrown 1Password Alumni

    We're told that Dropbox is looking at deploying a fix on Thursday.

  • I updated Dropbox. The problem still exists. It is the same problem which occurs when I am not using Dropbox. The encryptionKeys.js file that is created by 1Password contains embedded "newline" escape characters. This renders useless the mobile solution that AgileBits is providing. It will not work both portably and securely, with any browser, with or without the use of Dropbox. Copying the folder and its html files to transportable media, OR using Dropbox to transfer the 1PasswordAnywhere file folder which contains it, is unworkable.

    Frankly, the pointing of fingers at the developers of every browser as well as at Dropbox is a pathetic, gross and feeble, unwarranted abandonment of responsibility for AgileBits' own shortcomings.

This discussion has been closed.