Usernames filled in with " ' " instead of " @ "

BobHBobH
edited April 2014 in 1Password 4 for Windows

As the title says - Usernames are entered correctly, and work on Mac, but enter as Fred'bloggs.com instead of Fred@bloggs.com in Windows 7

Comments

  • DBrownDBrown 1Password Alumni

    What version of which browser are you using, @BobH?

  • Safari 5.1.7 - works well across platforms. (Unless it doesn't in this case). Of course, since you asked the question, I tried it in IE and it worked perfectly. Is this a known problem with Safari? (Or just my version? Bob

  • DBrownDBrown 1Password Alumni

    I haven't heard of this problem before, @BobH.

    I just used Safari 5.1.7 (the final version for Windows) in Windows 7 to save a new Login item with a username that included an "@" sign.

    Then I refreshed the page with the login form and pressed Ctrl+\; 1Password filled in the fields correctly, and the "@" sign was where I had typed it.

    So, I'm not able to reproduce the problem in what seems like the same setup.

    Please try creating a new Login item, to see whether that one behaves correctly.

    Let us know how it goes!

  • BobHBobH
    edited April 2014

    This is fun(!).

    I tried Ctrl+\; It worked perfectly.

    What doesn't work is using the Auto-Fill button against "Username" in the 1Password field.

    • If I set the cursor in Notepad and use Auto-Fill, it is OK.

    • If I set the cursor to the "Google" field at the top of Safari, it is OK.

    • If I call up Google - www.google.co.uk - and put the cursor in there - it enters an " ' ".

    I created a new login, with username fred.bloggs@domain.com (exactly that). Put cursor in this message and used Auto-Fill, got this:

    freD.bloggs'domain.com

    It does sometimes give a spurious capital too, as shown.

  • DBrownDBrown 1Password Alumni

    Just to make sure I understand, @BobH, are you talking about the Auto-type tool in the toolbar of the main 1Password program?

  • This is a known problem with Auto-Type and Safari. We're working on a fix. In the meantime, please do not use Auto-Type in Safari. Please use the 1Password browser extension for Safari. You can install this extension here: File > Preferences (Ctrl+P) > Browsers

  • DBrownDBrown 1Password Alumni
    edited April 2014

    I just created a new Login item (in the main 1Password program):

    I put the insertion point in a Notepad document, and clicked the Auto-type tool; 1Password typed the username, a tab, the password, and a carriage return, as designed and as you cited.

    I put the insertion point in the search field (next to the URL field) at the top of a Safari window, and clicked the Auto-type tool; 1Password typed the password and submitted the search (which implies that the carriage return was "typed," too).

    I put the insertion point in the Google field on the page that Safari displayed as a result, and clicked the Auto-type tool; 1Password typed the username (with the "@ replaced by a 2", NO tab, and the password, and submitted the search (which implies that the carriage return was "typed," too):

    (I can't put the insertion point in this message, because I'm typing it on a Mac, and 1Password for Mac doesn't include the auto-type feature.)

    Thanks for your help, @BobH! I'll bring this thread to Development's attention.

  • BobHBobH
    edited April 2014

    It looks as though we are in agreement. Thanks, @DBrown and @svondutch‌

This discussion has been closed.