App store thinks I have version 4.3 installed, but version 4.1.2 is running

At first I was baffled that the new version 4.3 is no different from my old version. I now see that version 4.1.2 is still installed.

I originally bought 1Password online, and so found remnants of older folders in the Library directory. I tried to deactivate all files by relabelling everything as *_OLD, as per your online instructions. However, v4.1.2 still launches and the app store still thinks I am updated to v4.3. What can I do?

Many Thanks.


  • mikeboremikebore Junior Member
    edited April 2014

    Which versions are showing in your Applications Folder?

    When you say you originally bought 1Password on line, that would be from Agile store not MAS so can't have been 4.1.2 which was a MAS only version.

    Have you done all installing since 4.1.2 via MAS? 4.3 from MAS should update and replace 4.1.2. Something is wrong if you have two versions of 1Password in the App folder, both installed from MAS. The MAS version is "1Password" and the Agile Store version is "1Password 4"

    When you say 4.1.2 always opens, do you mean when you click on the little iPassword Mini key in the menu bar?

    I hesitate to suggest this without understanding the above anomalies, but if you do have 4.3 in your Apps folder you could try quitting 1Password Mini then launching 4.3 from the Apps folder.


  • The original version I bought was v3.x. I had a similar updating problem when v4 arrived. I had assumed that the problem was now solved. I am not sure what MAS means; all my "updating" has been via the Apple "App Store" application. In my applications folder, the program name is Command Info tells me it is v4.1.2, created Jan 7th 2014. I had placed it in a folder called 1Password since by habit I used to save license keys etc as directory names with the application. There is no other version of 1Password in the Applications folder. v4.3 does not appear to be present. (Spotlight found 1Password 4.3.2.ipa in my iTunes/Mobile Applications directory, dated Nov 17th 2013, but that is clearly something different.)

    v4.1.2 opens when I double click the app icon in the Applications folder, and also when I open it via the iPassword mini key.

  • mikeboremikebore Junior Member
    edited April 2014

    Sorry MAS is Mac Apple Store.

    From your last post it is not clear to me why you said in the first post that "app store thinks I am updated to 4.3". Unless you were referring to the mobile app. Mobile apps show up in the iTunes app store, which is quite separate from the MAS . The latest version of the mobile app is 4.5.1.

    If you open the App Store app and click on the "updates" tab, is 4.3 update offered? should be from what you have said.

    What is showing in the "purchases" tab for 1Password?

    PS moving apps to other than the default location can cause update problems (for many apps) and might be the issue here. I would put the 4.1.2 app back directly in the apps folder.

  • The "Purchases" tab refers to my original purchase back on Aug 12 2012. When I click on the 1Password link, it takes me to the "1Password 4" MAS page where the drop-down declares "Installed." It does not state that version 4.3 itself is installed, but the page is advertizing v4.3. Yesterday, I had gone through what I thought was the normal install process when I found that the MAS had a 1Password v4.3 update ready. It is no longer being "offered," as it now believes that v4.3 is installed. The same failure to install seems to have occurred when v4.2 was released. I have now moved the app into the main Applications directory. v4.1.2 app, and mini-app, seem to be working fine.

  • mikeboremikebore Junior Member

    Have you tried running MAS update since you put the app back in default location?
    Have you any other partitions connected which might have 4.3 on? This could make MAS think 4.3 was already installed.
    You could try deleting the 4.1.2 app and reinstalling from the purchases tab. It should download and install 4.3.
    All a bit odd.

  • I deleted v4.1.2. I went to MAS and a new v4.4 appeared. I ran install but it did not appear in the Applications folder. Spotlight found it on an attached disk that I use for backups in a directory called "Installers." The backup disk does not have a system on it. I dragged the new 1Password over to Applications on the system disk, and now v4.4 seems to be running well. Your hint was right. It was not a partition, but on an unrelated USB-port backup disk. Strange, and unexpected. Thank you for your help.

  • MeekMeek

    Team Member

    Hi @creakyitem‌,

    I'm so glad to hear @mikebore's suggestion helped you get up and running! If you have any other questions, don't hesitate to ask!

This discussion has been closed.