Firefox 29.0 1Password extension buttons

Having just updated Firefox (on Windows 7, 64-bit) to version 29.0 yesterday (4/29/14), I noticed immediately that there are now two icons available (in the browser) for invoking 1Password. The standard "key" is there but there is also a "1P" symbol. I've not seen any other comments in the forum on this and I have sent the question in to the support team at AgileBits but I'm wondering if anyone else has observed this and if the two symbols supply anything but redundant functionality (I can't see anything different in the way they work). Also, if they are redundant does anyone know how to remove one or the other of them? Everything seems to work OK (although I haven't tested 1Password exhaustively) and on Chrome, there's still only one icon (the "key")... so it's something that happened related strictly to the Firefox update (my version of 1Password is 1.0.9.340).

Comments

  • DBrownDBrown 1Password Alumni

    Hi, @LoneRider.

    I just now updated Firefox from 28 to 29, and I didn't get the extra extension that you describe. It should be easy to fix, though.

    1. In Firefox, choose Tools > Add-Ons.

    2. On the page that appears, delete any 1Password extensions listed. (It sounds like you'll see two.)

    3. In 1Password, choose File > Preferences, and select the Browsers tab.

    4. Click the "install" button next to Firefox, and follow the instructions on the web page that appears.

    I hope that helps. Please let us know how it goes.

  • I did completely remove/re-install the Firefox add-on but to no avail (both icons went away at remove and then both re-appeared at re-install). However, working with the tech support staff at AgileBits, they were able to duplicate the problem (and I'm a bit surprised that you did not see it). Although the total solution is not known, part of the issue appears to be that Firefox 29 displays (or re-displays) all of the add-on icons on the ToolBar by default. Where the second icon for 1Password originates, I don't know, but the way to get rid of it turns out to be straightforward (thanks to Stefan at AgileBits tech support). Click on the options tab (hamburger like symbol at the right side of the ToolBar) and select "+ Customize" on the lower left. Then right-click on "Show 1Password" and select "Remove". While this action doesn't allow you to select which one of the two icons to remove, it does remove the "1P" duplicate icon. As far as I can tell, you cannot then remove the "key" icon (should you so desire) by the same method, so that one can only be removed, I think, by disabling the add-on (which makes sense). Works for me.

  • DBrownDBrown 1Password Alumni

    I'm glad you got it worked out! The developer of the software is often an indispensable resource. ;)

  • Merak75Merak75
    edited May 2014

    I am having this same issue. Please report back any solutions, thanks.
    As of now, I just customized the tool bar and dragged the 1P icon out.

  • I am having this same issue. Please report back any solutions, thanks.

    Please follow these steps:

    1. Open Firefox 29
    2. Click on the hamburger button in the upper-right corner
    3. Click on "Customize" in the lower-left corner of the popup window
    4. On the toolbar, you should see the following text: "Show 1Password" (no quotes)
    5. Right-click on "Show 1Password", then click on: "Remove from Toolbar"
    6. Click on the green button labelled "Exit Customize"
This discussion has been closed.