1Password button disappeared after Firefox 29.0.1 update

The 1Password key disappeared from my browser toolbar after Firefox updated itself to 29.0.1. I tried updating my 1Password app installation to 3.8.22 (build 32010) then removed and re-installed the browser extension. When Firefox restarted, the key button was there. But on a second browser restart, it was gone again.

This is on Mac OS X 10.9.3.

I saw a similar problem in the Windows forum, but the workaround involved an anti-virus tool that doesn't apply in my environment.

Any ideas?


  • MeganMegan

    Team Member

    Hi @scotthz,

    Please look in Firefox's Add-ons pane. Is the 1Password extension still shown there? Please ensure that it is enabled.

    If it is properly enabled, check in the 'Customize' pane to see if it has just been bumped off the menu bar by some other extensions.

    I hope this helps!

  • Thanks for the response. I had checked the add-ons, and it was there, and enabled. Nothing relevant on the Customize pane. Went back to Add-Ons, and just to verify, tried disabling then re-enabling. This resulted in two 1Password-related buttons showing up on the toolbar. One with the normal key icon, and another which was not wholly rendered. That is, I can see "1" adjacent to an empty white box with no border, visible only against the gray toolbar background. Hovering over the key button doesn't show anything; hovering over the other button shows "Show 1Password". Clicking the key button works as is did before. That's the good news.

    The bad news is that when Firefox is restarted, both buttons disappear, and still nothing under Customize. Going back to Add-Ons, the disable/enable workaround still works.

    Thanks again. It'd be nice to get back to the behavior I had before, but it helps to have found a workaround.


  • MeganMegan

    Team Member

    Hi Scott ( @scotthz‌ )

    Thanks for the detailed response! I was seeing some weird behaviour with the extension earlier, but since reinstalling the extension (and restarting the computer), I'm unable to recreate it. Perhaps the trouble is that I'm not using version 3 on a regular basis. However, I do remember that the first time I noticed both the key icon and the 1P icon in the menu bar, I used 'Customize' to drag the (badly rendered) 1P off the menu bar. It has not since returned, even after reinstalling the extension.

    I hope these odd steps help, in any case I am passing along your thoughts to our developers. Our efforts are largely focussed on 1Password 4 at this point, but they may be able to clear up this mystery better than I.


This discussion has been closed.