Can't get 1Password to fill in website in my app [Fixed]

MikeTMikeT Agile Samurai

Team Member
This discussion was created from comments split from: 1Password extension doesn't fill in properly with no username field.


  • I haven't been able to get the extension to work at all on the sites I've tried to login to. Not even the extension as part of the test ACME Browser app. After I choose the login credentials from the extension to use, the view disappears, but the values don't go into the login fields. I've tried it on a few different web sites so far. I'm using beta 19. Does it matter if the website offers you a mobile version vs. the desktop version where I would have first setup my login credentials to be managed by 1Password? Perhaps they use different field names in the desktop vs. mobile versions of the site. However, I also tried it with iTunes Connect which doesn't present a mobile version and it still didn't auto-fill my login credentials.

  • Its definitely working for me on other sites (beta 19). Just not this one.

  • Ok, well this is weird. I can login to this site using ACME browser, but not with my own app. I tap the forum's Sign In button, the login form appears. Then I tap the 1Password extension, choose 1Password from the activity sheet, then login to 1Password with my master password, then tap on Agile Forum. The view dismisses and so does the login form. But nothing is filled in. Very strange.

  • Oh, I think it's because I'm doing stuff in viewWillAppear and viewDidAppear on my website controller. I'll have to investigate that. Probably my fault.

  • Ok, I fixed it. I was loading my web content in viewDidAppear. Since the 1Password extension displays as a full screen modal view, it triggered viewDidAppear which basically re-loaded the page and lost the injection of the login credentials from 1Password.

    Other than this little snafu of mine, it was brilliantly simple to integrate the 1Password extension into my app.

  • MrRooniMrRooni

    Team Member

    Glad to hear it @tapzapp!

This discussion has been closed.