1Password Doesn't Work with DoD's Self-Service Center

Both DoD and DVA are moving towards a central authentication system.

To login to TRICARE, for example, it's:

https://myaccess.dmdc.osd.mil/identitymanagement/authenticate.do?execution=e1s1

To login in to VA, it's:

https://myaccess.dmdc.osd.mil/identitymanagement/authenticate.do?execution=e2s1

For some reason, 1Password can remember both the username and password, but can't enter the password into the form.

Any thoughts?

Comments

  • sjksjk oversoul

    Team Member

    Hi @rtvanhook,

    I'm sorry you're having trouble getting 1Password to fill the password field on DoD's Self-Service Center. Does the sign in page you're using look like this?

    As a possible workaround, can you try disabling auto-submit and click in the password field after filling?

    Then click Login to manually submit if the password field was filled after clicking in it.

    To disable auto-submit for a single item, you can edit it in 1Password and change the submit option to Never submit:

    To disable auto-submit for all sites, you can disable the Automatically submit logins after filling option in the Browser tab of Preferences. Or just disable Submit Login in 1Password mini:

    Quickly toggling auto-submit

    Please let us know if the workaround is successful (and I'll file a bug report) or if you still need more help. Thanks!

  • That's the site, and disabling auto-submit doesn't fix the problem. I've tried in Safari, Firefox, and Chrome. It still remembers the password OK, but won't submit it.

  • sjksjk oversoul

    Team Member

    Hi @rtvanhook,

    Thanks for the followup. Sorry this form is still giving you trouble.

    With auto-submit disabled, what happens if you click in the DS Logon Password or MyPay Password field after 1Password fills the DS Logon Username or MyPay Login Id field on the page? Here's a short video clip showing click-to-fill behaviour here (in Safari):

    DS_Logon_Password_-_click-to-fill.mov

    If that doesn't work for you, please try saving a new Login item manually on the page and testing with it. You currently won't be able to fill both fields (and auto-submit) because of the bug and I'm filing a report for that.

    I hope this helps!

  • It's a reasonable workaround if, as you suggest (although your .mov link is dead..) I a) try to fill with auto-submit disabled, and then b) click in the password box.

  • thightowerthightower T-Dog Agile's Mascot

    It must have been still uploading lol. I can see the movie in Safari thought its very very short. like 3 seconds.

  • sjksjk oversoul

    Team Member
    edited September 2014

    Hi @rtvanhook,

    Thanks for letting me know you got that workaround working. :)

    After first filling the DS Logon Username or MyPay Login Id field, you can can also tap the Tab key a couple times to select and fill the empty DS Logon Password or MyPay Password Id field instead of clicking in it.

    Not sure why the video clip link fails there. A few folks here tested it without any issues. Edit: as did @thightower; thanks. Yup, it's only a few seconds long. :)

    I've filed a bug report for the password field not filling with the first fill. Thanks again!

    ref: OPX-607

This discussion has been closed.