Sync problems with Dropbox

idgoddardidgoddard Junior Member

I have several devices with 1Password; Mac, 2 iPads, iPhone. On the iOS devices I have set to Sync with Dropbox. The MacBookPro syncing is set to Dropbox as well and I can see the 1Password folder - 1Password.agilekeychain in Dropbox. I am adding a new iPad fro my set up and I cannot get it to sync. I cannot get the iOS devices to sync. I am getting a message 'Vault Mismatch' - .... the primary vault is different from the vault you selected in Dropbox. The two vaults are different; 1159 items in one, 807 in the other. I have tried to merge anyway but I reach a point where it requires a password to "Please unlock you 1Password data in Dropbox ...." I am stuck ... any help will be appreciated

Comments

  • Hi @idgoddard‌

    I'm sorry to hear that you're having trouble keeping things synced up lately. I've got a few basic things that we want to check regarding Dropbox first, before we get into the serious troubleshooting:

    • Please ensure that Dropbox is installed and running on your computer
    • Check that you are logged in with the same account on all computers and devices
    • Confirm that Dropbox sync is selected in 1Password > Preferences > Sync on your Mac
    • Confirm that Dropbox is selected in Settings > Sync on your iOS device

    If all of those items check out, let's run a test and see where things are getting tripped up:

    • Create a test entry on your Mac ("Test, Mac") and add some data
    • Create a test entry on each of your iOS devices ("Test, iPhone/iPad") and add some data
    • Does "Test for Mac" show up on either of your iOS devices?
    • Does "Test for iPhone" and/or "Test for iPad" show up on your Mac?
    • Log in to the Dropbox website and click on the 1Password.html file inside your 1Password.agilekeychain folder
    • Enter your Master Password
    • Do either or any of your test entries show up in your database here?

    Please let me know the results of this little experiment - once we have a better idea of where things are going sideways, we should be able to get this straightened out simply for you :)

  • idgoddardidgoddard Junior Member
    edited June 2014

    Thanks for responding. I guess we'd better take these one at a time;

    First - on Mac, 1Password4>Preferences>Sync>DropBox - A drop down Dropbox Sync appears, "Choose the Dropbox folder". I navigate to the Dropbox folder in the Documents* folder and click Choose. "1Password found existing data in Dropbox. It will be merged .." I click Merge with Existing. Dialog Box - 1Password detected that data is different .... I can only enter password for Dropbox. It will not accept my Dropbox password. I have tested the password with Dropbox and it works. Will NOT work here. (btw I recently updated this password)

    • Note - I also navigated to the Dropbox folder in the root and there is a 1Password folder there, I tried selecting that 1Password.agilekeychain file with the same results. There is something weird going on with the 1Password dialog box requesting password to Dropbox. I am trying to attach a screen Grab without much success.

    image

  • Hi @idgoddard‌

    I sincerely apologize for the confusion here. The password that we are looking for here is the Master Password of the vault stored in Dropbox, not your Dropbox password.

    We are looking to clarify this language in the future (I can see how you thought it was looking for the Dropbox password), but for now, please try entering your Master Password in this field. That should get you up and running!

    .

  • idgoddardidgoddard Junior Member

    Megan, I worked around this issue by switching to iCloud sync on all devices - seems to be working. I don't know why dropbox is upset with 1Password but maybe they'll get over it!

  • Hi @idgoddard,

    I'm glad to hear you found a solution that works for you, although I'm sorry to hear that you weren't able to get Dropbox set up. If you decide you'd like to troubleshoot this further, please let me know and we'll get it straightened out. :)

  • I too am struggling with the Dropbox sync. Nothing I do seems to make any difference. I have un-synced all my devices (MacBook Pro, iPhone 5s, iPad), deleted the agile bits file in Dropbox, shutdown all devices and re-started the syncing - first with the MacBook - this appears to work (at least it creates an AgileBits file in Dropbox. But then, neither of my other devices Sync.

    iPhone says - "The operation could;t be completed/ (NSURLErrorDomain error -1012.)
    iPad says "Error loading app - internet connection lost" - when in fact I have a full connection, 5 bars

    Please can you assist - what was a great app, is rapidly becoming useless.

    Thanks.

  • jofallonjofallon Junior Member

    I may be having a similar Dropbox issue. I changed the master password on my primary vault, and various devices recognize either the old password, the new password or neither. Of course, I upgraded to IOS 8, and there have been several Dropbox updates in the last few days. Relying on Dropbox right now may be a bit risky till they work through the initial problems.

  • Hi Chris,

    I'm so sorry that you're having trouble here. Since resetting sync hasn't got things working for you, We'll need to take a closer look at your system here to determine where things are getting tangled up.

    I'd like to ask you to create some Diagnostics Reports, one from each of your devices.

    —Mac—
    http://guides.agilebits.com/knowledgebase/1password4/en/topic/diagnostics-report#mac4

    —iOS—
    http://guides.agilebits.com/knowledgebase/1password4/en/topic/diagnostics-report#ios4

    Then attach the entire file to an email to us: [email protected]

    Please do not post your Diagnostics Report in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your Diagnostics Report in our inbox.

    A short note here once you've sent the Report in will help us to keep an eye out for it. :)

    Once we see the report we should be able to better assist you. Thanks in advance!

  • Hi @jofallon‌

    I'm sorry to hear that your Master Password isn't syncing across all devices. We've seen this issue before, and, although it seems a bit disconcerting, it is no reason to distrust your sync source. Let's reset sync here to see if that gets things behaving better:

    • On your iOS devices, open 1Password 4 for iOS, tap Settings > Sync > Sync Service and choose 'Disable Sync’.

    • On the Mac, open 1Password 4 for Mac, and click the 1Password menu, then Preferences. Click Sync, and click Change syncing.

    • Check the box to remove the data from Dropbox and confirm that you want to disable sync.

    • Restart the Mac and iOS devices.

    • Check your Dropbox folder and delete any other 1Password folders or files that the remove data checkbox did not take care of.

    • On the Mac, go back to the Sync preferences, and click Dropbox. Click Choose vault, then navigate to your Dropbox folder and select Open. This will regenerate a 1Password folder in Dropbox, and that will contain a new 1Password.agilekeychain file.

    • Allow Dropbox to fully sync.

    • Go back into the iOS app and re-enable Dropbox sync. That should get everything on the same page for sure.

    Please let me know if you're still seeing a disconnect with the Master Password after resetting sync, and we'll investigate further :)

This discussion has been closed.