Qustodio preventing 1Password extensions from working

Hi all,

I recently installed Qustodio (parental control software) on my Mac. Everything works great except 1Password extensions.

  1. Even though 1Password extensions are installed on all my browsers, the "Add ____ extension" still shows in the 1Password Mini icon in the menu bar in each app. Pressing Command+\ does nothing.
  2. When I manually click on the 1Password Mini icon and select which account I want, which is supposed open that my account on that website, I get the following error message:

"

The troubleshooting page recommended on that error message did not offer any solutions that worked.

Help? Thanks.

Comments

  • P.s. Looks like I'm not the only one who has had problems with this software.

    https://discussions.agilebits.com/discussion/18359/cannot-fill-item-in-browser

  • Their main page states you can block applications although that seems to be a premium feature, is that the version you're running? (rather than the free one). If it is you could see if 1Password mini is being blocked. Can't say I've heard of the program before so no little about it. Below is an image from their site showing you where to configure what is running. They don't seem to have a wealth of material online regarding their product, that or I missed where the manual was.

  • Hi @battlesman‌,

    1Password Mini needs to be able to communicate with the main app and the browser extensions. It does so using web sockets. The message that you are seeing often shows up when this communication is blocked.

    The discussion that you linked to includes a link to our 1Password fails to fill data Knowledgebase article. Did you have a read through to see if any of the solutions there help? In particular, if you are able to:

    See if they’re [Qustodio is] blocking 1Password from communicating via 127.0.0.1/localhost

    I'm not familiar with Qustodio, but if they have an option to whitelist the local host (127.0.01), that should fix the issue you're seeing.

  • Thanks, @Littlebobbytales and @Megan.

    I have tried the steps you mentioned. 1Password and 1Password Mini are both allowed. I've even added other settings in both Qustodio and System Preferences's web proxy.

    See attached. Please help me understand what I'm missing.

    battlesman

  • Got it! Sometimes the solution is easy, but unexpected! I couldn't tell you why this solution works, but when the "Hide the menu bar icon" box is checked during installation, it prevents 1Password from doing its work. When you leave the box unchecked, that is, allow the menu bar icon to show, 1Password works as expected—keyboard shortcuts and all!

    I discovered this when I was installing it on my Yosemite partition. It worked fine on Yosemite, but not on Mavericks. So I reinstalled Qustodio on Mavericks leaving that box unchecked, and sure enough it works fine now!

    I'll leave it to you guys to investigate why that trick worked :)

    Thanks for your help, y'all!

  • So an option to hide the menu bar icon of Qustodio during its installation caused 1Password to stop working? very odd. Nice find discovering it!

  • Hi @battlesman‌

    I'm so glad to hear that you got it working! I'd be curious to hear the answer to @littlebobbytables‌ question though - are we talking about the menu bar icon of 1Password or Qustodio? It sounds like you're talking about Qustodio, but there is a similar option in 1Password and changing this option shouldn't make a difference between 1Password behaving and not.

    Thanks for clarifying! :)

  • @megan I'm referring to Qustodio's menu bar icon, not 1Password's. I haven't the slightest clue why that works, but it does!

  • Hi @battlesman‌

    Thanks so much for clarifying! I'm a bit baffled as to why that works as well - sounds like there might be something a bit wonky going on on their end. But I'll pass it along to our technical gurus as well, just in case. :)

  • @megan I'm totally bewildered. Sometimes it works fine, other times not. It's quite inconsistent! I'll do some more investigating...

  • @megan When it stopped working again, I reinstalled, and sure enough it works again. My current guess is that it's connected to the "Time Limits Limits" tab under "Rules." I'm going to experiment not messing with the time limits and see if that helps.

  • Hi @battlesman‌

    Please do let us know how your investigations go! I've spoken with a colleague here who has done trouble-shooting with Qustodio before, but he has been unable to reproduce any errors, so we're curious to see what you determine.

    This might be something you need to talk to Qustodio support about - they might be in a better position to help you. If you do so, please direct them to this article in our Knowledgebase: Configuring a proxy server or firewall that discusses the communication that 1Password does.

  • Thanks, @megan. I'm open to being a singularity, but since I just clean installed my entire OS (Mavericks), I wouldn't think it's something unique to me. Thanks again.

  • Hi - any update on this? I'm having the same exact issue since installing Qustodio yesterday. I'm potentially willing to try re-installing it without adding the icon to the menu bar, but since that seems to result in an inconsistent improvement, I'd prefer to get to the actual cause. Thanks in advance!

  • sjksjk oversoul

    Team Member

    Hi @Gammon2004,

    We don't have any new information yet about the actual cause of this problem. Maybe @battlesman has done some further testing and/or contacted Qustodio support and knows more about it?

    As @Megan mentioned earlier:

    I've spoken with a colleague here who has done trouble-shooting with Qustodio before, but he has been unable to reproduce any errors, so we're curious to see what you determine.

    If you do try the same temporary workaround that @battlesman discovered please let us know your results. Thanks!

  • @Gammon2004‌ Try contacting Qustodio support. I've tried contacting them twice to no avail.

    @sjk I've yet to discover the real issue, or fix it permanently. Please let me know if you find a solution!

  • MikeTMikeT Agile Samurai

    Team Member

    If they've gotten back, let them know that we'd be happy to help with anything they need to figure this out, and they can also contact us directly at [email protected] to figure this out.

    At this moment, we don't have any ways to work around Qustodio here.

  • Hello,

    I can confirm this is an Issue for me too with the latest version of both Qustodio and 1password. I actually found in Mavoricks disabling browser verification check fixed the issue (obviously not idea) however since upgrading to Yosemite both computers won't fill passwords even when the "Verify browser code signature" is unchecked. I believe that 1password and the extension are able to talk to each other though as when I browse to a website the 1password extension provides the password under the drop down box for the requested domain however it will never fill it for me.

    When I click the 1password icon in the top menu bar (1password mini NOT the browser extension) it does say "Add safari extension..." even though it is on safari and using the extension in safari i can search, view, copy, edit, etc. I'm not sure if this is a 1password bug or something weird going on.

  • Yeah I think Qustodio doesn't work with Yosemite at all currently, which is what their website says (it also says they'll post an update soon). My macbook air is on Yosemite and not working, but the others are still working. So independently of that, I think we'll likely still have the issue once they get it up and working. What are the potential risks of leaving 'verify browser code signature' unchecked? If it's only being used on sites that I know and trust, it seems like it might not be that big of a risk, but I don't know enough about the security issues involved to say for sure. Thanks!

  • MikeTMikeT Agile Samurai

    Team Member
    edited October 2014

    Hi guys,

    @kvwls,

    I'm not sure if this is a 1password bug or something weird going on.

    If you disable or uninstall Qustodio as a temporary test, you should be able to test to see if 1Password works much better. If yes, then the issue is with an interference between 1Password and Qustodio. At this moment, this is not much we can do to fix this. 1Password needs to be able to communicate between the extension and 1Password mini to securely share data.

    @Gammon2004‌,

    What are the potential risks of leaving 'verify browser code signature' unchecked?

    This is used to block unauthorized/infected browsers and/or websocket servers from accessing 1Password mini to communicate with it.

    If you only use authorized browsers like Chrome, Firefox, Safari, and/or Opera, you’ll be okay to have this turned off temporarily until Qustodio updates their app.

This discussion has been closed.