Some Rich Icons not propagating

Hi,

I'm running the latest versions of 1password for Mac and iOS.

I have edited some of my logins and software licenses on my Mac to use personal icons. All my recently personalised login icons have propagated to my iOS devices. The strange thing is that my recently personalised software license icons have not propagated.

Any ideas?

Thanks.

Comments

  • WinnieWinnie 1Password Alumni

    Hi @steve23094,

    after reading this I checked my own vault and found an item where the image was not propagated as well. I could fix it by adding the icon to the software license again and syncing.

    Could you see if that works for you? Do you remember when you added the icons?

  • Hi @Winnie‌

    There are some strange shenanigans going on.

    The icons that were not propagating have been added over the last few days, but the last time I changed them before that was quite some time ago. So I couldn't begin to say at what point things broke. I am synching through Dropbox. Something that occurred to me was that all the icons that were not propagating were dragged from somewhere else and straight into 1Password, and they did show as correctly updated on 1Password for Mac.

    Tonight I tried to force updates. Because I had spent some time sourcing icons from different places I decided the easiest thing to do was to copy and paste them within the 1Password app. I found that just copy and pasting within the same license didn't work, I had to create a dummy license and first copy the icon to there and finally back again to the original entry. When I did this I noticed the icons within 1Password changed from having a blank background to having a slightly visible background and therefore a clearly defined square edge. The changes then propagated through to my iOS devices.

    Just before finishing up, 1Password on my iPad crashed and bizarrely I lost the Rich Icon from a completely different software license that I had not been dealing with. It seems to me there is a bug somewhere that is causing corruption in these icons.

  • Come to think of it are you able to explain why an icon dragged into 1Password has a transparent background, and yet when copied and pasted (as per above) it then shows a visible background? And possible how to fix that?

  • And now 1Password for Mac is not syncing with Dropbox properly, perhaps this was the source of the original problem.

    I can only get 1Password to sync when I add a new dummy license which then propagates to my iOS devices, but when I move it to the trash 1Password does not initiate a sync (I can see this by looking at the last sync time in the Preferences). So I end up showing the entry on my iOS devices that is now in the trash of 1Password Mac.

    Exiting the app and restarting on OS X or iOS does not get them back into sync, what to do?

  • Yep, confirmed. Right clicking on a software license and selecting 'Move to Trash' does not initiate a sync, looks like a 1Password for Mac bug.

  • Drew_AGDrew_AG 1Password Alumni

    Hi @steve23094,

    I'm sorry about the problem with the sync not initiating when moving an item to the Trash. Our developers are aware of this and working on a fix.

    As for the problem with custom icons, can you please clarify exactly what happens, and the steps you're taking? What works as far as getting the icon to sync to iOS, and what doesn't work? I'm trying to figure out exactly what you mean about icons having blank or visible backgrounds. If you could possibly post screenshots of that, it would be helpful. Thanks!

  • edited November 2014

    Hi @Drew_AG‌,

    Good to know that you're working on the Trash bug.

    It's been a long time between when I last added some software licenses with custom icons and last week when I noticed problems. Since then I have updated to Yosemite and several version of 1Password for iOS and Mac, so I can't say when the issue was introduced. I am syncing with Dropbox.

    Last week I added some new software licenses with custom icons. I sourced icons from various sources, including from the Windows apps themselves. I used a Windows program to convert the icons into Mac format and moved them into the OS X file system. I then dragged them into 1Password for Mac whilst I was in Edit mode. The icon displayed correctly in 1Password for Mac but did not propagate through to 1Password for iOS (iPad or iPhone).

    Under 1Password for Mac and iOS I forced syncs and they showed success, other data was being updated just not the icons. Repeated drag and dropping into 1P4M did not force an icon update.

    To force a sync I had to create a dummy license, enter edit mode on the original license, CMD+C the icon, CMD+V the icon into the dummy license, CMD+C the icon in the dummy license and then CMD+V into the original license. This would force an icon update across all my devices.

    During this process an icon which originally had a 'see through' background now had a visible background. Here is a good example, Guild Wars 2 originally had a transparent background but when I had to update via the copy and paste method the background now becomes visible. You can see the square border, before you could only see the '2' graphic:-

    Thanks.

  • Drew_AGDrew_AG 1Password Alumni
    edited November 2014

    @steve23094, thank you for the additional information about that! I did some digging into this, and it turns out this is another known issue. You can take a look at this discussion on the Mac forums for more information.

    I'm sorry for the inconvenience! Our developers are working on fixing this as well. Thank you for taking the time to let us know about your own troubleshooting and what you were able to find, I will let our devs know. :)

    ref: OPM-1478

This discussion has been closed.