Security Settings and Auto Lock

My settings don't seem to be sticking in 4.2 beta 1. I'm on my Nexus 5 with Lollipop. I've created a pin yet I keep being asked for my master password and I turned off auto lock but I have to enter my password every time I open the app. I even turned off lock on exit.

Comments

  • Same here. Back to the release build.

  • LevarLevar
    edited November 2014

    Can confirm this is happening to me as well. On the same device Nexus 5 on Lollipop and version 4.2 beta 1 20141112 of 1Password

  • mverdemverde

    Team Member

    First of all, I want to thank each of you for being early adopters and testing our beta on Lollipop! And second, I want to thank you for taking the time to write in about this issue. Unfortunately, I am not able to reproduce the issue on Lollipop on my Nexus 5 or my Nexus 7. With a little testing though, I think that we should be able to figure out what's going on here.

    One thing to consider is that this may not be anything to do with the settings themselves. Regardless of whether Pin Code, Lock on exit, or Automatically lock are set, if the application is terminated you will need to re-enter your master password. This applies both when you terminate the app yourself by tapping the overflow menu and selecting exit and when the system terminates the app (for example, in the case of low memory conditions).

    If you have lots of background apps and/or services running, this may cause 1Password to be terminated when it is put in the background. Running an older build of Lollipop on your device can make this even worse, as the developer previews of Lollipop had a number of debugging and testing features enabled which would also consume resources.

    In order to try to rule out this possibility, could I get you to report back on the following:

    A. Lollipop build number

    Go to Settings > About phone > Build number (at the bottom of the screen)

    B. Device memory

    1. Go to Settings > Apps > Running (the middle tab on the apps screen)
    2. Tap the home button
    3. Launch and unlock 1Password
    4. Tap the recents button and switch back to the Settings app
    5. Write down the RAM numbers for System, Apps, and Free

    C. 1Password diagnostic report

    1. Launch and unlock 1Password
    2. Set the lock settings to your desired configuration
    3. Tap the home button and confirm that the problem still occurs
    4. After unlocking 1Password again, go to Advanced > Email diagnostics > Send mail
    5. Paste the URL for this discussion (https://discussions.agilebits.com/discussion/31436/security-settings-and-auto-lock) in the body of the email
    6. Send the report.

    For parts A and B, feel free to post the details to this thread along with anything else that you discover. For part C, provided that you include a link to this discussion, I will be able to easily connect the dots :) Looking forward to helping resolve this issue for you!

  • LevarLevar
    edited November 2014

    You're welcome, I'm quite glad to be an early adopter and testing the beta.

    I'm on the official Lollipop, though I did not update through nornal OTA method. This is a ROM, but it is based off the officially Lollipop images and nothing else.

    Before opening 1Password

    After opening it.

    The app doesn't show up in the " Running" list.

    As for "C. 1Password diagnostic report” I have actually sent in reports, but not in those steps. I will follow those steps and send in the report ASAP.

  • mverdemverde

    Team Member

    Thanks for the info @Levar. Based on the information you provided, it doesn't look like a pre-release build of Lollipop is the culprit here. It also doesn't look like there is any kind of serious memory pressure on your device either. Once I get your diagnostic report, I'll take a look and see if anything jumps out at me there. In the meantime, I have a possible work around for anyone experiencing this issue...

    After my previous post, I asked our development team to keep an eye out for any occurrences of this issue during testing. Although we haven't yet figured out steps to reproduce it consistently, a couple of our team members were able to reproduce the issue. In both cases, they were able to resolve the issue by exiting 1Password. Hopefully this will work for you as well (at least until we are able to fix the issue and release an update). Please try the following:

    1. Launch and unlock 1Password.
    2. Tap the overflow menu in the top right and select Exit.
    3. Tap Exit in the confirmation dialog.
    4. Launch and unlock 1Password.
    5. Go to Settings > Security and adjust the settings as you like.
    6. Tap the home button.
    7. Check that 1Password now observes the Lock on exit setting.

    Please let me know how this works for you. The fact that this worked in our case suggests that this may be an issue with settings changes not being updated on the first run. Information from you on how this works will provide more clues to the puzzle.

  • FWIW, I had this exact problem on my first run of 4.2b2, which I had installed to replace the release version of 1Password. This was on the Lollipop official release, installed OTA.

    After killing and relaunching 1Password, it hasn't (so far) reoccurred.

  • saadsaad

    Team Member

    Thanks for confirming you were also experiencing this issue during the first run after updating.

This discussion has been closed.