Master Password cursor not advancing

dcwhitdcwhit
edited October 2014 in iOS

I updated to Ver 5 on iPad and iPhone. Everything works well on the iPad Air. On the iPhone 6 when I try to type my master password the last 5 characters overlay each other, i.e the curser does not advance. I was able to access 1Password the first time after upgrading on the iPhone 6. Every attempt after that the curser won't advance after several characters.

Comments

  • After deleting and reinstalling the app several times it appears to be working properly now

  • There is something strange about the Master password entry box - I paste in part of my password after a long known section. The pasting does not work smoothly - pressing to bring up the past menu is intermittent - sometimes I have to move the cursor back a few character then forward - very fiddly.

  • BenBen AWS Team

    Team Member

    Glad to hear your issue was resolved, @dcwhit‌

    @jebr‌ I'm not aware of anything specific in 1Password that would cause that difficulty. Do you have the same trouble in any other password fields, or is it limited to the Master Password field?

  • I wonder whether there is any link at all between @jebr's problem and @hawkmoth‌'s problem described here.

    Stephen

  • MeganMegan 1Password Alumni

    Hi @jebr,

    I'm sorry to hear that you're having this trouble. It is odd. I've spoken with one of our developers about this, and we'd love to get some more detail to try and track this down:

    • As @bwoodruff‌ requests - are you seeing this in any other password fields that you paste into, or is it just the Master Password field?
    • What is the version number of 1Password, and iOS on your device?
    • Just in case it makes a difference ... which model of iOS device are you using?
    • Have you seen odd behaviour for the keyboard in any other apps?

    The more detail you can provide, the better the chance that we'll be able to reproduce the issue, which is the first step in finding a solution. :)

  • @Stephen_C‌ - I wonder too.

  • Hi

    I'm using 1password IOS 5.0.1 and IOS 8.0.2 on an iPhone 5s.
    I have re-tested a ton of times and there is definitely some sort of delay issue. I can reproduce the problem by just typing any random 11 characters into the Mater Password field the tapping into the box immidiatly brings up the Select All / Pate buttons. However if I type 12 characters in first then tap the box at the end of the text nothing happens. Through some combination of repealy tapping or tapping for longer at the end of the text I get the paste option. If I tap within the masked characters straight away the magnifying glass & Select/Paste options appear. So, it seems that the GUI is not responding to the tap further right than 12 characters.

    JEBR

  • Oh and I have not noticed any problems with any other dialog boxes just the 1password master password one.

  • MeganMegan 1Password Alumni

    Hi @jebr,

    Thanks so much for getting back to us with those details! I've been able to re-create this bug by following your steps. I've filed an issue with our developers and we'll do our best to get this fixed for you just as soon as possible!

    ref: OPI-1810

  • I just rechecked this thread and can now say I cannot access 1P again. It worked yesterday now the curser will not advance again past 13 characters.
    1P v 5, iPhone 6, IOS 8.

  • JasperJasper

    Team Member
    edited October 2014

    It appears the password input field doesn't extend all the way to the "lock" button, which may be causing some confusion. I'm not sure if it's by design, or a bug, but we've filed it in our internal tracker so one of our developers will take a look.

  • I tried searching the forums but haven't been able to find anyone else reporting these issues. For several weeks now I've been experiencing a lot of issues using 1Password on my iPad Air 2 and iOS 8. For instance, when searching I sometimes can only enter the first 5 characters, I have a lot of trouble creating and editing logins or generating passwords. It's hard to describe what's happening other than if this was a computer I'd say the cursor was moving around all on its own. I try to tap to search and I end up selecting another login's notes. Or trying to type in the website for a new login actually moves me down the page. There has been a lot more odd behavior and unfortunately it's not too usable in this state.

    I've tried deleting and re syncing via Dropbox everything but no luck. It works great on my iPhone 6 running iOS 8. Anyone else experiencing things like this or have a suggestion to fix it?

    Thanks!
    -Dan

  • There is an iOS bug that sometimes, but not always, comprimises the keyboard so that it won't accept any input on the far right side. I know it messes me up on entering my master password, and others have said it affect the internal function of the app too. I can't confirm that, because when I'm bitten by the bug, I can never get in.

    I can't tell if this is related to your issue or not. But it is a problem I have on my iPad Air. (not Air 2)

  • I just had this issue again. I tried to edit an existing login and delete the old password to update it with a new one. After I deleted the old password I tried to type in the new password but when I tried to type in the 2nd character, the cursor jumped to the notes field. I tried in portrait mode next but the keyboard was stuck in landscape mode and half of it got cut off. I then had to cancel the whole edit since it was randomly editing fields all across the login and even prompted me if I wanted to delete the login completely (which I did not). I'd be happy to provide more details but I'm not sure what would be helpful to troubleshoot and try to identify the issue.

    -Dan

  • The behavior of the keyboard you describe is the same a in the iOS bug I described. Can you remember what character you were trying to type when things went wacky? For me it's confined to the far right side of the keyboard. Is there a chance it as a character there? What happens if you try to type another character farther to the left? Can you enter that, even the field to which your cursor jumps?

    None of this is helping you, I realize. I'm sorry about that, but if this is indeed the same keyboard problem, it's Apple problem, and they have not addressed it so far in any of the iOS updates.

    Perhaps one of the AgileBits folks will come along and recognize something I don't.

  • Having this exact same problem on an iPad Mini (non-retina) and iOS8. Just reinstalled the iPad from scratch because iOS8 crippled the device terribly and I'm hoping a fresh install would help, but now I can't log in to 1Password. Now trying a reinstall of 1Password.

  • the page works ok one time. The next time, whether landscape or portrait on my ipad mini, the input field only accepts the first 2 characters of the 4 character password. Restarting the whole ipad corrects the problem. Does not appear that agilebits is working on this problem. The app is almost unusable. Restarting over and over is not a long term Solution. How do we get this worked on? Sounds similar to some other problems

  • Sorry, after using 1Passwors more in iOS8, I've discovered my problem is actually related to non-functioning keys on the keyboard, both at the login screen and inside 1Password. Here's the thread related to my problem: https://discussions.agilebits.com/discussion/30733/keyboard-problems-entering-master-password

    Sorry for any typo's. I can't even see what I'm typing because the iOS8 keyboard covers 75% of it.

  • Alas, the problem you describe, @r_illingworth‌, is an iOS bug, which Apple has yet to tend to.

  • BenBen AWS Team

    Team Member

    Thanks for the assist, @hawkmoth‌

  • BenBen AWS Team

    Team Member

    @Bardhelene‌

    I've merged your message into another thread on the same subject. Please see above. Thanks.

  • And ios 8.1.2 didn't fix it either.

This discussion has been closed.