Some logins are not synchronizing from Mac to Android after copying from another vault

edited December 2014 in Android

I created some logins (i believe via the web extension capturing them) on my Mac 1Password (v5.0.2 - 502007) and immediately moved them into another vault I share with my wife. Recently I copied several of those logins back into my Primary vault and put them into a folder. When I synced with my Android device (v4.1.5) some of the logins showed up and some did not. I tried editing them on my Mac and then syncing on Android and they still did not show up. I also tried moving one out of the folder, then editing and syncing and it did not show up either.

I'd rather not have to reset my android app and sync down again from dropbox, but this is the only option i can think of left to try.


  • rickfillionrickfillion Junior Member

    Team Member

    Hi @jamesxa,

    Hrmm... sorry to hear this wasn't as seamless as it should be. I think first thing that we should do is check to see if those items made it to the AgileKeychain file or not. This will give us an idea of whether the problem is that the Mac didn't push the items to AgileKeychain, or if 1Password for Android isn't pulling the item from the keychain.

    To do this, we can use 1PasswordAnywhere. To get into 1PasswordAnywhere, you can follow these instructions.

    Once you're in 1PasswordAnywhere, try to locate these items. Let us know what you find and we can get some next steps for you.

    Looking forward to hearing from you.


  • I was able to find the logins that are not syncing to my android device in 1PasswordAnywhere when viewed from clicking on the html document from within

  • rickfillionrickfillion Junior Member

    Team Member

    Hi @jamesxa,

    Excellent. I will get this in front of someone who knows Android more than I do to determine what the next steps are to diagnose this issue. We may move this thread in the process.


  • I have a second phone I am using to test the beta (4.2b5). After syncing with a test vault and that worked fine, I cleared my app data and synchronized to my Primary Vault - the one i'm having issues with some logins syncing in this thread. After the initial synchronization completed, all the items that aren't syncing on my primary phone were synchronized on my secondary phone during initial sync.

    I haven't tested the issue I'm having on primary phone with secondary phone yet.

  • I tested on secondary phone and it is displaying the same issue as primary phone. After initial sync on phone, if I copy a login from a secondary vault to my primary vault on Mac, it does not synchronize to the phone.

  • This does seem to only happen with items that were created in the Primary vault, moved to the secondary vault, and then copied back to the Primary vault. I created a test login in the secondary vault, then copied it to the Primary (where it had never existed) and this test login did sync with my phone.

    I created a new login on Mac in primary, moved to secondary vault then synchronized phone. It said 2 items downloaded, even though i had only made one other change (deleting the previously mentioned test login) aside from creating the new test login. After synchronizing phone, I moved the login from secondary vault to Primary (rather than copy) and synchronized phone again. 0 items synchronized and the login was not available on the phone.

  • periperi

    Team Member

    Hi @jamesxa‌

    I'm sorry for the delay. I tested this out with my Macbook and Android and was able to replicate the problem. Here's what I did:

    • Opened 1Password on my Mac and moved a couple of items to a secondary vault
    • Forced sync on my Android
    • Switched to the secondary vault and copied one item back into my primary vault
    • Moved the other login into my primary vault

    Afterwards, the two items which had been moved to the secondary vault would not sync with my Android.

    I'm forwarding this issue to our developers. Thanks for bringing this to our attention!

This discussion has been closed.