iPhone not syncing with MBP all of a sudden

I've been using 1Password Version 3.8.22 on OS X 10.9.4 and syncing with my iPhone 5 running iOS 7.1.2 for ~a couple of years. Recently my Yahoo iOS app locked me out of my account and I had to reset my password. I did this on my Mac and the new password will not sync over to my iPhone version of 1password. I've prompted syncing with the 1password app and also tried switching to iCloud syncing and back to Dropbox. When I try an set up dropbox syncing it doesn't seem to want to complete the process. I get left at a screen saying "Choose a Vault" with a file path to the passwords file "/1Password.agilekeychain" on the next line but it is greyed out. When I select it I get a message saying "The Vault already exists on your iPhone".

Can't make head or tail of this. Please help AgileBits

Comments

  • What version of 1P are you running on your iPhone? Have a look at this blog post about 1P3 for iOS and see if it helps.

    Stephen

  • Can't find the version in 1passwords settings tabs... or in App Store. How to determine. It's older version for sure. ta

  • Looks like I have at least 1password 4 on iPhone as the icon is not the one they indicate on the blog you linked to. Please Help AGILEBITS!!

  • On your phone go to 1P > Settings and tell us the version number from the bottom of the first settings screen please.

    Stephen

  • Ah I had noticed that but mis-read the bit about the app store and was not sure if it was the actual installed version or recommended install version. Duh.

    4.5.3

  • MrRooniMrRooni

    Team Member
    edited December 2014

    Good morning @wideEyedPupil‌. It sounds like you've run into an edge case in our sync setup. I have some steps for you to take, but these steps assume that your Mac has all of your up-to-date information as everything on your iPhone will be deleted. If you have information on your phone that isn't on your Mac then you'll need to run a backup first or send those items manually to your Mac before you begin.

    1. On your iOS devices, open 1Password 4 for iOS, tap Settings > Sync > Sync Service and choose 'Disable Sync'.
    2. Go to Settings > Advanced > Erase Data and confirm that you do, in fact, want to erase all the 1Password on your phone.
    3. On the Mac, open 1Password 4 for Mac, and click the 1Password menu, then Preferences. Click Sync, and make sure that your Dropbox sync settings are correct.
    4. Restart your Mac and iOS devices.
    5. Go back into the iOS app and re-enable Dropbox sync. (instructions here) That should get everything on the same page for sure.

    Let me know how that works out for you and if there's anything else I can do to help.

  • Thanks. I'm not sure what is in my iOS version that is not in my Mac version but I'm going to proceed anyhow, no choice really.

  • Step 1: In iOS version on iPhone I don't have that option. In Settings> Sync the only option is "Start Syncing" and an Item count of 605. Does this mean syncing is off already? (I was swapping between Dropbox and iCloud syncing trying to prompt it to sync before I logged this bug/help query)

  • More problems. Where I go to the Mac version Preferences there is no Sync button! Which tab should it be on, general tab? I think I've found a reason this could be going wrong. My Dropbox is not installed in the default location in the User Home folder. I have it elsewhere to avoid it being backed up by Time Machine. So the path is: myRootVolume/Buckingham/1Password.agilekeychain And there is a button labelled "Move to Dropbox" When I click this button I get a dialogue saying "Dropbox is not installed. Please install Dropbox from dropbox.com"

    I assure you Dropbox is installed and syncing my other files. Looks like a bug.

  • Seems to have worked. Yay!! Thanks. Twitter @1Password suggested to delete the iOS app and reinstall, this was cleaner. Cheers.

  • Drew_AGDrew_AG 1Password Alumni

    That's great news @wideEyedPupil, I'm happy to hear you were able to get it working! Thanks for letting us know how you were able to do that.

    If you need anything else, we're here for you! :)

This discussion has been closed.