Issues with Compact on Yosemite

edited November 2014 in Knox

Hi,

I have been running Knox for 6 months with no issues. However I have noticed that when I want to compact a vault it says I can not as on battery power.

However I am not on it obviously, I do not know if this is because of the update to Yosemite as the last time I ran it was a while back now so no immediate reference to that.

Any thoughts ?

Cheers

Comments

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Ian Robathan‌,

    That's unusual. We are seeing a lot of issues with Yosemite in general, so it's tough to say if this is a bug with Yosemite and not Knox.

    Can you do a reboot first and see if that'll resolve the glitch? There is a lot of issues that are easily resolved by rebooting for Yosemite.

  • thanks, tried a restart as shut down my Mac every day ... a reinstall is possible I guess but before I start to move all the files out of the secured vaults would like to know if anyone has the same issue.

  • Andrew_AGAndrew_AG

    Team Member
    edited November 2014

    You're the first person who has reported the issue so far that I've seen. I just tested on my MacBook, and I was able to run the Compact Vault no problem while plugged in, so you might want to try reinstalling Knox. You shouldn't have to move any files out of their vaults to reinstall Knox. Just delete the app, reboot, and reinstall it from our https://agilebits.com/downloads page. Just don't use any app cleaner apps (such as CleanMyMac) when deleting it.

  • Ok thanks I will try it in the next couple of days and let you know, so deleting the app will not affect the vaults and same password used ?

  • A reinstall has worked, thanks for your help

  • MikeTMikeT Agile Samurai

    Team Member

    On behalf of Andrew, you're welcome!

  • Sorry to come back to this but yet again compact is disabled with the same issue. This is now the third time since raising the issue this has occurred, has anyone else reported the same issues to you ?

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Ian Robathan‌,

    No, we haven't seen anybody else report this specific issue before or since Andrew's post #4, we cannot reproduce this either.

    The weird thing is that you said the reinstall fixed it but there is no difference as to how we compact your vault each time, time doesn't change anything. So, I can't think of what else it could be.

    Let's see if we can find the more precise error in the logs. Please try this:

    1. Launch Console.app which can be found in the /Applications/Utilities folder.
    2. Click the Clear Display button on the toolbar.
    3. Launch Knox and reproduce the problem. Then wait 30 seconds to a minute to let the Console refresh.
    4. In Console, press Command + A to select all the logs and press Command + C to copy them to your clipboard.
    5. Paste the output in your next reply here via Command + V.

    Thanks!

This discussion has been closed.