Accessibility issues for blind and visualy impaired users on IOS


A friend and I downloaded 1Password on our iPhones to check it out. We were very excited until we started using the app and ran into problems.

We do both believe that 1Password has some awesome features, and we would love to use it. However we ran into some serious accessibility issues, that at least for now means that we can not use 1Password until some of those accessibility issues are fixed.
The issues aren't written in a prioritized order, but the description will tell what we find most serious:

Issues with the interface

When looking at the interface of 1password we noticed that the 1Browser is shown as a button and a tab. In fact Voiceover says: 1Browser button, tab 5 of 5. That is incorrect according to the other information from the other tabs. The favorites tab is 1 of 4 according to Voiceover, so how can the browser be number 5?
We believe this is a bug, and that some cleanup in the code could fix this. It would perhaps look better if the button was where the favorites tab is now, due to the way 1browser shows up. Then, the buttons would be: "Switch to vault" and "Switch to browser" and they would be located at the same place on the screen.

""Touch ID-issue and translation of the interface languages

This is not accessibility related, we just found it and wanted to mention it anyway.
My friend has an iPhone 5S with touchID enabled. It was not possible to use touchID even though it was enabled. It works in other situations except for 1password. Therefor our conclusion is, that this is a bug.
The translation in 1Password on IOS looks not finished. Lot's of text isn't translated even though the tabs except for the settings tab. We hope this is a work in progress, but think it is sad to see a popular app be translated so bad as for this case.

Entering informations into 1Password (the serious part)

Here is the part where we both had serious issues.

  • When creating a new item the same issue applied regardless of which item was chosen. Let's therefor look at the issue when adding a login item for an app/ a webpage:
    When either of us hit "new2 we could easily give the item a title. Like: 1password forum.
    When tapping in the "username-field" there is no feedback spoken/sent to Voiceover. The only thing we can do is to find the field again. Here it says "username selected". And then we can enter the username via the onscreen keyboard. So far, so good. Now, if we want to review what we just wrote, this is not possible. The reason why is: Voiceover can't get the information from the textfield due to the way it is programmed. Please look at Apple's accessibility guides to fix this!
    We can then go on to the password. Here the generator has inserted a random password. However this is only known to us, if we turn the setting on, that shows passwords instead of hiding them. That means for us, that login items has a great potential to fail, since we can't get any information because the app doesn't use Apple's standards for accessibility. It is possible though to enter the password. What we had to do was first to delete all characters that the password generator put in the field, and then type in the password for the existing login. Again, we can't see how many characters we've typed in due to the accessibility issues already described.
    Now, for the website: The same applies. i actually wrote something down when I tried to create an item for testing, and I couldn't get it edited afterwards, due to accessibility issues.
    The fundamental problem is that some code need to be changed to Voiceover can get access to the fields like in the messages app, the notes app, the unlock-passcode-screen etc.
    This can be done, and some of the fields like the master password field works perfect. Now, please try to fix the rest.

Deleting a creditcard item crashes the app

We later on discovered that if we tried to delete a creditcard from 1Password the app crashed. Here's how we did it:

  1. After creating a creditcard we went to the edit screen.
  2. We placed our finger on one of the tabs at the bottum of the screen. We did this so we could navigate to the delete credit card easier with the screenreader Voiceover.
    When we either navigated to the delete creditcard with Voiceover gestures or placed a finger on the icon and double tapped it (you have to double tap on an item to activate it with Voiceover enabled) the app crashed.
  3. The only workaround there may be possible is to scroll from the top and then navigate to the delete button, but the other way around is much easier.

I do apologize that this post sounds as it does, but imagine you found an app, that you would love to purchase and use, because it's just the app you've been looking for to secure your important data. Only to discover that the serious important stuff can't be used, because the accessibility issues prevent you from taking advantage of the app.

I really hope to get some dialogue, so we can fix this, because I would love to b a happy 1Password user.

Thanks in advance.

Best regards


  • Hi @tbd‌

    With the exception of the TouchID section, I've copied your entire post over to our bug tracker and passed it to the developers after chatting to them.

    From the conversation I've learnt that the next release should have a certain number of improvements in this area already. I don't know if it will cover all your findings or not but certainly we'd be interested in your views once it's out.

    I can also say that after just a couple of minutes with VoiceOver I wanted to fling my iPhone out the window. I can only assume you learn a great deal of patience having to use such a feature. Beyond constantly having headphones plugged in I have no idea how you keep anything secret though as my iPhone announced to the room what my PIN was - not what you want.

    That aside, can I ask you a little more about your Touch ID and translation comments please. I'm not aware of any massive bugs when it comes to Touch ID and a lot of our users user it. I'm sure there are one or two annoyances but Touch ID for 3rd party apps is very new. So if you could detail what you're trying and how it isn't working that would be great.

    Similarly, when you say lots of text isn't translated can I ask what language you're referring to please.

    Thank you for taking the time to post your thoughts, it helps us improve 1Password :smile:

    ref: OPI-2167

  • Hi!
    Thank you for passing this along to the right people!
    Cool you gave Voiceover a try. :-)
    It’s not all that hard, when you know the concepts of how to use it.
    My friend told me that he enabled touchID in the settings, but when he tried to unlock 1password by using his touch-ID nothing happen.

    Regarding translations

    We both tested with Danish as the main language. Here there are many areas of the app that aren’t translated from English.
    For example when the app is launched for the first time: The word Welcome is translated correct, but the rest of the screen is in English. So is the buttons for creating a vault or syncing with an existing vault.
    Same applies for making the master password. When going on. When the autolock settings are shown, the title autolock after is shown in English, but the first block of text is correct translated.
    And it goes on and on from there.
    It doesn’t look all that professional. :( It looks like a lot of strings are missing in the app when it was published.
    We’ll look forward for the update.

    Best regards

  • MeganMegan

    Team Member

    Hi Thomas ( @tbd ),

    Thanks for the follow-up here!

    Regarding TouchID: It sounds silly, but I'd love a bit more clarification on what 'nothing happens' means. For example:

    • Does your friend see the 'Unlock 1Password with TouchID' prompt?
    • Is there an error message?
    • Does the TouchID prompt dismiss and show the Master Password pane?

    The more specific you can be about the issue, the more quickly we'll be able to sort out just where things are getting tangled up. Please note that TouchID must be enabled in both the Settings app and in 1Password's settings as well.

    Regarding the Danish translation ... you're right. It's not fully done yet. I've checked at the progress of the CrowdIn project, and it's sitting at about 70%. We recently made some changes to how we are using the translation project, so I'm not sure if we are able to accept any new translators at this time, but please let me know if you would be interested in helping us polish up the Danish translation.

  • Hi Megan!

    Thank you for your comments. I've now seen the latest update to 1password, and here are my updates:

    1. The translation seems to be better now. Only exception is under settings, advanced. Here are the text not translated yet. Same applies for creditcard and identities. Here the informations are shown in English.
    2. The accessibility is loads better in this version! Now I can enter and edit stuff! Nice job. But there is stille somwthing to look at.
    3. The app still crashes when adding a creditcard. Would you in fact like me to do some demos on this?
      If I may contact you via E-mail or Facebook that would be great, then I can send some samples to you so you can see what I'm doing. Would that be helpful?
      So far the only crash I can reproduce is when adding/editing a creditcard.
      Best regards Thomas
  • BenBen AWS Team

    Team Member

    Hi @tbd,

    Sorry for the delayed response. If you'd like to help with translating 1Password from English to Danish you can do so here:

    If I may contact you via E-mail or Facebook that would be great, then I can send some samples to you so you can see what I'm doing. Would that be helpful?

    That'd be great! You can email us at [email protected] and please include both a link to this thread and your forum username. Also, once you've emailed us, please post your ticket ID here so we can 'connect the dots.'



This discussion has been closed.