Error code 20 when creating a new vault

MikeTMikeT Agile Samurai

Team Member
This discussion was created from comments split from: Issues with Compact on Yosemite.

Comments

  • Good morning you all! i've just updated my macbook pro and now, with Yosemite, Knox doesn't create any vault. Following error message appear on my screen: "During the creation of the vault "DATA", Knox encountered the following error (20).

    Any help to resolve it, please?
    Thank you all!

  • Andrew_AGAndrew_AG

    Team Member

    Can you let me know what version of Knox you are running on the Mac? You may need to upgrade to the latest beta version to get it working on Yosemite.

  • Using v2.20 on a 2013 iMac running Yosemite. repeated tries to format a volume as a vault (256-bit, no Spotlight index) fails with Error (20). Deleting application and preference file, reboot and reinstallation, as advised above, does not resolve the problem. The volumes in question is one of 2 2T drives in a My Passport Pro 4T. Any other thoughts?

  • Same Error (20) using v2.30beta.

  • Andrew_AGAndrew_AG

    Team Member

    We weren't able to duplicate the error you got on Yosemite with the v2.30beta, so I'm wondering if you have the same problem using Disk Utility to encrypt the whole drive (since Knox is really just a "wrapper" to make doing the same thing easier to use).

  • I have the same problem as -shs- mentioned. Also running 2.20 and also trying 2.30 (beta). I also did reinstall the software and reboot the system. Everytime error 20 after creating the new vault. Maybe i should say that it´s an internal harddisk (1GB). I also created a vault on a external harddisk without a problem. I´m using the latest version of Yosemite.

  • Dixk Utility under Yosemite will format one of the 2Tb partitions of the external 4Tb drive as Case-sensitive Journaled. It does not give you an option of encription depth, but I assume you can shield it from Spotlight indexing in the Spotlight privacy panel.

  • Any update to the problem. I also tried to disk utility and this works fine. Doyou need more information to solve the problem?

  • MikeTMikeT Agile Samurai

    Team Member

    Hi guys,

    I've split your posts from the original thread as we're dealing with two unrelated issues.

    Do any of you use a tool called DriveGenius or any tool that monitors your drive?

  • Hi,
    I repaired my disk permissions with TechTool Pro 7 and after that I was able to create a new vault with Knox and Yosemite!
    Maybe repairing disk permissions with Disk Utility should have helped also, but I did not try.
    Hope this helps.

  • Andrew_AGAndrew_AG

    Team Member

    Thanks for your input, @peterter‌.

  • I also used disk utility to repair my disk. It said everything is okay. If there is no solution for the problem i have to search for another software...

    1.png 90.3K
  • Andrew_AGAndrew_AG

    Team Member

    Hi @beweissm‌,

    I was speaking with one of our developers, and he says it sounds like it is either a hard drive error or a full disk, despite what the Disk Utility says. It's tough to say for certain, though.

  • quagaarquagaar Junior Member

    I received the same error message when formatting a Seagate 3TB Backup Plus Desktop over USB 2 connection on Mac Pro (late 2009) running Mavericks and Knox 2.20. I was able to do the secure format through Drive Utility without error messages. My main drive is fairly close to full (about 8% free). I will retry when I get some things moved off.

  • Andrew_AGAndrew_AG

    Team Member

    Sounds good. Keep us posted if you're still having trouble.

This discussion has been closed.