List of applications that don't work with in-app filling

edited November 2014 in Android Beta

Just got Lollipop on my Nexus 5 and was excited to right away install 1Password Beta 4.2b2 for the in-app filling feature. Unfortunately, it doesn't work for my mobile banking app, which is the app I was most interested in using it for.

Here are the details, in hopes it can help whoever has to troubleshoot:

Phone: Nexus 5

Android version: 5.0 / LRX21O

1Password version: 4.2b2 (20141117)


App version:

Observed behavior:

1. I give focus to the password field, and tap the 1Password icon

2. I give the master password to 1Password and am prompted to choose a login

3. I choose the appropriate login, and am returned to the bank app

4. Password field is still empty


  • If you don't mind, I thought I'd add my list of apps which don't work to this thread.

    For me, it doesn't work on three apps so far:
    Hertz, Xbox 360 Smartglass, and Xbox One Smartglass.

    For Hertz, no option to fill in password appears at all. For the Xbox apps, the button for 1Password appears, and I'm able to open it and navigate to the appropriate password, but when I select it nothing happens (i.e. no username or password is filled into either app).

    Nexus 4 running Lollipop.

    P.S. Thank you Agile Bits for finally providing this feature! As it improves, I'm sure we'll all wonder how we ever survived without it.

  • saadsaad

    Team Member

    We really appreciate you both taking the time to try out in-app filling on Android Lollipop! I updated the title of this thread to make it a place where we can report applications that don’t play nice with in-app filling yet.

    I have passed on the name of the apps that have been mentioned so our development team gets a chance to review them as we work on improving in-app filling. Let us know if there are any other apps you want us to look into!

  • I tried to do in-app filling on the Aetna (health insurance) mobile app today and 1Password crashed. I'll try to document some more detail later.

  • EnerJiEnerJi
    edited November 2014

    More feedback:

    A: The Auto fill icon doesn't appear on the Evernote app.

    B: When trying to login to this very website:
    1) Auto fill didnt work the first time I tried (nothing got filled)
    2) The second time only the password was filled
    3) When trying to find the login in which to fill, there's no search! Not fun trying to scroll through almost 200 entries trying to figure out what the heck I named a particular entry.

  • I haven't found a single app that fills properly if it doesn't autodetect the right login at the beginning. If I hit "Browse Logins" it doesn't matter what I push, it won't fill.

  • guillaumesertonguillaumeserton Junior Member

    Amazon app doesn't fill

  • Nexus 5,Lollipop obviously. My list:
    Amazon Kindle
    Skype (if you use Microsoft login which is browser based, not native app)

    It also behaves funky in any inapp browser during login.

    Keep up with a good work!

  • The Pebble account login page also doesn't work. Another I've noticed is trying to log into Google on Javelin browser.

    Nexus 6.

  • mverdemverde

    Team Member

    Thank you all for the feedback! I've made a few notes for our development team regarding the request for search and the issues with filling in specific apps.

    Some of the apps on this list run up against a particularly tricky limitation, and that is that we are currently unable to fill credentials into embedded WebViews (as @mishamsk‌ noted above). The Amazon app, for example, uses an embedded WebView to host it's login page. Unfortunately, we don't have the same ability to fill into text fields rendered within a WebView that we would have if they were displayed using native text fields. We are currently looking at potential ways to work around this limitation though.

    @macewank I am still able to fill into apps even when the correct login isn't auto-detected. The apps in question could very well be apps that we need to add to our list for further investigation. If you don't mind, it would be great to collect the names of those apps for further testing.

  • @mverde‌ Is it possible to get a list of apps with known issues posted somewhere (as a sticky at first, then perhaps eventually to the knowledge base?) so that we don't keep reporting the same apps? It would also help to set expectations on whether a particular app not working is a minor bug (and thus likely to be fixed soon) versus a more significant design limitation which might take a bit longer to resolve.

  • The Bank of America app doesn't work. I've been disappointed that only a small percentage of apps that I've tried actually work. I hope things improve in future betas.

  • I just tried logging in on Amazon mobile with beta 4 and all it did was fill in the username and then wouldn't fill in the password when that was the only field that needed filling.

  • pntuckerpntucker Junior Member

    doesn't work with Vanity bank (credit union actually) app nexus 4 lollipop 5 & 1password b4 (can't install b5) icon is there, open 1P, select login and ... nothing.

  • The Meetup app doesn't autofill, and the Wells Fargo app doesn't match to the Wells Fargo login correctly, so I have to scroll to the bottom to find it manually.

  • andreiboscoandreibosco Junior Member
    edited December 2014

    These apps show the 1password icon but autofill doesn't work:

    • skype
    • kindle
    • onedrive
    • box
  • mverdemverde

    Team Member

    As per @EnerJi‌ 's suggestion, I've created a sticky to keep track of apps where in-app filling doesn't work. In compiling the list, it was illuminating to see that in the case of almost all of the apps mentioned in this thread, filling doesn't work because the app uses a built-in WebView for login authentication. We haven't yet come up with a solution for these cases, but it is something that we are currently looking into. Thank you for all of your testing and feedback!

This discussion has been closed.