TouchID | backgrounding bug

I don't know if this has been mentioned in the home button thread (https://discussions.agilebits.com/discussion/32639/touch-id-freezes-ui-if-touching-home-button-during-launch/p1) so pleas bare with me :smile:

  1. Make sure 1P isn't open (kill the task if it was open before)
  2. open 1P and immediately press the home button (this will take you back to home screen)
  3. The Touch ID popup comes up (on the home screen)
  4. unlock it (1P is still in the background)
  5. open some other apps, play around, read mails etc
  6. If you switch back to 1P using the task manager it will open 1P without asking for TouchID or password
    (if you open it by touching the icon instead, it will ask you to unlock)

cheers
froetzgloe

Comments

  • Hi @froetzgloe‌

    Thanks for bringing this to our attention! I'm able to re-create this on my device, so I'll pass this along to our developers to see if we can't improve 1Password's behaviour here.

  • Hi Megan,

    You're welcome. Im happy to be a part of this great product and want to thank you and your team mates for the awesome support!

  • MrRooniMrRooni

    Team Member

    Good afternoon @froetzgloe‌, and thanks for taking the time to write in. I've been testing your steps with 1Password 5.2 (released Monday as a free update on the App Store) and haven't been ablate reproduce it. I do remember fixing this bug (or one very much like it) during 5.2 development cycle. Can you make sure you're running the latest version of 1Password and re-test it for me? Thanks!

  • edited January 2015

    Hi @MrRooni‌,
    I've exchanged the 5.3 beta for the 5.2 AppStore version (sad that TestFlight doesn't allow both at a time) to test it and I'm still able to do the steps mentioned above. It didn't work the first try but now I can reproduce it all the time.

    I'm on iPhone 6 Plus 128GB (maybe it helps)

  • MikeTMikeT Agile Samurai

    Team Member
    edited January 2015

    Hi @froetzgloe,

    This is a known iOS 8 bug, the Touch ID prompt is not supposed to show outside of the app. However, when you see this Touch ID, that's connected to 1Password still running in the background. So, unlocking that specific Touch ID unlocks 1Password in the background and the auto-lock timer will kick off on its own.

    Unfortunately, because 1Password was already in the background, your setting for Lock on Exit will not kick in until you open it and leave it again.

  • Hi @MikeT ,

    Thanks for clearing things up. It's no big deal or security flaw since everybody (or almost all) who is using TouchID for 1Password is also using it for the phones standby. So there's actually no way for others to gain access to our passwords.

    Cheers
    froetzgloe

  • MikeTMikeT Agile Samurai

    Team Member
    edited January 2015

    Hi @froetzgloe,

    You're welcome. While it may not be a big deal, it's still a bad bug for us as it is not the right experience since 1Password should always show up locked.

This discussion has been closed.