Mac Book Pro & iOS Not Syncing

So my 1Password on my iPhone and on my Mac are not syncing. When I set it up on my Mac, finally got it to load my account. Looks like however the two are not cross syncing since.

$50.00 is a lot of money to spend on software you can not get to work the way it is supposed to. It says they are both syncing to iCloud.


  • thomamonthomamon
    edited February 2015

    Both my MBP and iPhone say they are syncing...

    My iPhone says 14 items and on my MBP it says 18 items. I am using iCloud to sync and have tried the trouble shooting and nothing is working.

    I am really getting fed up with this.

    I bought it through the Mac App Store....

  • thomamonthomamon
    edited February 2015

    I have disabled iCloud on my Mac, rebooted the Mac, shut off the Mac, turned iCloud back on and its still saying "iCloud is not available. Please enable iCloud to continue.

    I have checked the settings, it is enabled. iCloud Drive is enabled. 1 Password Mini is enabled.

    Very frustrating.

    I am also using the latest version of Yosemite and 1Password.

  • Drew_AGDrew_AG 1Password Alumni

    Hi @thomamon,

    I'm sorry to hear about the iCloud sync problems you've been having! I see that you posted about this issue on our forums a few weeks ago, and we asked you to send us a diagnostics report. In the email thread, you said iCloud sync was working after logging out of iCloud on your Mac, rebooting, logging back into iCloud, and enabling iCloud sync in 1Password.

    So it sounds like iCloud sync worked correctly at first, then stopped working again at some point? I'm not sure why that would happen, unless there was some sort of problem with iCloud Drive on your Mac. As a quick test, please open a new Finder window on your Mac - do you see iCloud Drive listed in the left side of that window? If so, please click on that. Are there currently any files/folders in there? Are you able to move a new file or folder into your iCloud Drive? (This isn't how iCloud sync works in 1Password, but iCloud Drive needs to be working in order for the CloudKit technology to work.)

    If iCloud Drive appears to be working correctly on your Mac, but you still get a “iCloud is not available” error in 1Password, please make sure you've followed the steps here (it sounds like you may have already done that, but please take a look at that link to be sure).

    If none of that helps and you're still having trouble with this, I'd like to ask you to create a new Diagnostics Report from your Mac:

    Then attach the entire file to an email to us: [email protected]

    Please do not post your Diagnostics Report in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your Diagnostics Report in our inbox. Once we get that, we'll be able to continue helping to solve this problem. Thanks in advance!

    ref: NKC-85474-188

  • @Drew_AG

    I guess I got it to work one time, but it does not look like they synced at all since the first time I got it working.

    I have tried all the trouble shooting steps listed and I have no problem using iCloud for anything else. I am able to pull files there to store them and such.

    Its just when I use your software, it is telling me iCloud Drive is not enabled when it is and I can use it for everything else.

  • Hi @thomamon,

    CloudKit, the framework for app syncing in iCloud, is completely separate from iCloud Drive. For us to use CloudKit though iCloud Drive has to be enabled and 1Password mini has to have access. So iCloud Drive can be working yet there can still be an issue when we interact with the frameworks required. We could have simply written a file to iCloud Drive as well but the advantages that CloudKit is meant to have over this simple alternative meant we went with the solution we believed we lead to more reliable syncing.

    Part of the problem is these frameworks are brand new as of iOS 8 and Yosemite and yes, there are bugs. So both Apple and ourselves are still working out the kinks.

    Please post the ticket ID here once you've sent in the new diagnostic report so we can easily locate it.

  • @littlebobbytables I do not know the ticket ID, but I included the link to this thread in my e-mail.

  • Hi @thomamon,

    I see somebody has replied to your message and that we're continuing the troubleshooting process there. The ticket will remain open while we try to understand why Apple's CloudKit framework is reporting a generic non-recoverable error (it's simply failing and not saying why). As you are now receiving support via our ticket system I'm going to go ahead and close this thread but if you have any further questions or issues please do post.

    ref: XVG-95321-144

This discussion has been closed.