1Password not opening when starting new MBP

I am running 1P version 5.1 (510027) on my mid 2014 MBP (2.8GHz Intel Core i7, 16GB RAM). I recently had to reinstall all of my software (long story - don't let a PC based IT group touch your MBP. Ever). As you can see from the screen shot, I have selected to keep 1P mini running but whenever I turn on my computer, I have to launch 1P manually. I feel like I am missing something obvious, but how do I get it to launch the mini automatically?

I tried having 1P launch upon open, but that is not exactly what I want. I just want the menu bar tool to launch.

Steve

Comments

  • I have the same issue. My 1Password Mini does not launch automatically. I have made a reinstall and removed old preferences.

  • Hi @bigdad13,

    I would hope simply removing the application and downloading a fresh copy may resolve it although @mos found they needed to do a little more than that.

    Let's start with the following steps which take care of a lot of oddities.

    1. Quit both 1Password and 1Password mini. You can do this with the keyboard shortcut ⌃⌘Q when 1Password is open (it doesn't have to be unlocked).
    2. Drag the 1Password application from your /Applications/ folder to the Trash.
    3. Reboot your Mac.
    4. Download 1Password again from the same place you purchased it. From the screenshot you look like a MAS customer so that would be Apple's App Store application.

    If that isn't sufficient we can cover the Starting Over guide and what you would want to do to keep your vault which obviously is perfectly fine and definitely still wanted :smile:

  • OK, I did not remove preferences but I did quit both, trashed the app and reinstalled from the App Store...same result. So, should I find the old preferences and kill them or should I go down the Starting Over route?

  • Hi @bigdad13,

    Now you didn't specifically say you'd rebooted your MacBook Pro so I hope you did. It's genuinely a key step thanks to aggressive caching in many of the latest versions of OS X.

    Lets assume you did though and it's still not working.

    1. Let's create an up to date backup from which we will restore a fresh copy of 1Password. So please launch 1Password and go into 1Password's preferences. Select the Backup tab and then click on the Backup Now button.
    2. To make life easier later click on the Show Files button and a Finder window will open at the location of your backup files. Copy the newest one, the one you just made, to your desktop.
    3. Quit 1Password and 1Password mini like you did before. I personally like the keyboard shortcut ⌃⌘Q for that.
    4. Open a Finder window and use the keyboard shortcut ⇧⌘G to open the Go to Folder... window and paste in the following path ~/Library/Containers/
    5. The top two folders in there should be 2BUA8C4S2C.com.agilebits.onepassword-osx-helper & com.agilebits.onepassword-osx, you want to move both of those to your Desktop.
    6. I realise it might seem overkill but I figure no half measures, lets eliminate any possible reason. So please delete 1Password from `/Applications/ like you did before.
    7. Reboot your Mac.
    8. Download 1Password (MAS) once more.
    9. If you sync using either iCloud or Dropbox it will see that data and ask you for your Master Password. As long as it's all synced you're free to do this. If you don't sync then this is where the backup on your Desktop comes into play. Select the I've used 1Password before option and from there Restore from backup and then use the Choose backup... button to select the backup you copied to your Desktop. A couple of confirmations, 1Password will close down to finish restoring the .sqlite database file and when you open it again it will be like you've never run 1Password before except that your vault is still intact. If you restore the database and need syncing you will have to re-enable it at this point as it's disabled after a backup as a safety measure.

    Now hopefully this resolves the issue. If it doesn't do please let us know.

  • Sorry I have not replied faster. Work got in the way. I did every thing listed...1-9....Rebooted and.....nothing. Tried it twice to be sure. :-( I am starting to wonder if there is a setting I am missing somewhere.

    I know what you're thinking..."he must have skipped something". I am pretty certain I didn't, but anything is possible. When I got to step 9, a screen showed up saying that 1P found my data on DropBox and asked if I would like to sync up. I said yes and everything proceeded as normal. Shut down...restarted and nothing.

    I obviously can still use 1P, but I have to launch it manually. Is there a setting in Security or Users that may be goofy?

    Steve

  • Hi @bigdad13,

    What I'd like you to do for us please is send in a diagnostic report. I'd like you to reboot your Mac, pause for a minute or two and then launch 1Password. Having done that I'd like to ask you to create a Diagnostics Report from your Mac.

    Then attach the entire file to an email to us: support+ [email protected]

    Please do not post your Diagnostics Report in the forums, but please do include a link to this thread in your email, along with your forum handle so that we can "connect the dots" when we see your Diagnostics Report in our inbox.

    Once you've sent the Report a post here with the ticket ID will help us to keep an eye out for it. :)

    Once we see the report we should be able to better assist you. Thanks in advance!

    The reboot is so 1Password not loading when it is meant to is fresh in the logs.

  • OK, I sent in the report. The ticket is: [#JXG-54868-351]

    I hope this is nothing silly that I am missing...

    Steve

  • Hi @bigdad13,

    Thank you for sending in the diagnostic report. Somebody will be in touch shortly.

    ref: JXG-54868-351

This discussion has been closed.