1Password button missing from Safari 5.0.6 on restart

I have 1Password 3..5.15 and even though the browser button is enabled in Preferences, it's not there every time I start Safari; only when I go into Preferences and then quit out of that does it appear— both the button in the browser bar, as well as the Key icon in the menu bar at the top of the screen.

This is very inconvenient and maddening. How do I stop this behavior so it automagically appears every time I start Safari?


  • Hi @Mulder,

    Sorry to hear you're having these troubles. The first thing to do before proceeding is to confirm there is nothing in the extension that isn't in your 1Password 3 vault. If that sounds odd it's because the extension in 1Password 3 maintained its own database. I would like you to visit our Sending a Diagnostics Report page and in the lower half of that page is 1Password 3 for Mac. Find the subsection for your version of OS X and download the diagnostic reporting tool. Run it and create the diagnostic report for your machine.

    Now if you're comfortable, all you need to do is search this report for the string # of unsynced items. If when you find it the entire line reads # of unsynced items = 0 then you're fine. If you're not comfortable then send the diagnostic report to [email protected] with a link to this thread, your username and even mentioning my name. You'll receive an automated reply with a ticket ID and if you were to post that here it will help link everything up.

    Lets say you know that you have no unsynced items though. That means you can safely uninstall the extension, reboot your Mac and try re-installing it again. Does this help at all?

    Please do report back either way.

  • Hmm… I get no number of unsynced items from that report: it's just

    of database items =

    of keys =

    of unsynced items =

    I also see that the Helper agent process is not running, but the problem with that is there's no way to turn it on. This is what I see:

    So, aside from that and one or two SIMBL items running (which never caused a problem), what can we do?

  • Hi @Mulder,

    I hadn't expected to see no number but I didn't anticipate so many browsers on your system - I'd even forgotten Camino existed.

    Can you perform the search one more time (sorry) but this time repeat the search for further instances of the string. You'll know you've found the correct one if you see something a little like this:

    Databases.db entry for OnePassword
    guid = 1
    origin = safari-extension_com.agilebits.onepassword-safari-2bua8c4s2c_0
    name = OnePassword
    displayName = 1Password Database
    estimatedSize = 104857600
    path = 0000000000000001.db
            # of database items = 104
            # of keys = 1
            # of unsynced items = 0

    The important part, the bit that tells you this pertains to the Safari extension is the origin line.

    As before, as long as that line says 0 unsynced items I would recommend uninstalling the 1Password extension from Safari, rebooting and seeing what happens if you then re-install. If it still says no item you are also free to perform those steps as for whatever reason, the extension database isn't there at all and you aren't running the risk of losing anything. That's what this has all been about so far, uninstalling the extension would delete the extension's database inside Safari and I didn't want you to do so unless there are no unsynced items.

    The Helper application issue should be an unrelated one but hopefully easy enough to resolve. If in 1Password you go to Help > Troubleshooting > Restart Helper, give it 10-20 seconds and then reboot your Mac. That should resolve that one.

    If you have any questions, come across anything odd and are unsure please do let us know and if need be we'll take it to email to look into it in more depth.

  • Sadly, I still get 0 unsynced items, and there's just one line with that in the entire report. As for the Helper application, there is no Help > Troubleshooting > Restart Helper item, so I can't do that.

  • littlebobbytableslittlebobbytables

    Team Member
    edited March 2015

    That option exists in the last version of 1Password 3 that we released, v3.8.22, which is available on our AgileBits Download page at the bottom. It might be worth updating.

    Also 0 unsynced items is good! The reason for going through all of this is that I didn't want to risk the loss of unsynced items. If you have none there is no risk from uninstalling the 1Password extension :chuffed:

  • I think you've missed a critical point: I'm running 10.5.8 on PowerPC, and 1Password 3.8.22 only works on Intel-based Macs running 10.6 or 10.7, so I can't install that version. I need a solution for this version; otherwise there was no reason to upgrade, since it provides no compelling feature and supports fewer browsers on PowerPC Macs.

    The issue I'm having is consistent, regardless of whether or not I uninstall the extension and then reinstall it: every time I need to restart my Mac, the 1Password icon(s) are missing from Safari. If there's a daemon somewhere that needs to startup when the Mac does, I need to know where it is and how to ensure it does startup.

  • Hi @Mulder,

    If uninstalling and re-installing the extension doesn't work it suggests your Safari profile is corrupted.

    I would suggest exporting your bookmarks, deleting your entire Safari profile and let it create a new one. If the extension stays after a reboot you can import your bookmarks. If that still doesn't work it could suggest the problem is deeper than just the Safari profile and possibly the permissions on your profile in general are mangled. It will be tricky though, it's been several years since I last ran anything that old and I'm not even sure if Apple has any decent support documents going back that far.

  • Nope, permissions are all okay, and the problem persists after getting rid of the existing Safari profile. This issue is so obvious that I'm astounded it wasn't noticed during development of this version and fixed. So, what to do now?

  • Hi @Mulder,

    I don't believe the issue is the extension itself, it can't uninstall itself or indeed even install itself - that's the job of the browser.

    As a troubleshooting device only I would like you to create a brand new user account on your Mac. Does the observable behaviour change there at all? Once we know the results of this test you're free to delete this test account.

    I'd also like to know what version of the extension you're running please. I don't have anything old enough that will allow me to install the extension that I believe 1Password 3.5.15 is attempting to install.

  • Okay, but where do I find the version number of the extension? All I see in the profile folder for 1Password are the various folders for the Firefox extensions: 3, 4, 5, 6, and 7.

  • Hi @Mulder,

    I genuinely can't say if the precise location has changed but the extension version should be in the extension list ini Safari. In Safari 8 that's in Safari's preferences in the Extensions tab.

  • Then we have a problem, because Apple seems to have disabled Extensions in Safari 5.0.6, which is the last version I can run under Mac OS X 10.5. They used to work when they introduced the feature with Safari 5.x, but they've changed the requirements somehow so that Extensions are only supported in Safari 6 or higher, which I can't run.

  • Hi @Mulder,

    Since your post I've found reference to Safari 6 with other extensions but I had no idea Apple went as far as disabling extensions in a what we'd describe as a minor version update. So you don't have an extensions tab at all in your Safari's preferences or if you switch to it you're informed that it's disabled?

  • No, I have an Extensions tab, but the problem is that I can't install any extension. Doesn't matter which one I try, it doesn't allow me to download or install any of them; always gives me an error message, which is because of the Safari 6 or higher requirement now.

  • I hate to say it @Mulder but I don't see a way forward at this point with Safari if Apple have done this. You may want to consider trying the last version of Firefox that was compatible instead, see if that works any better. The link for that can be found on this page, Firefox no longer works with Mac OS X 10.4 or PowerPC processors.

  • As you should know, since I have a PowerPC Mac, Firefox is not an option, so why would you suggest using it? Are you going to provide me with a brand new Intel-based Mac to run it on? If not, then address the issue and make it so I don't need one.

  • @mulder, did you review the link in my previous post? It will show you how to download 3.6.28 a universal binary according to that page that will work on OS X 10.5.8 running on a PowerPC chip.

  • Yes, I know I can run that really old version, but the problem is that it has a bunch of security issues that will never be addressed, which is why I shouldn't be using it. TenFourFox runs for me, but it seems slow compared to Safari and Firefox, and 1Password isn't compatible with it, either.

  • @Mulder,

    You're correct, it is an old version of Firefox and yes it will have unpatched security flaws. Without trying to sound harsh that will apply to everything about your machine though. As the Firefox page points out, Apple stopped supporting Leopard back in 2009 and I don't know of any current software still supporting PowerPC. Safari will be at risk, OS X will be at risk, the only aspect in your favour is it's probably unlikely that anybody targets the PowerPC chips now. Take the recently and highly publicised FREAK vulnerability. Apple released a patch this Monday but only for OS X 10.8-10.10. This means your machine will remain vulnerable.

    I understand staying current with Apple can be expensive and I do get that unless there is a great reason, giving up what seems like a perfectly working machine doesn't make much sense but you may need to consider that this machine has had its day. Certainly your hopes seem to now outstrip it's compatibility with working software.

This discussion has been closed.