Backup iTunes Transfer

Using 1P on iPhone, I used the advanced settings to backup my vault. Synced with iTunes (current version) on Windows PC (v 8.1) and I can see that 1P created a backup folder in the file sharing section; however, it appears that the folder is empty. If I right click on the folder (or left click for that matter) I should be able to copy the backup file, but clicking on the backup folder does nothing. If I try to move the whole backup folder, it indicates that it will copy, but it does not. I tried deleting the backup, performing another backup, and re-syncing, but still the same result. How can I fix this?

Comments

  • brentybrenty

    Team Member

    @SecretSquirrel: I'm sorry you're having trouble getting your 1Password backup out of iTunes! I tested this myself on both my Windows 8.1 and Windows 7 machines and was able to successfully save a backup using iTunes file sharing.

    From your description, I think you might be running into the same issue I did at first. Dragging the Backup folder out of the iTunes Window looks like it will work, but it just doesn't do anything. Instead, what you can do is select the Backup folder, scroll all the way to the bottom, and click Save To... That should do the trick!

    This is something we need to look into, as it seems that it is possible to drag and drop to copy from other apps I tested. It may be significant, however, that those were individual files (I could not find a way in Windows to transfer a folder into an app using iTunes file sharing; 'Select'ing a folder just opens it to view the files inside), whereas in 1Password it is a folder being shared.

    Thanks for bringing this to our attention. And sorry for the wait! Whew. I wanted to make sure I understood what was going on here so I could report it properly. I hope this helps! :)

    ref: OPI-2479

  • @brenty, thanks for taking the time to troubleshoot this issue. I followed your instructions and was able to move the backup. I also looked at a different iOS program's backup process, as did you, and found the same thing; i.e. when the backup is in a folder it cannot be directly moved, but a single file can be moved. I'm not sure why 1P uses a folder to hold the backup .zip file, but perhaps your developers can see if the folder is really necessary. Once again, thanks.

  • brentybrenty

    Team Member
    edited March 2015

    @SecretSquirrel: It was my pleasure! Well, except for the part where Windows stopped recognizing USB connections and then refused to restart. That was just silly. But I digress...

    Way ahead of you there on the folder thing. I have filed a ticket for this. And while it seems to be an iTunes for Windows issue at the core, I am hopeful that, if a folder proves unnecessary (I don't know the specifics as to why a folder is used in the first place, so it may be important), the folder angle may lead to a change on our end that helps folks in the future at least. Much like you, SecretSquirrel, we have some tricks up our sleeves; we're on the case. ;)

  • @brenty Double-Q would be proud.

  • brentybrenty

    Team Member

    Thank you for saying so, my friend. I do try to stay on the chief's good side! :+1: :+1:

This discussion has been closed.