Randomly deleted logins?

Has anyone else ever had an issue where a login they were SURE they have created, but maybe haven't accessed in a little while, is suddenly gone? This has happened a few times to me, and I don't want to believe that I am just going crazy. I have 1password syncing to my home macbook pro, my work imac, my iPhone, and my Android Tablet. Is it possible that all of these different things are causing syncing issues that might cause deletions?

I've also had times (okay only once yesterday so far but still) where I've changed the passwords on one computer, and then when I go back to 1password the next day to look at the password, it was reverted back to the old password. I am CERTAIN I pressed save! I actually thought to myself that I needed to make sure I hit save, and I pushed it and looked at the login again afterwards.

I've been googling and it doesn't seem like many other people are having this issue.... am I just losing my mind?!


  • MeganMegan

    Team Member

    Hi @kmhahn23 ,

    I'm so sorry to hear that you've been having trouble with 1Password. In order to get this sorted out, I'll need to know a little bit more about your 1Password ecosystem:

    • What is the version number of 1Password that you have installed? (Please include all relevant computers and devices)
    • What is the version number of your operating system (for all computers and devices)?
    • What are you using to keep things in sync?

    The more detail you can provide, the more quickly we'll be able to get you sorted out! :)

  • Sorry I just saw this now (I thought I would be emailed if I got a response). I'm using 1password 3.8.22 on my macbook, 5.2.1 on my iPhone. My macbook OSX is version 10.7.5 and my iphone is OS version 8.1.2. I will have to get the Android and iMac info tomorrow (they are left at work). I use dropbox to sync. I'll continue this tomorrow to give you the rest of the information...

  • @kmhahn23, in passing, go here to edit your profile and look at your Notification Preferences. You can then choose what sort of notifications you want for various events.


  • Hi @kmhahn23,

    You've got a lot of devices in there so once we have a full picture we'll see what we can suggest. Different versions and where you edited something can make a difference so as much detail as you can remember could be very helpful.

    Something as simple as if you're running 1Password 4/5 on the iMac might mean a difference in behaviour when you edit something compared to 1Password 3 on your MacBook.

    Also what you're running in different places may mean it's easier to check some machines than others to see if we can recover an item.

  • Ok, sorry I missed yesterday. My iMac 1password is version 3.5.9, and the imac itself is version 10.10.2. The android tablet 1password is version 4.1.6 and the tablet itself is 4.4.2

    The most recent place I edited where I noticed a discrepancy was on my macbook pro at home.

  • Thanks for the tip @Stephen_C !

  • Hi @kmhahn23,

    So just as a summary

    • MacBook: OS X 10.7.5 & 1Password 3.8.22
    • iMac: OS X 10.10.2 & 1Password 3.5.9
    • iPhone: iOS 8.1.2 & 1Password 5.2.1
    • Android tablet: Android 4.4.2 & 1Password 4.1.6

    So the first thing is I would recommend updating to at least 1Password 3.8.22 on your iMac, you're running an older version there than you need to.

    Now as you're running 1Password 3 for Mac in both locations I can at least comment on that part. Unless there is a significant change in 3.5.9, 1Password 3 will save changes if you move away from an item while in 1Password 4/5 we kept the changes in limbo and would allow you to resume editing.

    For deleted items the first thing to do is check your Trash, make sure it isn't as something as simple as that. If it isn't then we need to consider looking at backups.

    Now 1Password for Mac makes backups but how this works in 1Password 3 means we don't want to be restoring to Dropbox, not yet as it has the potential to mess up 1Password for iOS and 1Password for Android.

    I would probably recommend this on the MacBook.

    1. In Finder, copy your 1Password.agilekeychain from your Dropbox folder to your Desktop.
    2. Launch 1Password and enter the preferences.
    3. In the General tab click on the Choose Another... button and select the 1Password.agilekeychain you copied to your Desktop.
    4. At this stage we've effectively disconnected 1Password on your MacBook from Dropbox. Don't worry, this is just a temporary situation.
    5. You can now safely explore the backups on your MacBook using the File > Restore Data File from Backup....
    6. If you find the item(s) you will want to select them and export it using File > Export Selected > 1Password Interchangeable File.... This way when we return to the 1Password.agilekeychain in Dropbox you still have the items you want to restore.
    7. To return 1Password 3 to the 1Password.agilekeychain in Dropbox you will want to repeat step 3., ignoring the Move to Dropbox... button as it no longer works.
    8. Pointing to Dropbox again means returning to the file the others are using. If you found items you had thought lost you want to add them again via the File > Import... and follow the steps there, choosing the 1Password Interchangeable File format.

    That would at least restore missing items.

    What I would recommend doing is checking that all machines are correct as far as clocks go as maybe timestamps are an issue.

    Let us know how you get along and if you have any troubles or questions please do post!

  • Hi! I'm a bit slow with responses, work has been incredibly busy and I haven't had much chance to mess with these. I do have a question - I tried to update 1password on my imac and it isn't letting me. I can't remember the exact error (if it is important to know I can find out tomorrow) but something about not able to connect to the network or can't download the update? Is this a common problem? Is there way around it? I tried to update through the app itself (check for updates).

    And there was one instance where a missing log in was in the trash (which I found odd as I didn't believe I deleted it).


  • MeganMegan

    Team Member

    Hi @kmhahn23 ,

    If you're having trouble installing the update, you can always download a fresh copy from our website:

    • Fully quit 1Password
    • Head to our downloads page and scroll to the bottom for the 'Legacy' versions
    • Download 1Password 3
    • Drag the new app into your /Applications folder and replace the existing copy.
    • Do NOT use any app cleaners to remove the existing app. A simple drag and replace is all we need.

    Once you're using the latest version of 1Password 3, we'll want to check to see if the connection between the extension and the main app is functioning correctly. In 1Password 3, there was a potential for items to be saved in the extension but not properly transferred into the main app. (In 1Password 4 and 5, we've completely re-written the way that 1Password communicates, and this is no longer an issue.) Let's try this:

    • Open your browser to a webpage with a login screen
    • Fill in some test details
    • Open the 1Password extension, and unlock if necessary.
    • Select the option to save a new Login (give it a clever title like 'TEST')
    • Open the main 1Password app - do you see your test entry?

    Please let me know the results of this experiment.

  • kmhahn23kmhahn23
    edited April 2015

    Hi Megan! @Megan Once again, it took me a while to get to this (the computer that was having the issue is at work and I can only work on personal things when my workload is a bit slower). I was able to do the above and it worked great. Thank you! I actually don't use the browser extensions, but I downloaded one for firefox just to test and it seemed to work fine! Thank you so much for your help.

    I notice that you are up to 1Password 5 now. I have 1password on two macs, an android, and an iphone - would I have to purchase 3 different licenses to upgrade? And have there been any known issues to the upgrade process from 3 to 5?

  • brentybrenty

    Team Member

    @kmhahn23: Hey, I'm sure you're busy too! Thanks for getting back to us. I'm glad to hear that worked for you. On half of Megan you are most welcome! :)

    And 1Password has indeed come a long way! Since we license our software on a per-platform basis, you'd just need a single 1Password 5 license for your two Macs. You can, of course, check your existing license for upgrade pricing. Just be aware that you'd need to purchase 1Password from the Mac App Store instead if you want iCloud Sync (but that might not be something you need anyway since you have an Android device). Also, 1Password 5 can use your existing vault from 1Password 3, so no problem there. ;)

    1Password for iOS and for Android are both separate purchases as well if you want to unlock the pro features, but otherwise they are free apps (the Android version being read-only after 30 days, and the iOS version having pro features disabled unless you do the in-app purchase).

    I hope this helps. Let me know if you have any other questions! :chuffed:

This discussion has been closed.