Clicking URL takes to Google page & search bar shows password for site instead of opening page

Couple of days back 1password updated to version 4.2.0.548. Since then some entries when URL is clicked its open Google search page instead of web page. The search window of google shows password for site. Serious issue of security.

Comments

  • brentybrenty

    Team Member
    edited March 2015

    @Vivek: That is strange indeed. I am not seeing this behavior myself. Windows handles redirecting URL clicks to the default browser, so I wonder if there is something going on there. It should obviously be opening the correct URL, not a search page (although search redirects may happen if the URL specified is not available).

    What browser, extension, and Windows versions are you using? You also mentioned it is only some entries. What are the websites where this is happening? Please let me know. We will get to the bottom of this!

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @Vivek,

    Can you also check the URLs of the affected items, is it pointing you to the google's search page?

  • Hi Brenty & Mike

    Thanks for replies. Clarifications -

    • URLs of affected items are same which existed before 1Password update. Same URL when typed in browser opens correct page.
    • Browser is IE 11.0.17
    • Most of other entries other than a particular net banking site error message is "cannot access this internet explorer document. Restarting Internet Explorer might correct this problem." Despite of message page opens but does not fill in entries automatically & again error message is displayed "1Password could not enter in fields for "URL----------- of page". Some times messages are "Internet explorer is denying entry to frame because it is on some other domain (Other than "URL.........."). Please use auto type or another web browser".
  • brentybrenty

    Team Member
    edited March 2015

    @Vivek: As Mike and I suggested, see what URL you have saved for the item to verify that it isn't a Google search URL. With more information we can test this ourselves to see if there may be an issue with 1Password and specific sites.

    Some times messages are "Internet explorer is denying entry to frame because it is on some other domain (Other than "URL.........."). Please use auto type or another web browser".

    This concerns me. It sounds as if there may be some software which is causing the website to display in a frame. As a security feature, information from one site will not be allowed to 'cross over' to another within a frame. Since IE is displaying this behaviour, are you able to use the 1Password extension normally in another browser? It may be that only IE is affected, unless something is intercepting the URL in Windows itself.

    In case communication between 1Password and the extension is failing, try Help > Restart 1Password Helper in the main 1Password app. to see if that resolves the issue. Or it may be that security software on your computer is interfering with 1Password. Let me know what you find.

  • HI Brenty

    URL is https://netbanking.hdfcbank.com/netbanking/
    URL works okay with Google Chrome

  • brentybrenty

    Team Member
    edited March 2015

    @Vivek: https://netbanking.hdfcbank.com/netbanking/ loads normally in both Chrome and IE 11 for me. If it is not loading correctly at all in IE for you, there may be a problem with the browser itself.

    However, if it is just the login filling you are having trouble with, the frame error you described is due to a known issue: IE security policy does not allow the 1Password addon to fill the form because it is in a frame containing content from a domain other than the one you are visiting. As a workaround, you can copy/paste or (in some cases) use 1Password's AutoType feature to fill it instead of the addon. I hope this helps! :)

  • Thanks Brenty. Will re-installing IE resolve the issue ? Till 4 days back there was no issue with IE browser.

  • @Vivek While I couldn't reproduce it, I believe version 4.2.1.BETA-555 might fix this problem for you.

    https://app-updates.agilebits.com/product_history/OPW4#beta

    Can you please download version 4.2.1.BETA-555 and confirm the fix? Thanks!

  • Hi Svondutch

    I did install version 4.2.1.BETA-555. The issue with IE remains same.

  • brentybrenty

    Team Member

    @Vivek: Sorry to hear that didn't do the trick for you. I was able to test myself, with the same results.

    The bad news is that the bank really seems to want you to click to submit the login, which causes some problems for you, since the reason you're using 1Password is to log you in to save you some extra clicking (and typing).

    The good news is that I have a workaround for you, so you can at least continue using 1Password to fill a strong password for you -- if not submit the form. Just follow these steps:
    1. Go to https://netbanking.hdfcbank.com/netbanking/
    2. Enter your Customer ID and click Continue
    3. Enter your Password but do not click anything
    4. Click the 1Password button to open the menu
    5. Go to Settings > Save new Login... make sure it is set to "Create new login" and then save
    6. Open the main 1Password app and edit your new login item
    7. Change Submit to Never, and save

    Now you can go to the website and press **ctrl+** to fill the Customer ID and Password. You will just need to submit the each manually until such time as our banks stop making us jump through these hoops. I hope this helps! :)

This discussion has been closed.