1Password on Samsung Galaxy S2 ??

I have Samsung Galaxy S2,SGH-I777, rooted, running Android 4.0.3 (Ice Cream Sandwich), baseband version I777UCLE5. Trying to purchase 1Password on Google Play store. Purchase not offered, says "Your device isn't compatible with this version". I read on agilebits list of requirements that Android 4.0 was all that was needed. What am I missing - do I need to update my phone's operating ROM to a higher Android version? Something else?
I have 1Password on my PC and love it, really want it on all my devices. Thanks!

Comments

  • I am reposting this with a better title so that hopefully it will clear I am asking for assistance.

    I have a rooted AT&T Samsung Galaxy S2, (SGH-I777) running Android 4.0.3 (Ice Cream Sandwich), baseband version I777UCLE5. I am trying to purchase 1Password on Google Play store. The Play store says "Your device isn't compatible with this version". According to Agilebits website, Android 4.0 or greater should be sufficient -- what am I missing?? Do I need to update my phone's operating ROM to a higher Android version? Something else? I have 1Password on my PC and love it, but really need it on all my devices to be a workable password management solution. Thanks!

  • periperi

    Team Member

    Hi @flyfr8rs. Thanks for contacting us today. :)

    I'm sorry to hear that you're having trouble downloading 1Password 4 for Android through the Play Store. It is indeed compatible with Ice Cream Sandwich and I personally have it installed on an S2 as well, so there shouldn't be a problem there.

    It also looks like you have the stock OS rather than a custom ROM. However, it may have something to do with being rooted.

    Can you confirm that you're installing this version of 1Password through the Play Store?
    https://play.google.com/store/apps/details?id=com.agilebits.onepassword&hl=en

  • Yes, I'm trying to install through Google Play store. My phone had been running Gingerbread 2.3.6 - I updated the ROM to factory Ice Cream Sandwich 4.0.3 yesterday in order to be able to install 1Password. The ROM is described as the official factory version modified only to be able to install on a rooted phone. Is being rooted a problem for 1Password installation?

  • periperi

    Team Member

    Hey @flyfr8rs. I think the problem may be that you had to root the device in order to upgrade its OS. I'm unable to replicate the issue on my Galaxy S2 which came stock with 4.0.

    I looked into your device and it looks like it needed to be rooted before the firmware upgrade was possible. I believe this may be causing the issue with 1Password in the Play Store.

    Are you able to click the "Your device isn't compatible with this version" message to view the reason that it's incompatible?

    Also, can you try installing another app from the Play Store that requires Android 4.0 and up? Let me know if that works or if you see the same incompatible message. Thanks!

  • Hi Peri, Thanks for looking into this. I am not able to click on the "incompatible" message or get any additional info from the Play store. However, I have found some encouraging information here: http://www.howtogeek.com/138500/the-ultimate-guide-to-installing-incompatible-android-apps-from-google-play/

    If you can point me to where I could download the current, stable application (.apk) file (presumably the same file that I would be getting from the Play store), I'm hopeful that my issue may be resolved. I'm not certain that I'll get update notifications, but will find that out after at least getting a successful install. Thanks!

  • periperi

    Team Member

    Unfortunately, the only place to download the stable version of 1Password 4 for Android is through Google Play. :(

    If you'd like to become a beta tester, you could sign up for our beta newsletter, though.

    I'm sorry I don't have better news for you there! Let us know if there's anything else we can do to help.

This discussion has been closed.