Cannot Select Firefox Browser

When I check "Mozilla Firefox 3.6.13" and hit "OK," and then return to the same window, the box is unchecked. I cannot get the selection of Firefox to stick. Any ideas?

Comments

  • DBrownDBrown 1Password Alumni
    hnbock, welcome to the forum!

    I haven't seen or heard of that, before. :blink:

    If you launch Firefox and choose Help > About, does it report exactly the same version of Firefox as is listed on the Browsers tab of 1Password preferences?

    Are you using Firefox profiles?

    Are you able to complete these instructions in the FAQ section of the user's guide?
  • hnbockhnbock
    edited January 2011
    Hi David,

    1Password does report the same Firefox version.

    The 1Password button does not appear as an available option for my Firefox toolbar.

    I am not using Firefox profiles.

    Harvey
  • DBrownDBrown 1Password Alumni
    I can think of only a couple more reasons that might happen, both related to the version of Firefox and 1Password for Windows.

    Can you take screen shots of the following things and embed them (or link to them) from a follow-up post?
    • the Firefox "about" box
    • the 1Password "about" box
    • the Browsers tab of 1Password preferences

    In Windows Vista or 7, you can use the snipping tool to take a screenshot, and save it to your Desktop.

    Thanks!
  • hnbockhnbock
    edited January 2011
    Here you go.

    Firefox_About_Box.PNG

    1Password_About_Box.PNG

    Browsers_Tab.PNG
  • DBrownDBrown 1Password Alumni
    Thanks for the screen shots!

    On the Updates tab of 1Password preferences, please enable the Include Beta versions option; then click the Check Now button.

    Let us know if the latest beta solves the problem.
  • hnbockhnbock
    edited January 2011
    Hi Dave,

    I just tried this. It didn't help.

    Harvey
  • DBrownDBrown 1Password Alumni
    Thanks for trying, Harve.

    I'm just not able to reproduce the problem on any of my own Windows test environments, so I'm hoping someone else will post if they've seen similar behavior.

    I'm really sorry not to have a more satisfying answer for you, at this time.
  • I'm having exactly the same problem. Windows 7 running in VMware Fusion on an iMac. Firefox 3.6.13, iPassword 1.0.2.155.

    When you check the preferences box for FireFox for the first time Windows pops up a "do you want to let regedit run" kind of window. Click yes. Box is checked.

    Close preferences and reopen, box is un-checked. Check the box again. Now Windows does not pop up the confirmation window. Close everything and open Firefox - no plug-in.

    It's like Windows is blocking the registry update.

    Everything works fine for the plug-in for IE 8.
  • DBrownDBrown 1Password Alumni
    Thanks for that info, CHM-CT.

    I'm just not able to reproduce the problem, so I'll ask the developer for advice.
  • hnbock wrote:

    When I check "Mozilla Firefox 3.6.13" and hit "OK," and then return to the same window, the box is unchecked. I cannot get the selection of Firefox to stick. Any ideas?


    Is the "profiles" button enabled? If yes, what profile(s) are listed there? Are they checked?

  • Is the "profiles" button enabled? If yes, what profile(s) are listed there? Are they checked?


    When I go to the "Browsers" tab and check Firefox, the Firefox "Profiles" button is grey. If I enable it, the "default" profile is checked. When I exit out of the page and come back to it, the Firefox browser is unchecked and the "Profiles" button is grey again.
  • hnbockhnbock
    edited January 2011
    I uninstalled Firefox (erasing my settings) and reinstalled. The problem ended.
  • DBrownDBrown 1Password Alumni
    That's good news! Thanks for updating the thread.

    I'm sorry it required such drastic measures, but profiles do seem to complicate things in ways I don't entirely understand.
This discussion has been closed.