Login fails on www.hevanet.com

This discussion was created from comments split from: 1P doesn't manage to log in a given page....

Comments

  • I have a similar problem, except it only happens once in a while (once in six or seven tries, maybe?) and only at one particular site. Doing the copy-and-paste works. Exiting the site and trying again usually works. It's not a password-length issue, since the password is only 7 characters long. (There's no worries about the weakness of the password.) I've tried re-creating the log-in manually, with no change in results.

  • littlebobbytableslittlebobbytables

    Team Member
    edited April 2015

    Hi @ASquash,

    If the Login item normally works and logging out of the site returns it to normal behaviour then it sounds more like potentially a cache or cookie issue. Maybe you're being directed to a slightly different page for some reason because you were previously logged in. It's hard to tell at this stage.

    We'd need to know a little more I think.

    1. The site in question.
    2. Any observations you can make regarding patterns. Does it only happen when you're logged in, is it more specifically only after you've been logged in for a while? Is the page you are having issues with one you normally use, do the URLs match?

    I don't think it's related to the original issue if you find that the Login item normally works, for these two to be related I'd expect your Login item to always fail. Let's see if any extra detail can help narrow down the issue :smile:

  • Hello, littlebobbytables,

    The site is the junk mail filter associated with my ISP and email service. The ISP's address is http://www.hevanet.com/index.html; the junk filter's address is https://sec.hevanet.com/JunkEmail.html. The problem is most common when the filter is the first place I go after turning on the computer and opening the browser (Firefox). The ISP's page is my home page, so opening the browser takes me there straightaway. I have Firefox set to open at login". I don't always go there first thing on startup, nor do I always go to the filter first. I usually check the filter only first thing in the morning, and don't have enough observations to say whether the problem also exists in connection with trying the filter later in the day. I'm using OS X 10.9.5, Firefox 36.0.4, IP 4.4.3; the IP extension is 4.3.0.

    The ISP has changed junk filters since I originally created the login in 1P3. The URL in the 1P login is not the current URL for the filter, but it gets me to the site. Then, it usually connects me with my wonderful spam.

    This problem existed in IP 3, too. I used the same work-around; re-creating the 1P login didn't solve the problem then, either. I have updated OS X 10.9.x, Firefox, and--obviously--1Password and the Firefox extension since the problem first appeared.

    What am I overlooking?

  • dtearedteare Agile Founder

    Team Member

    Thanks for the details, @ASquash. Maybe I'm missing something but I was able to create a new Login and it worked for me in Chrome and Firefox.

    Instead of creating the Login from within the browser, can you try creating it from within the main 1Password app instead? It shouldn't matter as I tried both but just incase I'd like you to give it a try.

    One note I should mention is I was using 1Password 5.3 beta for the main app, but I simulated tests for the way 1Password 4.4.3 would do things. If creating the Login within the app doesn't help, I'll ask @littlebobbytables to jump in here as I know he has a setup with 1Password 4.4.3 handy.

  • If only my strudel could be as flaky as this glitch. I can go for several days with no problem, then have the problem more than once in quick succession. I have Firefox set to delete all cookies when exiting, so that seems unlikely to be the issue when the computer has only just been started. I haven't been regularly purging the caches or .plist files; since it has never gone wrong more than once at a time, I have no good way to do controlled experiments. The current Login was created from within the main 1P, with no obvious change in flakyness. Should I be revisiting the idea of sacrificing a small goat?

  • Hi @ASquash,

    So I tried creating a fake Login item using our How to manually save a Login guide in the following environment.

    OS X 10.10.2 (I don't have a Mavericks machine any more)
    1Password 4.4.3
    Firefox 36.0.4 + 1Password Browser Extension 4.3

    What I then did was attempt to fill on https://sec.hevanet.com/JunkEmail.html using ⌘\ and then I cleared both fields by visiting http://www.hevanet.com/index.html before returning to https://sec.hevanet.com/JunkEmail.html. Doing that a number of times I haven't been able to replicate any flakiness. It means I'm at a loss as to why you're experiencing what you are.

    I can spitball possibilities with you but they will be guesses.

    1. It can't do any harm to completely purge the cache in Firefox.
    2. Do you run with many other Firefox plugins?

    I'm also curious by precisely what you mean from your first post where you stated "Exiting the site and trying again usually works"

    We'll hold off on the small goat for now, for starters I have no idea what cleaning compounds you could use to clean up the Mac afterwards.

  • Hello, @littlebobbytables ,

    The only extension installed is 1P 4.3.1. I've got a bunch of plugins, but the only one that is automatically always active is the OpenH264 Video Codec; everything else is "ask to activate".

    What I was intending to say about exiting the site and trying again is that if I click on the "Home" button in Firefox, taking me back to the Hevanet home page, and then starting over with clicking on the spam filter link, then clicking on the keyhole button and clicking on the login for the spam filter, I succeed in logging in. So far, I've never had the error message in two successive tries. Using Firefox's "back" button also works, if I go all the way back to the Hevanet home page, not just to the spam filter login page.

    I'll try clearing the Firefox cache(s).

    As to the goat, I'd been planning to click on the ubiquitous and endlessly annoying advert for "Clean My Mac". Is that not recommended?

  • Hi @ASquash,

    I would personally recommend against any cleaning application. Certainly we know users in the past that have been caught out by app cleaners deleting their vault as they didn't realise what the program was intending on doing. I don't know Clean My Mac so it might be okay or at least useful for certain circumstances but in general I would shy away from them and they would have to build a strong case as to why it should be on any system I care about and what can it do that I can't myself. Maybe I'm being unfair but I grew up seeing these sorts of things on various versions of Windows and I don't think any of them ever lived up to their claims there either.

    The next time you experience this particular issue can you try something for me please. Instead of clicking on Home and then returning to the login page, what happens if you hold down the shift key and click on the page reload button? I believe this is should force a full reload of the login page and I'm thinking this will work as effectively as your current workaround. I'll certainly be interested to know if that works :smile:

  • Hello, @littlebobbytables ,

    Okay, this is embarrassing; it was a problem with the chair/keyboard interface. The ISP's analysis was that I was trying to access the junk filter while the email was still downloading, which blocked access. The problem seems to have been fixed by taking care to wait a bit longer before tying to access the junk filter. Thanks for your efforts.

  • Hi @ASquash,

    I think it's fair to say that was never going to be an easy one to guess, not without some investigating at a level that neither of us had access to :smile:

    Hopefully no more issues!

This discussion has been closed.