Upgrade is failing

I recently upgraded my Mac to Yosemite and reinstalled 1Password version 3.8.21. When i tried to update the software after the files were extracted, I got the following error...."An error occurred while extracting the archive. Please try again."

Any thoughts on ways to resolve this?

Additionally, even though I was able to add the Firefox (version 37.02) extension, the computer returned the following error message..."The 1Password app must be installed for the extension to work properly". I presume that is because of the problem above.

Thanks for any help.

Comments

  • dancodanco Senior Member Community Moderator

    How did you extract the files? I have seen some reports of problems when using a third-party unarchiver, rather than Apple's built-in one.

  • Hi @mock3532,

    I would have to hazard the guess that either it's a corrupted download or as danco suggests, a third party archive program that is having trouble handling the zip file. I've just tried downloading 1Password 3 from our site and it extracted with no issues.

    I would suggest deleting the zip file from your Downloads folder and try downloading a fresh copy from our AgileBits Download page before extracting the application using the Archive Utility which is the built-in OS X application for this.

    Please do let us know how you get along.

  • i used the Apple built-in unarchiver. It is virtually a brand new operating system with very little third party software loaded in. I also reloaded the software from the link you gave me but the extension could find the app even though it is loaded in my computer.

  • Drew_AGDrew_AG 1Password Alumni

    Hi @mock3532,

    Since you're having trouble with 1Password 3, I've moved your discussion to our 1Password 3 for Mac forum, where you'll be able to get more help specifically for that version, if necessary.

    So it sounds like you were able to download version 3.8.22 and extract it correctly? Hopefully that part of the problem is solved, but please let us know if you need more help with that.

    As for the problem with the extension not finding the 1Password app, my first guess is that you installed our newer extension which is compatible with 1Password 4 and 5. To install the correct extension for version 3, open the 1Password app and go to the menu for 1Password > Install Browser Extensions. That should open the site for the correct version of the extension. Does that help?

    By the way, I was able to find your license in our system, and because you bought your 1Password 3 license in 2013, you were given a free upgrade to a 1Password 4 license when we released that in October 2013. The latest version is 1Password 5 for Mac, which is a free upgrade for 1Password 4 license owners. Version 5 was specifically designed for Mac OS X 10.10 (Yosemite). Was there a particular reason for trying to use 1Password 3 on Yosemite? In case you didn't know you already had a license for 1Password 5, I've resent your license info to the email address associated with your forum account.

    Please let us know if you have more questions about that or if you need anything else. Thanks!

  • Thanks Drew. I reloaded everything with the version 5 app and that seemed to work including the extensions.

  • That's great to hear Drew was able to help @mock3532 :smile:

    As this seems to be resolved I'm going to close this thread but if you have any questions or issues in the future don't hesitate to post!

This discussion has been closed.