Citibank username login issues [manually save new login]

«1

Comments

  • Went From A Mac with Mavericks - no issues using 1Password on Citibank login. Now on a Mac with Yosemite - 1Password will not autofill the UserID.

    Makes 1Password pretty useless if I have to remember the passwords and manually type them in - any suggestions?

  • brentybrenty

    Team Member
    edited April 2015

    @LaneHasler: Sorry for the trouble! Strange, because my Citi login is working much more reliably now...

    ..which is what I was going to say, but it turns out they changed it again! :angry:

    I logged in and paid my bill just a week ago or so I think. Anyway, my guess is that you're using a URL similar to this:

    https://online.citibank.com/US/JPS/portal/Index.do

    Sadly, this form isn't working well anymore. I got it to fill a few times, but it seemed almost random. Fortunately, I had much better results on these URLs (selected from the "Sign on to" menu in the upper right):

    https://www.citi.com/credit-cards/creditcards/CitiHome.do

    We will have to investigate further to see if we can tame those other login forms as well, but in the mean time this should serve as a workaround. I hope this helps! :)

    ref: OPX-546

  • brentybrenty

    Team Member
    edited April 2015

    @LaneHasler: Just an update: I was able to get my Citibank login working at all of the following URLs by resaving it:

    https://www.accountonline.com/cards/svc/LoginGet.do
    https://www.citi.com/credit-cards/creditcards/CitiHome.do
    https://www.accountonline.citibank.com/cards/svc/LoginIntNext.do
    https://www.accountonline.citibank.com/cards/svc/LoginGet.do
    https://online.citibank.com/JSO/signon/LocaleUsernameSignon.do
    https://online.citibank.com/US/JPS/portal/Index.do

    Please try to manually save a new login at one of those last two and let me know if that helps (resaving the login at the others made no difference in my case).

    Also, I hope you don't mind, but I've moved this conversation to our new dedicated browser filling section of the forums. :)

  • Still having the problem with Citibank login - Any Update on a Solution This is one of the top 5 passwords for me so having it not work in 1Password is a real glitch

  • brentybrenty

    Team Member

    @LaneHasler: Hmm. I just paid my bill last night, and I'm not having trouble logging in today either. Are you having trouble logging in at a particular URL? Please try resaving your login as I suggested above.

    If you're still having trouble, knowing which OS, 1Password, and browser versions you're using may help us get to the bottom of this. Thanks in advance! :)

  • https://online.citibank.com/US/JPS/portal/Index.do is the URL I'm using Mac Yosemite OS Safari 8.0.6 and 1 Password 5.3.1

  • brentybrenty

    Team Member

    @LaneHasler: Ah yes. As I mentioned in my previous post,

    Please try to manually save a new login at [the URL you're having trouble with]

    as I was able to fill at all of the URLs above after manually saving at the page you linked. Cheers! :)

  • rsluebrslueb Junior Member

    Saving a new login only works some of the time. But even when it does work, all of the ancillary information such as the security questions/responses and user profile information is not present. It has to be manually copied from the old login to the new - a bit of a hassle.

  • MeganMegan

    Team Member

    Hi @rslueb,

    You're right, a new Login won't have all the nicely saved security questions. 1Password mini makes it easy to copy this information into your new item however. Try this:

    • Use ⌘⌥\ ( Command-Option- \ ) to open mini.
    • Type the title of your old Login.
    • When the correct name is highlighted, use the arrow keys to move over to the details view.
    • When viewing the details, use ⌘O (or click the anchor button) to pin the details to your screen.
    • Now you can click to copy the details and paste them into your new entry.

    I hope this helps!

  • rsluebrslueb Junior Member

    That's a good tip I was previously aware of. Unfortunately, I still can't reliably logon to the Citi website even after saving a new login. It's not a serious problem though, just an inconvenience.

  • Drew_AGDrew_AG 1Password Alumni

    Hi @rslueb,

    I'm glad that tip was helpful for you! It comes in really handy for me too. :)

    Citi login sites are rather notorious for not playing nice with 1Password, and it seems like every time our developers get the 1Password extension to work correctly there, Citi changes something on their site, and it's "back to the drawing board" again! :dizzy:

    I also have a Citi login, and in case it helps, right now I seem to have the most luck using 1Password with the following Citi login page: https://www.accountonline.citibank.com/cards/svc/LoginGet.do

    They do seem to have a lot of different pages where you can sign into your Citi account, so if you're having trouble with one, it often helps to try saving a new Login with one of the others. I've also tried adding several Citi login URLs to my Login item, although that doesn't always work since each Citi login page works differently "under the hood".

    I'm glad to hear it's not a serious problem for you, but if you'd like more help with that, please do let us know, and we'll be happy to work further with you. Take care!

  • When attempting to login to Citi Credit Card using Auto Fill or "Copy and Paste", Citi login does not recognize the username and forces you to manually enter the username before accepting the password.


    1Password Version: 1Password 5
    Extension Version: 5.4.BETA-27
    OS Version: Mac OS 10.10.4
    Sync Type: Dropbox

  • There's a long discussion here (on the Saving and Filling in Browsers forum) about the challenges presented by the Citi logins. Maybe some of the suggestions later in the thread will help you.

    Stephen

  • sjksjk oversoul

    Team Member

    Hi @dugersd,

    Let us know if you're still having trouble getting a working Citi Credit Card login if nothing in the discussion that @Stephen_C referred to helps and we'll see what else we can do for you. Thanks!

  • Thank you for the feedback.

  • MeganMegan

    Team Member

    Hi @dugersd ,

    We're always happy to help! Our team is always working to improve 1Password's filling and Citibank is one that we'd love to conquer once and for all. ;)

    We appreciate your patience as we work on this unique site.

  • No worries. I just hope to help you when I can . Thanks

  • sjksjk oversoul

    Team Member

    Thank you, @dugersd. Hopefully we're able to help you, too! :)

  • coastertuxcoastertux Junior Member

    I think they just changed their form again because I've been having issues recently too and I tried re-saving a new login manually with the instructions above. What happens is when I fill, the username field turns red and the website doesn't change it from username to us*****me like it usually does. If I turn off auto submit, I can re-enter my username manually and it does its normal thing and I can login.

  • sjksjk oversoul

    Team Member

    Hi @coastertux,

    Thanks for describing the trouble you've had with your Citi login and the workaround for it. Sorry this can be such a game of Whac-A-Mole for you and other folks.

    I've moved the thread that @dugersd started into this related discussion in Saving and Filling in Browsers that @Stephen_C referred to. Having it in one spot can make it easier for others with Citi issues to find this hopefully useful information.

    Enjoy the rest of your weekend!

  • I just rechecked my login record for my Citi-managed Best Buy Visa, and it is still working fine, including automatically filling and submitting my credentials. I continue to be able to log in successfully, without having to change anything.

    If it helps, my login page is https://www.accountonline.com/cards/svc/LoginGet.do

  • brentybrenty

    Team Member

    Indeed. My results are the same. I think part of the issue that some are experiencing is that many previous Citi login pages now redirect. Currently I am seeing the following 3 destination login pages (down from roughly 8 a few months ago):

    https://www.accountonline.citibank.com/cards/svc/LoginGet.do
    https://online.citibank.com/US/JPS/portal/Index.do
    https://www.citi.com/credit-cards/citi.action

    As hawkmoth mentioned, the first one (https://www.accountonline.citibank.com/cards/svc/LoginGet.do) is the one you want to use (although the others will work too, it's more of a hassle. Manually saving and filling the login there works best. Just be sure to double-check to make sure that your actual username and password are saved correctly in the Login item (rather than b*******), and I'd also recommend saving the other two URLs in the item as well, in case Citi decides to do more redirects in the future.

    And, to end on a positive note, let's count our lucky stars that Citi doesn't use a multi-page login process as many other financial institutions do. Heh. I hope this helps! ;)

  • https://www.citi.com/credit-cards/citi.action

    The Safari extension doesn't work with this site. It doesn't load the user name, It has to be copied and pasted. I'm sure it's something they've done, but it's unfortunate for such an important commercial site.


    1Password Version: 5.4b32
    Extension Version: 4.4.3b2
    OS Version: 10.11b7
    Sync Type: WiFi

  • sjksjk oversoul

    Team Member

    Hi @TomWolsky,

    I've moved your Safari extension not working with Citicard post from Mac Beta into the discussion of this issue here in the Saving and Filling in Browsers category. Please take a look at the post from brenty right before yours and see if it helps you create a working Login item for the Citi site that you're having trouble with. Thanks!

  • Thank you sjk and brenty for the URL. Works fine.

  • sjksjk oversoul

    Team Member

    Great news, Tom! Thanks for giving that a try and letting us know it works, both so quickly. :)

  • this didn't work for me, unfortunately. i've tried manually adding a login and adding all the abovementioned URLs. i've tried removing the saved username, ive tried deleted the saved pw in 1pw, but it will not ask to save again, so my only option is to manually add another.

    it will autofill the username, but not the pw. what a bugger

  • Autofill of my username is not working for me, either, on Citi.com (banking). It does autofill the password. Autofill for both username and password works correctly on Citi Cards (credit cards), which is a separate login.

    The banking URL I am using is https://online.citi.com/US/JPS/portal/Index.do. The Citi Cards URL is https://www.accountonline.citibank.com/cards/svc/LoginGet.do.

  • brentybrenty

    Team Member
    edited March 2016

    @cars10, @verdi1987: Hey there! As I mentioned in my previous comment in August of last year (in the old discussion you're commenting in now), you'll need to save the login manually:

    1. Navigate to https://www.accountonline.citibank.com/cards/svc/LoginGet.do (Edit: This page will actually redirect to https://accountonline.citi.com/cards/svc/LoginGet.do now, so this URL is fine too.)
    2. Enter your login credentials
    3. Click the 'keyhole' icon to bring up the extension
    4. Click the 'gear' icon for Settings
    5. Click Save New Login
    6. Give it a name and Save
    7. Close the webpage and select your new login from the extension to have 1Password Go & Fill
    8. Submit the form manually if you have autosumbit disabled

    Something in particular to note here is that if you save the login with the **** in the username, that's what you'll get; 1Password will faithfully save and fill that ****. So you'll either need to focus the username field to remove the **** before saving, or manually edit the item in 1Password afterward to replace that *** with your actual username. I think you'll find that works much better. Cheers! :)

  • cars10cars10
    edited March 2016

    @brenty,

    thanks for your response. I really thought I was close. You were right, its the damn little asterisks that cause it to mess up. Nice one, citi!
    I could not find a way to save it without the asterisks, as soon as I went to click on the extension the damn javascript would change it.

    Unfortunately, once I went to edit the username and replace the asterisks in 1pw it no longer fills in the password on the site (but it does fill in the username) and both fields turn red.
    GRRR

    edit: i thought i would do a workaround and disable javascript just to get 1pw to finally save it correctly, but the citi page doesn't load without JS. lovely

This discussion has been closed.