To use 1Password extension in Chrome, the main 1Password program has to be installed as well

downloaded the beta version, I can see the logo in my Chrome browser, but I can't find the setup / .exe file in my downloads where I can install 1Password. What am I doing wrong?

Comments

  • It says: ,,The Chrome extension was succesfully installed".

  • brentybrenty

    Team Member
    edited March 2015

    @StefMooij: I'm not sure you're doing anything wrong necessary, but it sounds like Chrome maybe didn't save what you expected it to.

    Just to make sure we're on the same page, the 1Password browser extensions and the main 1Password app are separate downloads (since not everyone uses the same web browser).

    It sounds like maybe you've already installed the extension from here, and just need to download and install the main 1Password app from here now.

    Be sure to check out our 1Password for Windows user guides, and reach out if you have any questions. We are always here to help! :)

    P.S: We are still in the process of updating and migrating the Windows guides to the new knowledgebase, so I apologize for any confusion this might have caused!

  • StefMooijStefMooij
    edited March 2015

    Thanks a lot @brenty!

    I will try to figure it out with your instructions. If I don't, I will be back in this threas :)

    It should not make any difference wether I want to use the Beta or regular version for Windows, right?

    I already read on the Internet about the great community behind 1password and this is now confirmed for me.

  • brentybrenty

    Team Member

    @StefMooij: Indeed. And you are most welcome!

    The process is the same whether you're using the current beta or the regular version (since it isn't an overhaul like a new major release). Our guide is a great general resource when you're just getting started. And if you run into trouble or just have questions, we're here for you!

    Thank you for not only your support, but your kind words. We really do have a great community here! :chuffed:

  • StefMooijStefMooij
    edited April 2015

    Okay @brenty, so i've managed to install the programme and have the normal (not beta) extension in my Chrome browser.
    I followed the guide step by step and tried to let 1Password save my username and password for Facebook and Dropbox first. But when I logged in, the browser extension did not ask me to save my file. When I look in 1P and into my Login, there is nothing.

    What am I doing wrong?

    • Do I need to start the laptop one more time? (will try that immediately)
    • Is the 2-way authentication blocking 1P?
    • Is the fact that I deleted all previous memorized passwords by Chrome an issue?
    • I first saved the file on my computer on my HD and then read in the manual that I can best leave it in the map 'documents' so I did. Without changing the name of the file, it's still .agilekeychain
    • Doesn't it work because I first downloaden the free version of 1Password?

    EDIT: I've tried to submit my Facebook account and password manually in the 1P programma and that worked when I used the Chrome browser extension. Does that mean I have to manually insert all my usernames and passwords?

    When I manually insert the username and password in the 1P programme, it keeps telling me that the preference is to insert the data via the browser extension, but I don't know how.

    SECOND-EDIT: It finally suggested out of itself to remember my password, I think the problem is solved. To be continued.

  • @brenty so the programme all works. I now want to install it to my Android device which should work fine.

    The only problem I have now, is that I want the vault (Map in C:/documents) to be copied to my dropbox account, so my vault is in the cloud and I can easy acces it via my Android device. What's the procedure for replacing the vault to another place (From C:/ drive to dropbox)?

  • StefMooijStefMooij
    edited April 2015

    So I found out that I can move the map to my dropbox account and on my laptop the programma is still working, so I guess that went well.

    But when I try to sync my android via the 1P app and then click op dropbox sync and I enter my master key password, nothing happens. Then it says the location no longer exists..

  • MikeTMikeT Agile Samurai

    Team Member

    Hi @StefMooji,

    Is it possible Dropbox hasn't finished its sync on your PC yet? If it is not finished, 1Password on your Android device won't find everything it needs to download from Dropbox, which is why it said it can't find data.

    On your PC, you should see a green checkmark on the Dropbox icon in your system tray area. Once you do, try again with 1Password on your Android device, see if it will now unlock.

  • Thank you for the quick response @MikeT,

    I see a green checkmark on the dropbox logo on my laptop. And I can even find the map on dropbox were the .agilekeychain file is located (Dropbox/Apps/1Password/1Password.agilekeychain).

    But still, when i start up the app on my Sony device, it says the file no longer exists.. It starts syncing when I enter my Masterkey, but stops after 1 second and goes back to the main menu.

  • brentybrenty

    Team Member

    @StefMooij: Sorry you're still having trouble there! I have a similar issue with Dropbox from time to time, but I had guessed it was because I do so many crazy things to my Dropbox data during testing. Perhaps you are running into a similar issue.

    What file does it say is missing exactly? In 1Password for Windows, please try File > Repair 1Password Vault to make sure that it is intact. Then allow Dropbox to continue syncing.

    On your phone, try to set up Dropbox sync again and point 1Password to your vault in Dropbox. Often when I run into this problem, just retrying a few times (or coming back to it later on, once Dropbox is settled) works. Just make sure the path to your 1Password vault in Dropbox on your phone matches the path on your computer, in case it is looking in the wrong place.

    Please let me know what you find. I look forward to hearing back from you. :)

  • StefMooijStefMooij
    edited April 2015

    @brenty: it's okay as long as I get help! And I did.

    So I've synced dropbox and re-installed the app on my smartphone and now it works :) What an easy solution it was...

    But I have one more question: how do I get to my logins, when I'm on a different computer or smartphone, which doesn't have the browser extension of app?

    And I'm definitely going to purchase the pro version of 1Password after 30 days of try out, but do I have to purchase for both laptop and smartphone? And again when I change phone of laptop?

  • brentybrenty

    Team Member
    edited April 2015

    @StefMooij: Excellent! I'm glad to hear it's working for you now. :+1:

    1Password is licensed per-platform, so if you have multiple Windows PCs you use, you only need to buy a single license for 1Password for Windows.

    1Password for both iOS and Android (depending on what phone you have) are both free apps, with an in-app purchase to unlock the pro features. And for instance if you go from one iPhone to a new one, your purchase will carry over since it is tied to your App Store account; however, if you go from iOS to Android, that would be a separate purchase.

    Since you're syncing with Dropbox, you can actually access your 1Password data on some devices using 1PasswordAnywhere. This is a webpage inside your vault (1Password.agilekeychain/1password.html) in Dropbox which you can open in your web browser to view your data. Just be sure that you open it through the Dropbox website (rather than from the computer's hard drive) since most browsers won't allow webpages to access the local filesystem.

    I hope this helps. Let me know if you have any other questions! :)

  • StefMooijStefMooij
    edited May 2015

    @brenty Thanks so much for the help so far.

    I've now bought the license for Windows and happy with my purchase.

    The only thing not working is the extension on a different computer then my own. I'll explain what happens:

    When I open Chrome on a different computer, and I log in on Chrome, the extension becomes visible in the upper right corner of the browser. When I try to open my vault through that extension, it gives tries to load something and then gives an error.

    Then I tried to find the problem with the trouble shouting button, but there didn't seem to be anything helpfull over there. Or something I could relate to.

    I hope you can help me out on this one, then everything will be perfect!

    Gr Stef

  • MikeTMikeT Agile Samurai

    Team Member
    edited May 2015

    Hi @StefMooij,

    When I open Chrome on a different computer, and I log in on Chrome, the extension becomes visible in the upper right corner of the browser.

    Do you mean logging into Chrome to enable the Chrome Sync, which then installs the 1Password extension as well?

    When I try to open my vault through that extension, it gives tries to load something and then gives an error.

    Can you tell us what the error was or if you can, take a screenshot of it for us.

    Also, can you give us the version of the 1Password extension that is installed in that specific Chrome browser. To find out, open Chrome, right-click on the 1Password button to select Manage Extensions and the version should show up next to 1Password.

    It sounds like maybe Chrome installed the previous version of 1Password extension that is not compatible with 1Password that is installed on that computer. To use 1Password 4.x extension, you also have to have 1Password 4.x for Windows installed.

  • I have got version: 4.3.1.90

    First it says: looking for the 1password helper...

    Then it says: either the helper is not running, or something prevents it from communicating with the 1password browser extension.

    I hope this was helpfull.

  • brentybrenty

    Team Member

    @StefMooij: Just to clarify, the 1Password extension in Chrome (or any browser, for that matter) won't be able to work without the main 1Password app installed. I believe that's why you're seeing this error. 4.3.1.90 sounds like the current extension version, but you'll need the app installed to be able to use it!

    When using a friend's computer, if you're using Dropbox to store your 1Password data you can actually use 1PasswordAnywhere to access your vault through the Dropbox website. WHIle it isn't as full-featured as the...well, full 1Password app, it's handy to use in a pinch when you need to access something. I hope this helps! :)

This discussion has been closed.