How to save second login item that is no "password"


I already tried some stuff from the HowTo's and searched the Forum, found some similar stuff, but nothing that helped.

I have a site to login which needs a phone number and a PUK-code. The PUK-code is not set up as password field. Additionally, the site relies heavy on javascript; the input-fields have no "name" but will be queried by "id", and the login-button is no "submit", but a link.
This works absolutely fine in normal browsing, however it is difficult to get 1password to fill this. Even though the PUK is not a password, it's not memorable so it would be great to use 1password to login.

The site is - then you click on "Ihr Tablet oder iPad kann kein SMS empfangen?
Nützen Sie das Login mit HoT-Rufnummer und PUK." to get the two fields - phone number and PUK1. The fields are not named, but have the id "MsisdnPuk" and "Puk", so it should be theoretical possible to at least fill those, if not submit. I tried the "Save new login" function, to no avail - probably because 1password does not detect the login here (nothing happens when I click that - on other sites, it does - asks me about a name to save it). I tried saving the form-fields to the web-form details in 1password - which also fails, probably because the fields have no names?
The funny thing is, the phone number will be filled, the PUK not.

Can you point me to how I can configure these login items that this will work? I have several of these logins and without 1password this is a p.i.t.a.

thank you!

1Password Version: 5.3
Extension Version:
OS Version: OS X 10.10.3
Sync Type: iCloud


  • littlebobbytableslittlebobbytables

    Team Member
    edited May 2015

    Hi @noledge,

    You're quite right, we definitely have trouble with that page. It isn't that we can't cope with saving a Login item for a page which doesn't have a password (I have one or two that fit into this bracket in my own vault) but we really don't like this particular one for some reason. 1Password just doesn't want to recognise that there is something to save for some reason (that's both the stable versions and the beta releases).

    Sadly this one might take a bit. I can't think of what else to try at the moment - it has me stumped :(

This discussion has been closed.