Quick search is not working as expected! (even after 1 year)

Downloaded version 5.3 (530029) and still disappointed to see bug that I reported one year ago. Somehow my old post was closed or something, I wasn't able to post there.


1Password Version: 5.3
Extension Version: Not Provided
OS Version: 10.10.3
Sync Type: Dropbox

Comments

  • Hi @pashkatarakashka,

    Your old thread does seem to have been closed. I don't know why, it might be some forum related spring cleaning.

    You're correct, the bug hasn't been addressed yet. The bug report is still open and awaiting dev time. Sometimes we can get sidetracked or a particular bug gets forgotten about. For example, we've had two releases that stand out in my mind, one resolved a number of tricky and serious sync issues. They took quite some time to properly squash if memory serves me correctly. Another related to a series of Secure Note bugs, mostly around rendering. Whilst not dangerous to the data, it essentially stopped many users from being able to interact with their data. I'm sure you would agree with me that as frustrating as the search bug is, making sure syncing doesn't mess up your vault overrides everything else in terms of priority. Being able to view your data is a strong second too.

    We'd love it if we could address all bugs as they were reported but the resources required mean that isn't even remotely practical. So we have to do what every software development team does, assess, prioritise and hope not too many surprise events happen that throw everything up in the air.

    I say all of this because when I say I will raise the issue again with the developers I would like you to believe I'm being honest with you. I will raise the issue but it might be there are other bugs deemed more important to tackle and I'm not in the position where I can make any promises. I can imagine that might seem very frustrating but misleading you with expectations that can't be backed up seems worse.

    ref: OPM-1323

  • In other words this bug has the lowest priority ever. By the way, I have tried the same on Windows and search works as expecting.
    Being software engineer myself, I understand all you said, but still missing such obvious bug for years is really something which I will hardly understand. Thanks for your efforts and being honest anyway.

  • Hi @pashkatarakashka,

    It may be I bring up this bug report and somebody gasps that it seems to have been neglected this long. I wouldn't to second guess what the response may be. What I see from the bug report is it seems to be fairly low profile amongst our users, heck, I didn't even know it misbehaved like that and I use 1Password for Mac more now than I ever have in the past.

    It still needs to be addressed though, if only so our Windows dev can't rightfully point out that 1Password for Windows does it correctly.

This discussion has been closed.