Login issue [Sams]

Login problems
I am having trouble logging to the Sams Club credit card website both with the windows and the ipad/ipod touch apps:

https://www2.onlinecreditcenter6.com/consumergen2/login.do?subActionId=1000&clientId=sams&langId=en&accountType=generic

This is a two-step login website. First, you type your userid, then in a different webpage you type your password. The problem is that 1password (windows and ipad) cannot resolve this with one login entry. That is, I have been able to find a workaround this problem by creating two different login entries in Windows. One is for the userid and the other one is for the password. I use the fill option (Ctrl+\ then fill login) on each page with its corresponding entry, but this is impossible to do on the ipad since it opens its own website and you cannot use the fill login. On a mac (yes, I am a customer with the three versions of 1password and love the program!), only one login entry is required and it is quite intuitive to just right-click and fill in the userid and the when the new page loads right click again and click fill in again and it knows that it should fill in the password.

I would appreaciate any help on how to resolve this issue on both the windows and iOS environments.

Thanks,
David.

Comments

  • MikeTMikeT Agile Samurai

    Team Member
    Hi Dake, welcome to the forums!

    Have you try using the “Globe” icon on the 1Password browser’s toolbar? That brings up all the possible Logins that you can use to fill in on the web site, you should be able to log in on the second page using that Globe Icon.

    It sounds like you are using two Logins for 1Password for Mac as well. Am I wrong? It is possible you can configure a single Login to have the specific field names from both pages, so that 1Password can auto-fill specific fields on both pages with one Login.

    At the moment, for 1Password to work with multiple pages, the best way is to create a Login for each page. This is true for all platforms.
  • Hi Tom!

    Yes, I have clicked on the globe button on the 1Password browser’s toolbar on my iOS environments. The only thing that shows up is a ballon that says logins. If I click on it, it doesn't do anything.

    I am only using one login with my macbook pro. It somehow "understands" that it needs to fill up the first part of the login (the username) on the first page, and then when you click submit and the new page loads asking for the password, if you click on the empty password field and do a right-click, you can use the 1password 'fill in' command and it correctly fills in the password. But if I use the same login in Windows or the iOS platform, it does not work in the same way.

    By the way, I have all my logins syncronized with dropbox across all platforms. So, I am using the exact samer logins across all platforms. So, it seems to me that it is definitely a problem particular to how 1Password works on each different platform. Also, I should mention that I am using the latest version of ie8 on my windows (windows 7) machine, and I cannot install another webrowser due to company policy.

    Any ideas?
  • DBrownDBrown 1Password Alumni
    edited February 2011
    Dave, you're right that 1Password works differently on the three platforms, which is the reason why some Logins work on one platform but not on another. :(

    Please try this:
    1. In 1Password for Mac, make a duplicate of the Login that's working.
    2. Edit the duplicate Login, and remove all fields except for the two designated as username and password.
    3. Try using that duplicate Login on the Mac; then try using it in Windows.

    Please let us know how it goes.
  • Dave,

    My mac is at home now, but I will do it as soon as I get out of work and will post my results.


    PS. Mike, I am sorry I called you Tom in the previous post... too little sleep over the past few days! =)
  • DBrownDBrown 1Password Alumni
    edited February 2011
    dake wrote:

    Dave,

    My mac is at home now, but I will do it as soon as I get out of work and will post my results.


    PS. Mike, I am sorry I called you Tom in the previous post... too little sleep over the past few days! =)

    Just for the record, I go by David. (giggle)
  • So, that makes it 0 for two on the names. David, I guess you can call me Pete from now on... :D

    OK so I made a duplicate of the working login and removed everything except the password and username fields. I tried it on the mac and it worked the same way as the original (perfectly!). I tried it on the windows environment and the iOS, and it failed the same way as the original. :(

    Thinking about Mike's post, I also checked another login in the iOS and the "Globe” icon on the 1Password browser’s toolbar behaves as it should. It pops up a logins menu and shows the "active" login. BUT on the Sams club website, the "Globe" icon only displays the popup but no entries are displayed. I'm stumped! It's strange, I have been using 1password for a while and noting like this has ever happened before. It normally just works!

    Any other ideas David?
  • DBrownDBrown 1Password Alumni
    No problem, Pete. ;)

    I think the difference is in how the Mac, Windows, and iOS versions handle URL matching, particularly in terms of "precision" or "granularity." I'll ask the developers to look into it, in case that's a false conclusion.

    For now, you may need to have a single Login for use on the Mac and two logins (one for each page) for use in Windows. Some experimentation would show whether a third Login (or pair) is required for iOS.

    That'll be kind of a pain to set up and kind of a pain to maintain (if you change your password, for example); but 1Password on each platform should offer only the Login or Logins that work on that platform, so it shouldn't be a pain to actually use, day to day.

    We'll continue trying to improve consistency in this area, in future releases of all our 1Password products.

    Thanks for your patience, Dave!
This discussion has been closed.