Fill on Hikvision IP Cameras

I own quite a few Hikvision cameras. When I invoke Fill, the username and password end up with "anonymous" and 5 bullets for the password field. I manually entered the correct credentials then manually saved from the 1P plugin. Confirmed that it saved correctly in 1P. However, it fails to ever work on fill in (not using autofill)...

Not sure how to get help from anyone including agilebits on this one as the cameras are local to me and not available on the interwebs. (I supposed I could privately open it up to the agilebits people and let them try).

Any one have ideas?


1Password Version: 4.4.3
Extension Version: 4.3.1
OS Version: 10.9.5
Sync Type: DropBox

Comments

  • brentybrenty

    Team Member

    @ravedog: You've come to the right place! Unfortunately without a URL it's hard for us to test this ourselves to either offer a solution, a workaround, or improve 1Password in the future.

    However, it is also important to note that 1Password 4 is no longer under active development, so it won't be able to take advantage of improvements we've made since then or any in the future. If you're able to use Yosemite, 1Password 5 is a free upgrade for all 1Password 4 customers, and we've done a lot of work there in the past year to make filling even better.

    The best thing to do would be to upgrade, since saving the page source and sending it to us might help us improve filling there (if it doesn't already work), but any changes we make won't be backported to 1Password 4. But regardless it might be best to continue this conversation via email (in case files or other information needs to be exchanged), so just send it to support+forums at agilebits dot com, and be sure to include a link to this forum thread and your username in the email so we can 'connect the dots'. Thanks in advance! :)

  • ravedogravedog Junior Member

    I understand but am not going to Yosemite on this machine any time soon. It has really slowed down my machine's responsiveness and I'm on an I7 Mac Book Pro.

    As far as a URL I don't mind opening up one of the cameras to you privately so you can look if you want.

  • brentybrenty

    Team Member

    @ravedog: I hear you! The good news is that OS X 10.11 isn't dropping support for any Macs, and I've heard a number of folks remark that it runs much better on their old 17" MacBook Pros -- and it's still an early development release!

    Go ahead and shoot us an email as I mentioned above and we can pursue this further. If you can include the page source as an attachment, that alone may be sufficient. Cheers! :)

  • ravedogravedog Junior Member

    I sent you people an email! Hope we can figure something out!

  • brentybrenty

    Team Member

    @ravedog: Great! I was able to track it down now that I knew to look for it. I'll close this discussion and we can coordinate there to see what we can do to help. Cheers! :)

    ref: LFE-15674-132

This discussion has been closed.