1P built-in browser problem

tawongtawong Member
I started getting this weird issue with built-in browser in 1Password App for both iPhone/iPod and iPad. When I'm browsing inside 1P all empty fields are filled with my user name. I think this started with last App update.

Comments

  • robrob Agile Customer Care

    Team Member
    tawong wrote:

    I started getting this weird issue with built-in browser in 1Password App for both iPhone/iPod and iPad. When I'm browsing inside 1P all empty fields are filled with my user name. I think this started with last App update.


    Hi, tawong. Could you let us know which website this started with? In other words, which login item URL did you tap to get into the 1P browser, or does it happen with all logins?
  • RobYoder wrote:

    Hi, tawong. Could you let us know which website this started with? In other words, which login item URL did you tap to get into the 1P browser, or does it happen with all logins?


    It happens with all logins including any new logins I created in the App directly. All empty fields on the site would be pre-filled with my login name.
    I just created test login with Amazon in the App. See pic attachment.
  • robrob Agile Customer Care

    Team Member
    tawong wrote:

    It happens with all logins including any new logins I created in the App directly. All empty fields on the site would be pre-filled with my login name.
    I just created test login with Amazon in the App. See pic attachment.


    Yes, that is one reason 1Password for iPhone doesn't autosubmit forms - it might search Amazon for you instead of loggin you in. This can be a problem in some cases, but in that one, I don't think there's much of a problem because when you tap to sign in, the search field isn't activated too. I'll pass this on to the dev team, but I think we've got an update coming for the iPhone that might take care of this issue.

    Thanks for the report!
  • I'm having the same problem with 1P filling forms after logging into a work related website.
    The website is ccs.coair.com/ccs/default.aspx

    photo2hv.th.png

    m8761 is the equivalent of a username. 1P fills any open field on the website with it, basically rendering
    the program too time consuming to use :(

    There are quite a few other people at work that are having the same issue.

    I'm using an iPhone 4 ios 4.1, !password version 3.5.5


    Below is another website with the same issue. www.equinoxforum.net username stratoform

    photo3t.th.png

    So far I've tried backing up the database to the laptop and then wiping the 1p db and restoring.
  • MikeTMikeT Agile Samurai

    Team Member
    edited February 2011
    Hi guys,

    We made a lot of progress in improving our auto-fill engine for the 1Password touch 3.5.6 update. It has been submitted to the App Store for approval and once it is, it’ll be available for you to download. Please do update this thread and let us know if the update fixed the issues or even if it didn’t.

    We want to improve the built-in browser but we do need some help from you guys since we do not have the ability to test the code after logging into the sites mentioned here.
  • edited February 2011
    Thanks for the reply Mike.
    I've also encountered the problem using 1P to log in to the forums here.
    I also forgot to mention before that this field filling started in November.
    Before that 1P worked fine on all the websites I used it with.
  • khadkhad Social Choreographer

    Team Member
    Please do let us know if the issue persists for you once you update to 1Password 3.5.6 from the iTunes App Store. It is still awaiting approval at this time, but we hope Apple approves it soon.
  • I had a similar problem with Apple's support site (discussions.apple.com):

    I was trying to edit a post, and 1Password filled everything in with my email address!
  • 1Password 3.5.5 generates an error using a self generated strong password when logging into Wachovia. They'll be gone soon and THIS DOES NOT MATTER, but might be useful information.

    I can manually cut and paste the 1Password password from the 1Password edit screen into the bank's login in Safari and it works. When 1Password does it in its browser, an error message is generated: "The User ID contains invalid character(s)." The password is just upper and lower case letters and numbers and 14 characters.

    Dropbox sync'd to iMac and 1Password there works as expected.

    Just checked the App Store and there is no update shown for 1Password to 3.5.6 yet.
  • khadkhad Social Choreographer

    Team Member
    edited February 2011
    Welcome to the forums, stevew.

    1Password for iPhone 3.5.6 is not yet available at the time of this post. 1Password Pro 3.5.6 has already been approved, so if you are using 1Password Pro, you should be seeing the improvements on your iPhone. As previously mentioned, please let us know if version 3.5.6 does not resolve the issues for you once you have installed it on your iPhone.

    We appreciate your patience as we await the approval of the update in the iTunes App Store.
  • I just updated 1P Pro to 3.5.6 and it seems to have corrected the autofill problems that occured on the first two websites I used in my first post. Im ad to be able to get functionality out of the app again. Thanks.
  • khadkhad Social Choreographer

    Team Member
    Thanks for updating the thread to let us know. I am glad everything is working well for you! Always good news. :-D
This discussion has been closed.