Accessing Generator History Doesn't Work?

I'm on a page that I generated a password for but I'm unable to see/use the password I generated. It says "passwords for bblabla.blah" and shows a list of entries with the domain name, but click on one does nothing.

The whole reason I even needed to look into the history is silly - I generated a password that wasn't long enough but because I hit submit on the form, 1Password tried to save it off into a login. I clicked Not Now, because I needed to generate another, valid password, but the second time I did it 1Password did not ask me, presumably because I clicked Not Now. Not Now should only ignore that particular instance of generation, not any subsequent ones!

1Password Version: 5.3 (530029)
Extension Version: 4.3.1
OS Version: OSX 10.10.3
Sync Type: iCloud


  • dancodanco Senior Member Community Moderator

    Is the password present, as just a row of dots, when you click on the item? It should be.

    If it is, you have three options. Hover the mouse to the right of the password entry and it will give you a box saying Copy, which you can use to copy it to a useful place. Or you can hold down the Option key to see the password. Or you can click on the Edit button (bottom right of the entry) and click in the password field to have the password availabe until you leave the edit.

  • There was no password present when I clicked on the item.

  • Hi @Vexir,

    I'd like to just make sure I'm on the same page so to speak.

    Any time you copy or fill a password generated by the 1Password mini Password Generator it creates a Password item in your vault and can be found in the Passwords category. If you create this while your web browser is in focus and a web page loaded, like you did, you should even find the URL is the title of the item. By accessing the item directly you should find it easy to copy the password just by clicking on the field and I've never heard of a case where the password generated wasn't saved properly.

    Now some of that you may or may not have already known which is why I wanted to cover it, just in case. If you knew all of that and it doesn't apply/help can you help me understand a bit more please. I'm peripherally aware that you can see a password history from a sub menu of the Password Generator but it's functionality isn't great, I would always recommend going via the main 1Password window and selecting the Passwords category at the moment. Please do let us know how you get along though.

  • dancodanco Senior Member Community Moderator

    I believe, though I could be wrong, that if one uses conventional copy and paste (Command-C and Command-V) to enter the generated password, then it does not get stored in the Passwords category. One needs to use the Copy or Fill buttons of the Password Generator.

  • I was using the fill button. I see the entries that contain the URL of the page I was on when they were generated, and if I am on that page with focus on that browser, then I also see a list of entries in the previously generated passwords section under that page's login item. The problem is that clicking on one of those entries doesn't do anything, or if it does, it doesn't give me any feedback that it did. If it is copying the password into my clipboard, then the app should indicate that it did so.

  • Hi @Vexir,

    My suggestion would be to make use of the main 1Password window. When you interact with 1Password mini and select a Password item it should attempt to fill into the current page. I've just tested with Amazon's login page and selecting a Password item from the Password submenu or via the Password Generator's history submenu does fill (the history submenu doing this is a very recent change). Saying that, this doesn't seem to be behaving well for you and this site. The solid fallback would be to bring up the Password item in the main 1Password window and copy the password to the clipboard by clicking on the password (the default behaviour is to copy) and then pasting into the field. If 1Password doesn't ask if you wish to update an existing Login item then you can force it do so by following the steps in our How to manually save a Login guide. Now the window allows you to either save a new Login or update an existing one and this screenshot should help highlight that.

    Does that help at all?

    @danco, this did indeed use to be the case but we fixed it. Some people assumed using the keyboard shortcut would save the item and there's nothing worse than the loss of a complex password :(

  • I ended up using the main 1Password to retrieve the generated password. I just wish the browser extension would make those available to me as well.

  • Hi @Vexir,

    I suspect it's something specific to the site in question or maybe something in the steps you originally made as you should be able to access a Password item from 1Password mini.

    Try the following and see if you observe the same behaviour as me.

    1. Visit Sign In page.
    2. Open 1Password mini either by clicking on the 1Password Browser Extension icon or using the keyboard shortcut ⌥⌘\.
    3. Navigate to Password Generator and click the FILL button.
    4. This will create a Password item titled
    5. If You clear the sign in page (reloading does the trick) you can fill just the password either by selecting the Password item in 1Password mini's main menu or via the Password Generator's history for this page.

    Screenshot for step 3.

    Screenshot for step 4.

    Screenshots for step 5.

    If the Password item has been created in some other way, so that the extension hasn't been able to associate the Password item with a particular website then the last screenshots won't be what you see. It's only if you create the Password item via extension (so that the browser and a website are in focus) that all the correct elements are filled at the time of creation.

    I would hope if you try that out that you can fill from 1Password mini. It might give some clue as to a different step from what you did yourself or maybe there is something just odd with the specific site in question that you've been interacting with. Hopefully that is all of some interest to you.

This discussion has been closed.