Safari issue on Mac [followup troubleshooting via email]

Trying to use 1Password at web site https://www.mysynchrony.com/index.html, and can't get 1password to file in username or password, whether i use the browser plugin or not. Conversely, was able to make it work when switching to firefox. Safari is my default browser, so would prefer to use it. Thanks.


1Password Version: 5.3.2
Extension Version: 4.3.1
OS Version: OS X 10.10.3
Sync Type: dropbox

Comments

  • AGMarshallAGMarshall 1Password Alumni

    @msolomon8107 Can you please try manually save a new login via the Safari browser? I did this using "dummy" information and it seems to fill in just fine on this website.

  • Did not work. Did as you suggested, manually created the login, still the same behavior.

  • brentybrenty

    Team Member

    @msolomon8107: I have the same experience that AGMarshall does: 1Password fills the login, submits the form, and I'm taken to the "account validation" page. Maybe if you tell us in more detail what's happening in your case it will shed some light on this.

    Since it sounds like it's working in Firefox, and it's working in Safari for us, I wonder if there might be something going on in Safari specifically on your system. Please make sure that you have Safari's AutoFill feature disabled, as this can conflict with 1Password if they're trying to fill the same form.

    Also, if you have other Safari extensions, disable them and see if that makes a difference. Please let me know what you find. I look forward to hearing back from you! :)

  • Will check this out when I get home on Sunday. Btw also tried same site/login using 1password on the iPhone and same behavior - didn't fill in the username and password.

  • Hi @msolomon8107,

    The issue on your iPhone is for different reasons. We do have a bug report regarding the issues on the iOS platform for websites that use an IFrame for the login components and this site is one of them.

    It might be worth trying to create a login using this URL which is the actual login page embedded in their home page. The URL is:

    https://consumercenter.mysynchrony.com/consumercenter/Login.do

    I think that will work on iOS. Certainly I could fill both the username and password by using that URL instead of their main page just now on my iPhone.

    This is a different issue from the Mac though, Safari on the Mac shouldn't have any trouble filling the home page and like AGMarshall and brenty the quick test I did worked okay for me although like them I was merely testing filling with dummy data. Hopefully we can figure out why it isn't for you :smile:

  • Tried again today, following the instructions to disable autofill, which i did, and then looking at extensions. The only other one i had running was my avast antivirus, and for the test i disabled that. Tried 1password after doing these things, and it did not make a different. Still not filling in the username or password, and still can't even copy the password from 1password and paste it into the password field on the synchrony web site. So not working for me at all.

  • Hi @msolomon8107,

    You won't ever be able to paste your password into that site because they've told the browser not to allow pasting

    onpaste="return false;

    They're working under the misguided notion that this helps with your security while we would humbly disagree.

    I'm genuinely perplexed as to why this site is giving you so much trouble that we can't replicate on a Mac.

    Everything I've tried suggests that Safari 8.0.6 on OS X 10.10.3, running 1Password 5 with extension 4.3.1 should work

    If you click on the show web form details for your Mysynchrony Login item, does it look like this?

    That's what a Login item created with the How to manually save a Login looks like.

  • the web form details look exactly the same. I've already tried the manually save a login route ... no go. at a loss how to proceed

  • did notice one difference. my login does not have the 2nd website listed --- the one that is consumercenter.mysynchrony.com.

  • Hi @msolomon8107,

    I can only assume something is different about your set up, every Login item I save from the browser has both website fields stored without any interaction from myself required. Let's see if a Diagnostic Report can shed some light.

    I would like you to create the following Diagnostic Report please. This guide will assist.

    Please do not post your Diagnostics Report in the forums

    The email address you will want to use is [email protected]

    When sending the diagnostic report to the address above it would help immensely if you could include a link to this thread and your forum handle so we can connect the two.

    Once you've sent the report a post here with the ticket ID will help us to keep an eye out for it. With access to the report we should be able to better assist you :smile:

  • Don't use the apple mail application for email. So it errors when trying to attach report to mail. Any other way to attach it to my mail app (Postbox)?

  • Hi @msolomon8107,

    Step 7. in the guide will help you out there, it shows you how to bypass the Create New Mail Message... button which is hardcoded to Mail. As a Thunderbird user myself I understand your pain.

  • edited June 2015

    thanks. just emailed diagnostic. Came out as zip file. hope that is correct

    ref: HIG-62925-416

  • Hi @msolomon8107,

    That is correct, somebody will be in touch shortly :smile:

    ref: HIG-62925-416

  • thanks

  • per email to restart and see what happens --- no luck ... tried after restarting Mac, no difference. still nothing inserted into fields

  • Steve_JoynerSteve_Joyner Customer Support 1Password Alumni
    edited June 2015

    Hi @msolomon8107,

    I'm Steve. :) Since we're working with you directly via email, there's no need for you to provide updates in this forum.

  • Hi @msolomon8107,

    Steve is right, to reduce the potential for confusion it is best to keep this to one channel of communication. I also suspect we might have reached the limit of what we can easily try in the forums anyway but I'll certainly be keeping an eye on it as I too want to know why a manually saved Login item for you is so different from mine.

    So for now I'm going to close this thread but we will be remaining in contact with you via email.

This discussion has been closed.