Chrome extension won't fill passwords

The past few days, my Chrome extension won't fill in any passwords from 1Password. The Safari extension works, but Chrome won't. I have uninstalled and reinstalled the Chrome extension and still don't see any change. Here is the version of Chrome I'm using. Version 45.0.2438.3 dev (64-bit)

1Password Version: 5.4 beta 20
Extension Version:
OS Version: 10.10.4
Sync Type: Dropbox
KB Article: extension-troubleshooting-ensure-helper-running


  • Hi @CRMFYI,

    When you checked to see what version you were running did you happen to notice if it said you were up to date or if you had updates pending? pending browser updates do something and as a result the extension is shut down. If this is the case simply rebooting Chrome to allow it to finalise the update will resolve the issue.

    If it isn't that I'd ask if you could reboot your system and see if that makes any difference. Sometimes it's amazing what gets gnarled up that a simple reboot can resolve.

    Obviously if neither work please do let us know and we'll continue the troubleshooting :smile:

  • @littlebobbytables ,

    I have both ensured that no Chrome updates are awaiting a browser restart and I've restarted my computer, and neither has seemed to help. I have tried both right clicking on a username field and selecting "1Password" as well as being on the page and using the browser extension button for 1Password. As I say, I can use 1Password just fine in Safari, it is just that it has stopped working in Chrome.


  • Hi @CRMFYI,

    If you click on the 1Password menu icon (not the browser icon) with Chrome active does 1Password suggest you install the Chrome Extension?

    I've confirmed there isn't anything specifically whacky about the combination of the dev version of Chrome and our extension so the next hunch is something Chrome specific is interfering with the communication between the 1Password mini and the Chrome Extension. If that is the case then I would expect 1Password mini to suggest you install the extension even though it already is. I'm not sure how much this page, Troubleshooting communication issues between 1Password and the extension will help as I would suspect most would mean a global issue rather than a specific issue but it's worth ensuring none of it applies as maybe you have a firewall block Google specifically. I was considering proxy settings but unless I'm mistaken Safari and Chrome both use the system settings here. At the very least it eliminates a number of possibilities.

  • @littlebobbytables ,

    Here is what I'm seeing happen. If I'm in either Chrome or Canary (developer Chrome release), clicking on the 1Password Menu icon pauses, does not present my login immediately, but even when it does, clicking it does not pass my username or password into the web page. If I'm in Chrome and do the exact same thing, 1Password immediately shows the login for that web page and clicking it passes my credentials into the web page flawlessly. I highly doubt it's a firewall setting since the same 1Password helper can work in Safari and does not work in Chrome. I uninstalled the 1Password extension for Chrome again and installed it again, ensuring that it would properly connect to 1Password or give me an error message. It installed properly and said "Welcome to 1Password".

    I'm stumped. This is only Chrome related and quite annoying. Any other ideas or more direct troubleshooting of my specific issue would be appreciated.


  • Hi @CRMFYI,

    So clicking on the 1Password Chrome Extension icon does bring up the 1Password mini menu? I apologise as I may have misunderstood the original issue then. That does eliminate firewalls and similar as being an issue as they would block any communication between the browser.

    Now we released a new version of the extension just yesterday. Has the issue improved at all in version of our extension for Chrome? If you're still running you might need to visit Chrome's extension page chrome://extensions and enable Developer mode (top right hand corner of the page) as it will then make a Update extensions now button visible.

    I'm wondering if what you were experiencing was related at all to some timing issues we've been facing with Chrome and that I believe the new version should help with.

    Apologies for any misunderstanding I have have had with your original issue.

  • @littlebobbytables ,

    I restarted Canary, which had a new development build ready to start using. I checked Chrome and Canary and found they were both on 4.40 of the extension, then I tried logging into Wells Fargo, for example. First I tried with right clicking on the username field and using the 1Password option there; it didn't work. I then tried the extension button for 1Password and it again didn't work. I then went to the menubar and used the 1Password feature there and again, it didn't work. To test things further, I opened Safari and tried Wells fargo there and each and every method to log in from Safari worked.

    Any additional help would be appreciated.


  • brentybrenty

    Team Member

    @CRMFYI: Just to clarify, have you tried the stable version of Chrome? I'm simply not able to reproduce the issue there, with either the beta or stable 1Password extension, so it sounds like this problem may be limited to Canary (or possibly other prerelease versions of Chrome). We can support beta versions of 1Password obviously, but other companies' beta software is a bit outside of our purview. Please let me know! :)

This discussion has been closed.